Contribute
Register

[solved] ACPI exceptions and errors with recompiled DSDT on GA-Z170X-Designare

Status
Not open for further replies.
Joined
Jun 20, 2013
Messages
15
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
GeForce GTX 750 Ti | Intel HD530
Mobile Phone
  1. iOS
It means you need to re-extract, not just disassemble.
You need to re-extact/re-patch after any of the following:
- BIOS updates
- BIOS option changes
- hardware changes

No reason to "move all patches" to ACPI/patched. It is better to accomplish patches via Clover if possible (for the reason stated above regarding re-extract/re-patch as it relates to SystemMemory address mobility).
Ok, problem source identified. After initial ACPI tables dump I installed WiFi PCI-E adapter which caused mentioned SystemMemory addresses to change. Indeed, it looks like Clover way will be more stable. Thank you very much, do you accept PayPal donations?
 
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have basically the same hardware, and the bios time is different on my mobo bios as well. Can you post a guide to exactly the steps you took to correct the problem?
 
Joined
Jun 20, 2013
Messages
15
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
GeForce GTX 750 Ti | Intel HD530
Mobile Phone
  1. iOS
I have basically the same hardware, and the bios time is different on my mobo bios as well. Can you post a guide to exactly the steps you took to correct the problem?
It looks like the BIOS/UEFI time is in UTC, while the macOS one is in your timezone. If you try to adjust the BIOS time, during next time sync macOS will revert it back to UTC.
 
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ok, problem source identified. After initial ACPI tables dump I installed WiFi PCI-E adapter which caused mentioned SystemMemory addresses to change. Indeed, it looks like Clover way will be more stable.

Yeah, that has been my experience - how do I re-extract and repatch using clover?
Im having a lot of trouble getting the x86PlatformPluginInjector to stick and maybe this is why.
 
Joined
Jun 20, 2013
Messages
15
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
GeForce GTX 750 Ti | Intel HD530
Mobile Phone
  1. iOS
Yeah, that has been my experience - how do I re-extract and repatch using clover?
Im having a lot of trouble getting the x86PlatformPluginInjector to stick and maybe this is why.
If I'm not wrong, you don't need to extract anything if you'll do the ACPI patching via Clover.
I doubt the problem with x86PlatformPluginInjector is caused by BIOS/macOS time mismatch. The only problem I've encountered due to wrong BIOS time was when for some reason a 2041 year was set and macOS couldn't boot as well as clean installation couldn't finish due to some security signature check fail.
 
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ok- thanks! I've been chasing a kernel panic around my machine for months, now, every little bit helps!
 
Joined
Jun 20, 2013
Messages
15
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
GeForce GTX 750 Ti | Intel HD530
Mobile Phone
  1. iOS
Ok- thanks! I've been chasing a kernel panic around my machine for months, now, every little bit helps!
I've attached my current Clover folder (using 10.12.4). Hope it will help you.
 

Attachments

  • CLOVER.zip
    1.8 MB · Views: 72
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thank you, but I don't see the attachment!
 
Joined
Jun 20, 2013
Messages
15
Motherboard
Gigabyte GA-Z170X-Designare
CPU
Intel i7 6700K
Graphics
GeForce GTX 750 Ti | Intel HD530
Mobile Phone
  1. iOS
Joined
Jul 9, 2015
Messages
33
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Cool, got it thanks. Are you using the x86PlatformPluginInjector?
I don't see where your loading it - Would you mind taking a look at mine and seeing if there is anything out of place that might be blocking it, since we have the same hardware?
I noticed you were using some CustomUUID strings, does that allow iMessages to work? I currently have all that stuff working, but I'm wondering if that compromised some other important things.
Thanks!
 

Attachments

  • config.plist
    9.3 KB · Views: 217
Status
Not open for further replies.
Top