Contribute
Register

[Solved] Accidentally erased config.plist in clover config -- can't boot to restore from Sierra USB

Joined
Jul 20, 2017
Messages
7
Motherboard
Gigabyte z270
CPU
7700k
Mac
  1. Mac Pro
New to the forum, so let me know if this needs to be moved or changed. Performed many searches before taking a deep breath and making this post.

Had my build working beautifully, except could not get newly-installed kexts to show up in config.plist (working on half-mini pci-e fix via RehabMan). After a few fails, turned to clover configurator and tried to make edits to kextstopatch. Saved changes and ended up with a blank config.plist. Thought I could use Sierra USB to restore or install over existing install with blank config.plist. Now, can't boot at all. A similar thread posted in October 2016 recommended booting without loading caches, but that option seems no longer available in the latest clover. Any ideas?
 
Last edited:

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
4,963
Motherboard
Gigabyte Z390M Gaming - Clover 5102
CPU
i5-9600K
Graphics
RX 570 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. Android
New to the forum, so let me know if this needs to be moved or changed. Performed many searches before taking a deep breath and making this post.

Had my build working beautifully, except could not get newly-installed kexts to show up in config.plist (working on half-mini pci-e fix via RehabMan). After a few fails, turned to clover configurator and tried to make edits to kextstopatch. Saved changes and ended up with a blank config.plist. Thought I could use Sierra USB to restore or install over existing install with blank config.plist. Now, can't boot at all. A similar thread posted in October 2016 recommended booting without loading caches, but that option seems no longer available in the latest clover. Any ideas?

What I would try ...

1) If you are happy using the "Terminal" app -

The config.plist on your UniBeast stick should work. Copy it over the blank one on your hard-drive. That should get you booted.

Or maybe ...

2) Find a config.plist here that has been uploaded by a builder with a similar spec machine. It won't be perfect by any means but it might get you booted to a desktop and enable you to do proper configuration there. Worth trying.

Yes, you can boot without drivers and caches. When the drive selection menu comes up, press any key to bring up the command-line switches (I use Spacebar).

:)
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,514
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
A similar thread posted in October 2016 recommended booting without loading caches, but that option seems no longer available in the latest clover. Any ideas?
To boot without caches: At Clover Boot Screen select Options and add -f to Boot Args
 
Joined
Jul 20, 2017
Messages
7
Motherboard
Gigabyte z270
CPU
7700k
Mac
  1. Mac Pro
Thank you for the replies UtterDisbelief and BreBo.
@UtterDisbelief Unfortunately, I can't seem to boot from USB either, not even when choosing it from BIOS boot menu. In this case, boot just hangs at Apple logo with progress bar stuck at zero. Due to that, I can't get to Terminal & try your suggestion

@BreBo Thank you. I can add the command, but no change in outcome.

Still unable to boot from HDD, USB, or Recovery even without caches
One weird thing is some boot args from the erased config.plist seem to have been preserved. nv_disable=1, for example, is still there... Very new to this so sure I'm missing something here
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
4,963
Motherboard
Gigabyte Z390M Gaming - Clover 5102
CPU
i5-9600K
Graphics
RX 570 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. Android
Thank you for the replies UtterDisbelief and BreBo.
@UtterDisbelief Unfortunately, I can't seem to boot from USB either, not even when choosing it from BIOS boot menu. In this case, boot just hangs at Apple logo with progress bar stuck at zero. Due to that, I can't get to Terminal & try your suggestion

@BreBo Thank you. I can add the command, but no change in outcome.

Still unable to boot from HDD, USB, or Recovery even without caches
One weird thing is some boot args from the erased config.plist seem to have been preserved. nv_disable=1, for example, is still there... Very new to this so sure I'm missing something here

Well, if you can see the Apple logo then you have got past the Clover boot menu and into Apple territory. Can you use the "-v" command-line? Just press the Spacebar when at the Clover drive menu and select it from the options.

This is Verbose mode and should give you a screen of scrolling text. That might tell us where the boot problem is...

Another good one is "-x" for safe-mode which will load no extra drivers.

:)
 
Joined
Jul 20, 2017
Messages
7
Motherboard
Gigabyte z270
CPU
7700k
Mac
  1. Mac Pro
Well, if you can see the Apple logo then you have got past the Clover boot menu and into Apple territory. Can you use the "-v" command-line? Just press the Spacebar when at the Clover drive menu and select it from the options.

This is Verbose mode and should give you a screen of scrolling text. That might tell us where the boot problem is...

Another good one is "-x" for safe-mode which will load no extra drivers.

:)
Here is a screen of verbose readout when trying safe-mode boot from USB
My untrained eye sees "Kext com.apple.kec.Libm failed to load"
IMG_0001.jpg
IMG_0001.jpg
 
Joined
Jul 20, 2017
Messages
7
Motherboard
Gigabyte z270
CPU
7700k
Mac
  1. Mac Pro
Was able to alter config.plist from another mac and have booted correctly. Thanks to you guys for your help. Now, if only I could learn how to install kexts properly :)

Have a great weekend
 
Top