Contribute
Register

[SOLVED]5870 fail: black screen, continuous beep fans at max

Status
Not open for further replies.
Joined
Apr 21, 2011
Messages
79
Mac
Classic Mac
Mobile Phone
Hi All!

I successfully installed clean 10.6.0 OS X on my P8P67-B3 + 2600K + MSI Lightning R5870 build, but I can't either upgrade to 10.6.7 or use ATI drivers from Multibeast.
I tried to follow this guide: viewtopic.php?f=79&t=16873 (basically it suggests running BridgeHelper and Multibeast right after updating to 10.6.7, but prior to system restart), and it fails after restart. If I set GraphicsEnabler=Yes, then upon starting from my Snow Leopard partition I get black screen with continuous beep and (GPU?) fans at maximum RPMs. When during beeping I've tried to adjust CPU fan to lower RPMs with a knob at the back of my case to check whether it's CPU or GPU fans has started, I've heard the second beeper simultaneously, which beeped one long and at least 3 short beeps (I powered off the system immediately before I could count how much beeps there were). This behavior is reproduced with GraphicsEnabler=Yes in any case, no matter which version of ATI drivers I install (I tried Chameleon with Experimental ATI support, ATI drivers package from Multibeast or just vanilla 10.6.7 kernel).
It boots ok with GraphicsEnabler=No on 10.6.0 kernel (though the mouse is laggy and no sound); on 10.6.7 it doesn't boot even with GraphicsEnabler=No, hanging somewhere around the text

waiting for DSMOS
AppleIntelCpuPowerManagement timed out
DSMOS has arrived

I tried resetting CMOS and downgrading BIOS (btw my 1502 bios revision for P8P67-B3 is not found anywhere on ASUS site, it has only older versions), but no luck.
Is there really an extra beeper somewhere on GPU besides system speaker? What does this sound mean? Does it mean its dangerous to do more tries to start the system that way? Is it possible that it's an incompatibility of all MSI Lightning R5870 model, or it's just my card/setup?
What else can you suggest to enable native support with this card?

Thank you!

PS The system was on default bios settings, no overclocking, SATA set to AHCI. The graphics card seems to be working ok under Windows 7.
 
Joined
Apr 21, 2011
Messages
79
Mac
Classic Mac
Mobile Phone
Re: 5870 fail: black screen, continuous beep, fans at maximum

Finally I've got it working with 10.6.7 by running a package from Andy's CD for P8P67 PRO as described here (with the only difference that I ran package right after Multibeast and before restart, not after):
http://tonymacx86.com/viewtopic.php?f=79&t=16873
Probably, it's a different version of Chameleon that makes difference.
I can't use GraphicsEnabler=Yes, since it still gives the same beeping effect with either bootloader version.
Now everything seems to work well (including StarCraft 2), however, my 5870 gets recognized as "Radeon 5000", and I can't run Geekbench. Same symptoms as described here: viewtopic.php?f=15&t=15798 , but that solution with patching DSDT to add either Vervet or Duckweed framebuffer didn't work for me :(

Any suggestions on how to properly patch DSDT for MSI Lightning 5870 on P8P67?
Does anyone have correct DSDT for P8P67 and 5870?
 
Joined
Nov 16, 2010
Messages
2,639
Motherboard
AsRock Z370M ITX/ac
CPU
i7-8700K
Graphics
AMD 5700XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Re: 5870 fail: black screen, continuous beep, fans at maximum

The framebuffers "Uakari", "Hoolock" and "Zonalis" are used for 5870's. If you install Andy's bootloader (ATI Package) from my guide in my signature, you can just set GraphicsEnabler=Yes and all should be well.
 
Joined
Apr 21, 2011
Messages
79
Mac
Classic Mac
Mobile Phone
Re: 5870 fail: black screen, continuous beep, fans at maximum

Gordo74 said:
The framebuffers "Uakari", "Hoolock" and "Zonalis" are used for 5870's. If you install Andy's bootloader (ATI Package) from my guide in my signature, you can just set GraphicsEnabler=Yes and all should be well.

Gordo, thank you so much!!! Andy's bootloader with AtiConfig=Uakari did the trick, now everything is working!
 
Joined
Nov 16, 2010
Messages
2,639
Motherboard
AsRock Z370M ITX/ac
CPU
i7-8700K
Graphics
AMD 5700XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Re: 5870 fail: black screen, continuous beep, fans at maximum

drcrack said:
Gordo74 said:
The framebuffers "Uakari", "Hoolock" and "Zonalis" are used for 5870's. If you install Andy's bootloader (ATI Package) from my guide in my signature, you can just set GraphicsEnabler=Yes and all should be well.

Gordo, thank you so much!!! Andy's bootloader with AtiConfig=Uakari did the trick, now everything is working!
:thumbup:

You can add that line permanently to the boot.plist so you dont have to type it in everytime too :D
 
Status
Not open for further replies.
Top