Contribute
Register

[Solved] 10.15.1, updated kexts, pastrychef-verified EFI, 5700XT freezes in OS

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,362
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Check your memory and CPU use at the time that this happens.
Please update your profile to include CPU, motherboard, and GPU that you are using.
 
Joined
Sep 11, 2019
Messages
138
Motherboard
ASUS ROG STRIX z390-E Gaming
CPU
i9-9900K
Graphics
5700 XT
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
I used @ModMike recommendations when setting up the BIOS for working with discrete graphics. They are in the topic Z390-I.
I'm quite familiar, I was running his EFI until this new board. Maybe I should just bust out the z390-i tomorrow and see if I can get it running on that. I've been suspicious of this board the whole effing time.
 
Joined
Nov 21, 2017
Messages
27
Motherboard
ASUS PRIME Z270-A
CPU
i7-7700K
Graphics
RX 580
Mac
iMac
So as I understand RX 5700XT does work and fully functional with IGPU enabled then.
 
Joined
Sep 11, 2019
Messages
138
Motherboard
ASUS ROG STRIX z390-E Gaming
CPU
i9-9900K
Graphics
5700 XT
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
I'm stress testing it with the EFI from @iDrakus right now. To be quite clear - it will not work if you go into the bios, enable IGPU and reboot. You have to go back into the bios after saving the bios, so it exposes the additional settings. It has to have the 128MB set and the RC6 standby disabled for it to function correctly. I froze damn near immediately without re-saving for those changes. I've completed geekbench cpu and gpu testing since saving the bios again and i'm onto others.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,362
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
So as I understand RX 5700XT does work and fully functional with IGPU enabled then.
Yes.

Since you are using Z270 motherboard, you probably don't need EmuVariableUefi in /EFI/CLOVER/drivers/UEFI/.

Please try removing it. If it works, you should get kernel panic logs if/when you get a kernel panic. This will go a long way to helping figure out what's the cause of your crashes.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,383
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Yes. That's good. You have IGPU enabled. I was told IGPU needed to be disabled for 5700 XT to work. I guess that was wrong.
Have you seen the system report? Is this just Hackintool listing the CPU IGPU standard. I did a bit of testing and could only get IGPU enabled to work by spoofing the ID 12345678 so it did t have metal.
 
Joined
Sep 11, 2019
Messages
138
Motherboard
ASUS ROG STRIX z390-E Gaming
CPU
i9-9900K
Graphics
5700 XT
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
Nope. Froze again. Screw it. I'm going to bed and swapping the board out for the z390-i tomorrow and will test that configuration. The ONLY difference between what @iDrakus and I are running is the board itself.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,362
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Have you seen the system report? Is this just Hackintool listing the CPU IGPU standard. I did a bit of testing and could only get IGPU enabled to work by spoofing the ID 12345678 so it did t have metal.
iDrakus and piano08man both have booted in to macOS with IGPU enabled and with iMac19,1.
 
Top