Contribute
Register

[Solved] 10.15.1, updated kexts, pastrychef-verified EFI, 5700XT freezes in OS

Joined
Mar 25, 2019
Messages
7
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9 9900KF
Graphics
RX 5700
Mac
Mac Pro
Mobile Phone
Android

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,420
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,420
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
This Config worked for ASUS Z390-i.


However, I would like to use my own Config, since it works 100% with my motherboard.

Here is my:
Your config.plist uses iMac19,1. It's better to use iMacPro1,1 because IGPU has to be disabled to use 5700 XT.
 
Joined
May 31, 2013
Messages
228
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
My Sapphire RX 5700 XT Pulse good work macOS 10.15.1 Final.
I use motherboard ASUS ROG STRIX Z390-I Gaming + CPU Intel Core i9 (9900K)

Снимок экрана 2019-11-03 в 08.22.20.png
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,420
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
For you folks who are tagging in, here is the updated EFI with the bootable config.plist. We are still troubleshooting stability issues - my 5700xt freezes after a few minutes in the OS. If anyone has fixed this on 10.15.1 with whatevergreen 1.3.4, I would love to know the solution. The decoder doesn't seem to be supported without using iMacPro1,1 - or so is my current observation.

My specs: 9700K, ASUS z390-E gaming, Sapphire Pulse 5700XT.

If you are asking for help in this thread for hardware unrelated to the 5700XT, this is not the place for it. If you're having graphical issues related to the 5700XT, please hang around and let us know what steps you've tried to make it work correctly. Thanks!

Obviously, if you aren't using that mobo, your steps to get to this point could be wildly different.
Are you sure your stability problems are related to 5700 XT and not CPU or RAM?
 
Joined
May 31, 2013
Messages
228
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
Your config.plist uses iMac19,1. It's better to use iMacPro1,1 because IGPU has to be disabled to use 5700 XT.
Perhaps you are right, but if everything works, is it worth changing something?

I have a 9900K processor, and it is in the iMac 19.1. Therefore, I use it.
 
Joined
Sep 11, 2019
Messages
138
Motherboard
ASUS ROG STRIX z390-E Gaming
CPU
i9-9900K
Graphics
5700 XT
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
Perhaps you are right, but if everything works, is it worth changing something?

I have a 9900K processor, and it is in the iMac 19.1. Therefore, I use it.
Have you verified via hackintool that the VDA Decoder is fully supported?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,420
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Got that fixed and working, thank you. It would be nice to find out what is the exact issue that is causing the boot to hang on this card.
You are still getting hangs at boot??

For piano08man, I forgot to enable some items in config.plist > Kernel and Kext Patches section. That has been resolved and booting should be good now.
 
Top