Contribute
Register

[Solved] 10.15.1, updated kexts, pastrychef-verified EFI, 5700XT freezes in OS

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,929
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I have Asus Z270A, so I set my Internal Graphics Mode to PEG, I am assuming that is the same thing. I'm gonna try changing to HDMI and see if that helps.
Primary display should be set to PEG. Enable multi monitor to enable IGPU.

Try launching Hackintool to see if it says VDA Decoder Fully Supported.
 
Joined
May 31, 2013
Messages
382
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
I cannot boot from my RX 5700 XT. I updated the clover, the kexts, the argument, but I always get errors when loading. What is the problem?

iGPU Bios Enabled

F4EEB151-8BE9-449A-8F3E-99A7D05FD539.jpeg

87629FA6-51E1-4070-BD3E-7D6099C22704.jpeg
 
Joined
Nov 21, 2017
Messages
27
Motherboard
ASUS PRIME Z270-A
CPU
i7-7700K
Graphics
RX 580
Mac
iMac
Primary display should be set to PEG. Enable multi monitor to enable IGPU.

Try launching Hackintool to see if it says VDA Decoder Fully Supported.
It does say decoder failed. Should I switch back to iMacPro to fix that?
 
Joined
Sep 11, 2019
Messages
138
Motherboard
ASUS ROG STRIX z390-E Gaming
CPU
i9-9900K
Graphics
5700 XT
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
Yes i do same results after making lot of strugle i figured out to get the card working without any glitches
Would you care to share? I have the card booting into the OS and fully supported - but I'm still freezing after a few minutes. Definitely seems video related at this point. What did you do to get it "working without any glitches?"
 
Joined
Sep 11, 2019
Messages
138
Motherboard
ASUS ROG STRIX z390-E Gaming
CPU
i9-9900K
Graphics
5700 XT
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
It does say decoder failed. Should I switch back to iMacPro to fix that?
I had to leave mine as iMacPro for it to keep the decoder supported - as soon as i switched to imac19,1 - which is my processor equivalent, it said decoder failed.
 
Joined
Nov 21, 2017
Messages
27
Motherboard
ASUS PRIME Z270-A
CPU
i7-7700K
Graphics
RX 580
Mac
iMac
OMG... so many people hijacking the thread.
We are all having the same problem with the 5700xt being stuck, and something with this config fixes the issue. If that solution can be isolated that would be helpful for everyone, and your problem as well.
 
Joined
Sep 11, 2019
Messages
138
Motherboard
ASUS ROG STRIX z390-E Gaming
CPU
i9-9900K
Graphics
5700 XT
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
This Config worked for ASUS Z390-i.


However, I would like to use my own Config, since it works 100% with my motherboard.

Here is my:
Ha, well, good luck - we haven't been able to get it working with anything but this config yet. :)
That is the problem here, I d

We are all having the same problem with the 5700xt being stuck, and something with this config fixes the issue. If that solution can be isolated that would be helpful for everyone, and your problem as well.
We've been trying to get the config working properly for days. Have some patience. I doubt we'll have it fixed tonight. :)
 
Top