Contribute
Register

[Solved] 10.13.2 update problem

Status
Not open for further replies.
Joined
Mar 6, 2012
Messages
24
Motherboard
GA-Z97X Gaming 3
CPU
i7 4790k
Graphics
ASUS AMD Radeon Vega 56 Strix OC
Hi,
I don't get the update completed. I first tried to simply update from AppStore (as it worked always before), after the automatic reboot the MacOS Install entry appeared in clover boot menu but it get stuck in Apple Boot Screen. Thanks lord the Mac OS High Sierra Boot entry worked as before and booted into 10.13.1. Then I tried to download the update from Apple and installing it after removing the /macOS Install Data folder, reboot and replace the apfs.efi (with this from here: https://www.tonymacx86.com/tmx/apfs.efi-10.13.2.zip) in /Volumes/EFI/EFI/Clover/drivers64UEFI with same result: get stucked in Apple boot screen after choosing MacOS Install in Clover boot menu. Both times I waited > 10 mins. Could anybody help to complete the update please?!
Thanks in advance!
 
Last edited:
Joined
Jan 15, 2011
Messages
65
Motherboard
Gigabyte Z68X-UD3H-B3
CPU
i7-2600K
Graphics
GTX 650
Mac
  1. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hey heckenhugo! I'm on an older system (Z68) and my update is stuck as well. I too have tried to delete "MacOS Data" folder from terminal and reboot and reinstall the update and combo update and neither worked for me.
 
Joined
Sep 5, 2012
Messages
5
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
Intel Core i7-3770K @ 4.2GHz
Graphics
NVIDIA GeForce GTX680
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
Hi,

I had the same problem - stuck in endless install reboots...
What I did was:
  • Boot to 10.13.1 with the "old" configuration
  • Mount EFI partition of boot drive
  • updated FakeSMC.kext to version 6.26-322-xxxxxxx (EFI partition CLOVER/kext/10.13)
  • updated apfs.efi (EFI partition CLOVER/drivers64UEFI)
  • removed everything from EFI partition CLOVER/kext/Other, all kexts are in CLOVER/kext/10.13
  • removed the install data dir on system drive (macOS Install data)
Reboot and the old 10.13.1 system still works and the macOS install option in Clover boot menu is gone
  • Mount EFI partition of boot drive
  • copy FAKESMC.kext to EFI partition CLOVER/kext/Other)
  • updated Lilu.kext to version 1.2.1 (EFI partition CLOVER/kext/10.13)
  • copy the new Lilu.kext to EFI partition CLOVER/kext/Other)
  • run the updater to 10.13.2 macosupd10.13.2.dmg
Reboot and choose macOS install option in Clover boot menu and the update works
 
Joined
Mar 6, 2012
Messages
24
Motherboard
GA-Z97X Gaming 3
CPU
i7 4790k
Graphics
ASUS AMD Radeon Vega 56 Strix OC
Tyvm, beppo: putting the FakeSMC.kext into both directories (Other and 10.13) did the trick. I didn't use lilu before so I skipped this step...
 
Joined
Feb 29, 2012
Messages
6
Motherboard
GA-Z270MX-GAMING5
CPU
i7 7700
Graphics
GeForce GT640 2048 MB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Tyvm, beppo: putting the FakeSMC.kext into both directories (Other and 10.13) did the trick. I didn't use lilu before so I skipped this step...

This worked for me, however i HAD to use the combo updater, the app store was no go.....
 
Status
Not open for further replies.
Top