Contribute
Register

[SOLUTION!] Asus P8Z77-V LX no audio in El Capitan

Status
Not open for further replies.
Joined
May 15, 2011
Messages
235
Motherboard
ASrock z370 Fatal1ty Gaming mini-ITX/ac
CPU
Intel Core i7 8700K @ 3.7GHz (4.7GHz Turbo)
Graphics
Intel UHD630/Gigabyte GTX 1070 Mini ITX
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
So, I recently installed El Capitan using UniBeast. Everything went surprisingly smoothly. Audio was giving me constant static though, which annoyed me quite a bit. It turned out that somehow, I have no freaking clue how, UniBeast had installed VoodooHDA on the system. I spent quite a while searching for the kext files and finally found and deleted them, including the voodoo pref pane and app.

After that of course I had no audio. Native HDA didn't work. Patched native HDA didn't work. I tried every possible method listed on this site and other sites. I tried many, many times. Lost count. Almost lost my mind. As a last effort I tried to install audio with the Mavericks MultiBeast 6.1. This didn't work, because it is designed for Mavericks, so no El Capitan support.

But then I figured I could extract the kexts I want with Pacifist and install them with kextWizard. And so I did. I also copied the kexts to EFI/Clover/Kexts. And IT WORKED! I now have perfect, non-static audio. Even the microphone works. It captures very quiet audio, but at least it works. That's all I care at this point.

So, if you have this motherboard (Asus P8Z77-V LX) and you install El Capitan with UniBeast and do not have audio, try this:

• Make sure you have no other audio kexts installed.
• Make sure your Clover has audio device 1 injected and rootless=0 as boot flag.
• Download Mavericks MultiBeast 6.1. Go to MultiBeast App file -> Show Package Contents -> Contents -> Resources.
• Select AppleHDA-887_v100302.pkg and HDAEnabler1.pkg and copy them to Desktop (for example).
• Use Pacifist app to open these packages, then extract the kexts (they look like folders) to Desktop.
• Use kextWizard, or any other kext installation tool to install those kexts to System/Library/Extensions/. Also copy the same kexts to your EFI partition EFI/Clover/Kexts/10.11/.
• Repair permissions and Rebuild Cache with your kext tool, then reboot.
• Cross your fingers and hope that it works! It did for me.
• Select Internal Speakers as the audio output device in System Preferences.

Now you are done! Enjoy clear, static free audio.

Edit: Use Mavericks MultiBeast, not Yosemite.
 
Joined
May 15, 2011
Messages
235
Motherboard
ASrock z370 Fatal1ty Gaming mini-ITX/ac
CPU
Intel Core i7 8700K @ 3.7GHz (4.7GHz Turbo)
Graphics
Intel UHD630/Gigabyte GTX 1070 Mini ITX
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
To be frank, all the HDA guides are quite difficult to follow. They could be simplified. As could this guide, I'm sure. P8Z77-V LX should be listed as an unsupported mobo right off the bat to avoid any wasted effort.

Simple step by step guide = better results.
 
Joined
Sep 11, 2015
Messages
16
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Thank you so much it worked like a CHARM !!

Just had to remove the Clover injection for previous HDA enabler that I installed with audo_CloverALC (the kexts were not in my 10.11 folder inside the EFI partition).

Thank you again!!
 
Joined
May 15, 2011
Messages
235
Motherboard
ASrock z370 Fatal1ty Gaming mini-ITX/ac
CPU
Intel Core i7 8700K @ 3.7GHz (4.7GHz Turbo)
Graphics
Intel UHD630/Gigabyte GTX 1070 Mini ITX
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
That's great! Glad this solution helped. :)

I heard that the newest multibeast should have the working drivers for this motherboard, but the description says it is the same alc patch method, so I wouldn't count on it. For now, we are stuck with manual install/reinstall after sysytem updates.
 
Status
Not open for further replies.
Top