Contribute
Register

<< Solved >> Solarflare SFN5122F Mac OS Driver not more available

Joined
Jun 20, 2013
Messages
21
Motherboard
Gigabyte Aorus Z490 Elite AC
CPU
10700k
Graphics
Sapphire Radeon 6900xt SE
Anyone try them in Catalina yet?
 
Joined
Mar 21, 2011
Messages
90
Motherboard
ASUS Prime Z390-A bios 1402
CPU
8700K
Graphics
5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
I just tried now, both the signed and unsigned version of the driver PKG.

Unsigned wouldn't even start. Signed started to install, and then threw an error saying "This is from an untrusted source" and quit.

I have a second machine where I started out with Mojave and upgraded to Catalina -- The drivers appear to be working fine on that machine.

Does anyone know how I can manually transfer/install the drivers from Mojave machine > Catalina machine?
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,558
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I just tried now, both the signed and unsigned version of the driver PKG.

Unsigned wouldn't even start. Signed started to install, and then threw an error saying "This is from an untrusted source" and quit.

I have a second machine where I started out with Mojave and upgraded to Catalina -- The drivers appear to be working fine on that machine.

Does anyone know how I can manually transfer/install the drivers from Mojave machine > Catalina machine?

Maybe look at Hackintool app and disable gatekeeper?
 
Joined
Mar 21, 2011
Messages
90
Motherboard
ASUS Prime Z390-A bios 1402
CPU
8700K
Graphics
5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Good news!

I was able to copy the Solarflare kext off of my Mojave machine and simply added it to /EFI/CLOVER/kexts/Other folder on my Catalina install. After a reboot I now see two extra Ethernet ports that I didn't have before. Unfortunately, I don't have my 10GbE network fully setup yet so this is not tested. But in theory, it's working.

Here's the .kext file if you'd like to try it out yourself.
 

Attachments

  • Solarflare10GbE.kext.zip
    239.6 KB · Views: 544
Joined
Jun 20, 2013
Messages
21
Motherboard
Gigabyte Aorus Z490 Elite AC
CPU
10700k
Graphics
Sapphire Radeon 6900xt SE
My Solarflare card is still working after an upgrade to Catalina. But I am getting some instances from a cold boot where I'm not getting an ip address and therefore no network connection. After a reboot or 2 it works again. Also running the installer for the driver seems to get it working again as well. Not quite sure what's going on and haven't had any time to look into it. Even when it doesn't "work" the system still sees the card and ethernet interface. Only started happening under Catalina. I used it under Mojave for about a year with no issues.
 
Joined
Jul 24, 2011
Messages
4
Motherboard
Z390 Designare
CPU
i9 9900k
Graphics
Vega
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
My 10Gbe SFP+ has been working fine with these drivers up to Catalina 10.15.2
However, i just updated to 10.15.3 and they no longer work. SFP+ card still recognized but no green light, no active connection. Looked in Apple kexts and the Solarflare driver is still the same version as before
 
Joined
Jun 1, 2014
Messages
12
Motherboard
ASUS Z370-A Prime
CPU
i7-8770K
Graphics
5700XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Good news!

Here's the .kext file if you'd like to try it out yourself.

Good News indeed! Thank you so much for uploading the kext, as I was in the same situation not being able to install the "untrusted" package.

copying the .kext into the EFI/CLOVER/kexts/other worked like a charm, thank you again! (Y)
 
Joined
Mar 10, 2020
Messages
1
Motherboard
Mac Pro (Mid 2010)
CPU
2 x 3,46 GHz 6-Core Intel Xeon
Graphics
Radeon RX 580 8 GB
Thank you all for the great info.
I've tried installing both the signed and the unsigned driver on my MacPro Mojave fresh install.
Unfortunately at the end of installing the signed, it says that the install has failed and I need to contact the developer.

So I tried to manually copy the kext file to "EFI/CLOVER/kexts/" but I can't open it via "Go to folder".
Could any one please help me ho I would "open" the folder?


Edit:
Btw I have a MacPro, so would the kext then go to:
/System/Library/Extensions


Thank you!
 
Last edited:
Joined
Apr 21, 2020
Messages
1
Motherboard
MacBook Pro
CPU
8850H
Graphics
Radeon RX 480
Mac
  1. MacBook Pro
I have recently installed drivers for Solarflare SFN5122F on a MacBook. For anybody doing the same here are the steps required:
  • Disable System Integrity Protection by booting into recovery using Command+R and running csrutil disable, ( detailed info: https://developer.apple.com/library/archive/documentation/Security/Conceptual/System_Integrity_Protection_Guide/ConfiguringSystemIntegrityProtection /ConfiguringSystemIntegrityProtection.html#//apple_ref/doc/uid/TP40016462-CH5-SW1 )
  • Mount dmg image with driver (I used version 3.3.4 from "SF-111621-LS-1-Solarflare OS X Driver Package _OS X 10.9 - Signed_.dmg". Sha 256 of this dmg should be 024643f3842a6da4b12651e62aa6fff8afbf8c4558a30b41b690e3616eed0b3b)
  • There will be "Solarflare10GbE.pkg" in the mounted image, right click on it and select "Show Package Contents"
  • Copy "Archive.pax.gz" file from "Content" in the package to any temporary location (e.g. desktop)
  • Extract contents of "Archive.pax.gz" and copy kext "Library/Extentions/Solarflare10GbE.kext" from "Archive.pax" to "/Library/Extentions/" on your system drive
  • Change permission of the kext to root using command "sudo chown -R root:wheel /Library/Extensions/Solarflare10GbE.kext"
  • Trigget kext cache update using "sudo touch /Library/Extensions/"
  • Reboot system and check the card is working, you can see details of any problems by looking at "Solarflare10GbE.kext" info in "Extension" section in "System Information"
  • Enable back System Inegrity Protection by running csrutil enable in recovery mode. After enabling System Integrity Protection you will need to confirm the kext is trusted in "General" tab of "Security & Privacy" in "System Preferences"
 
Joined
Mar 8, 2020
Messages
103
Motherboard
Asus ProArt X570-CREATOR WIFI
CPU
Ryzen 9 3900X
Graphics
RX 5700 XT
I have recently installed drivers for Solarflare SFN5122F on a MacBook. For anybody doing the same here are the steps required:
  • Disable System Integrity Protection by booting into recovery using Command+R and running csrutil disable, ( detailed info: https://developer.apple.com/library/archive/documentation/Security/Conceptual/System_Integrity_Protection_Guide/ConfiguringSystemIntegrityProtection /ConfiguringSystemIntegrityProtection.html#//apple_ref/doc/uid/TP40016462-CH5-SW1 )
  • Mount dmg image with driver (I used version 3.3.4 from "SF-111621-LS-1-Solarflare OS X Driver Package _OS X 10.9 - Signed_.dmg". Sha 256 of this dmg should be 024643f3842a6da4b12651e62aa6fff8afbf8c4558a30b41b690e3616eed0b3b)
  • There will be "Solarflare10GbE.pkg" in the mounted image, right click on it and select "Show Package Contents"
  • Copy "Archive.pax.gz" file from "Content" in the package to any temporary location (e.g. desktop)
  • Extract contents of "Archive.pax.gz" and copy kext "Library/Extentions/Solarflare10GbE.kext" from "Archive.pax" to "/Library/Extentions/" on your system drive
  • Change permission of the kext to root using command "sudo chown -R root:wheel /Library/Extensions/Solarflare10GbE.kext"
  • Trigget kext cache update using "sudo touch /Library/Extensions/"
  • Reboot system and check the card is working, you can see details of any problems by looking at "Solarflare10GbE.kext" info in "Extension" section in "System Information"
  • Enable back System Inegrity Protection by running csrutil enable in recovery mode. After enabling System Integrity Protection you will need to confirm the kext is trusted in "General" tab of "Security & Privacy" in "System Preferences"
Thanks @chig00!

I can confirm this solution still works on 10.15.4 & 10.15.5 with OpenCore.

The solution from post #14 only works with Clover.

Thanks!
 

Attachments

  • Screenshot 2020-05-24 at 22.44.53.png
    Screenshot 2020-05-24 at 22.44.53.png
    810.5 KB · Views: 287
Last edited:
Top