Contribute
Register

SMBios 19.x - iMacs 2019

Joined
Dec 19, 2016
Messages
87
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
what you did because nvram native did not work
BIOS 1801 and native NVRAM working without EmuVariableUefi-64.efi and .rc scripts.
 
Joined
May 5, 2019
Messages
20
Motherboard
ASUS Z370A
CPU
i7-8700k
Graphics
RX580 Nitro+
I would be very grateful if you could help me achieve the same low power consumption and temperature on my RX 580 Nitro+. I'm running 10.14.5 with smbios 19,1.
...
I'll keep an eye on the temperature now. Currently 43 but is hasn't settled yet I think.
Trying Orinico now, and can see it's loaded in ioreg. Also dGPU reports as 'AMD RADEON RX 580' instead of 'RADEON RX 580' in About / System Report. Also videoproc lists this dGPU instead of HD 630, when using Orinoco.

Temperature on dGPU still settle around 50 degrees celcius during normal browsing / light use (browser open), as before. Cannot get it lower. Would like to.
 
Joined
Oct 6, 2013
Messages
12
Motherboard
Asus Maximus XI Hero
CPU
i9-9900k
Graphics
Vega 64
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Does working native NVRAM mean that it doesn't hang on reboot at all?Mine boots fine without EmuVariableUefi + rc, but reboot or shutdown hangs. Is there any tip on this symptom?
 
Joined
Mar 30, 2013
Messages
144
Motherboard
Asus Prime Z370-A
CPU
i7-8700K
Graphics
RX 590
Mac
MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
I switched to iMac 19,1 today and I noticed that the idle CPU clock has gone up to 1,29GHz (13x) instead of 800MHz (8x) . So the whole thing feels a lot snappier too. But is that what Apple wants? Is the real iMac 19,1 also clocked like that? What are your experiences?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,348
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I switched to iMac 19,1 today and I noticed that the idle CPU clock has gone up to 1,29GHz (13x) instead of 800MHz (8x) . So the whole thing feels a lot snappier too. But is that what Apple wants? Is the real iMac 19,1 also clocked like that? What are your experiences?
I saw the same jump in idle MHz but, oddly, I didn't notice any change in power consumption...

I don't know if real iMac19,x idles at that speed.
 
Joined
Mar 30, 2013
Messages
144
Motherboard
Asus Prime Z370-A
CPU
i7-8700K
Graphics
RX 590
Mac
MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
I have checked the Intel specs and the CPU should idle with 800Mhz by design. So there is definitely something wrong with SMBIOS 19,1 or 19,2 and the i7 8700k with the clover plugin-type for PWM. But anyway I have switched to iMac Pro 1,1 and that even let me disable my IGPU and I also don't use WEG anymore. PWM is perfect and also no black screen issues with my Radeon 570. Also HEVC is working. Thank you Apple for finally fully support our Radeon cards. The only issue left is the purple lines on startup. But my Mac always sleeps when I walk away so I will see this only once in a while or with the next upgrade.
 
Last edited:
Joined
May 22, 2011
Messages
1,045
Motherboard
ASUS TUF Z390 Plus Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Guys, some values of the SMBIOS changed such as Firmware Features, EFI versions, etc. Update your Clover Configurator and SMBIOS.
 
Top