Slow wifi after sleep

Discussion in 'El Capitan Laptop Support' started by vbo, Oct 5, 2015.

  1. vbo

    vbo

    Joined:
    Jul 13, 2014
    Messages:
    299
    Oct 5, 2015 at 12:01 AM #1
    vbo

    vbo

    Joined:
    Jul 13, 2014
    Messages:
    299
    Pronlem: Wifi is considerably slower (transfer rate) after sleep. This is new since I upgraded to 10.11, I never had this issue with 10.10 on the same machine.

    I'm using a BCM94352Z connected to a 802.11n router at 300mbps on a 5GHz network (link speed as reported in OSX is the same before and after sleep). I use FakePCIID and the BCM94352Z_as_BCM94360CS2 injector.

    On a fresh boot, I'm seeing 12MB/s transfers to/from my NAS. After sleep, this goes down to ~1.5MB/s. I see the same issue with internet speedtest: 50mbps download on a fresh boot (ISP bound), but only 10mbps after sleep.

    I tried turning wifi on/off, switching to the 2.4ghz network and back with no success. After sleep, my wifi seems to be capped at ~10mbps no matter what. As soon as I reboot, it is back to full speed.

    Any idea where to look? Besides this speed issue, the wifi works fine after sleep (no disconnect, comes back on as soon as I turn the laptop on).
     
  2. McShmoopy

    McShmoopy

    Joined:
    Jun 12, 2015
    Messages:
    253
    Motherboard:
    Gigabyte Z370-HD3P
    CPU:
    i7 8700k
    Graphics:
    1050TI
    Mobile Phone:
    iOS
    Oct 5, 2015 at 12:11 AM #2
    McShmoopy

    McShmoopy

    Joined:
    Jun 12, 2015
    Messages:
    253
    Motherboard:
    Gigabyte Z370-HD3P
    CPU:
    i7 8700k
    Graphics:
    1050TI
    Mobile Phone:
    iOS
    IM suffering from an extremely similar issue too mate, it seems to come from me using a DSDT patch to fix the instant wake issue associated with the new USB nonsense. The best workaround Ive had is disconnecting from wifi or turning it off before sleep. Once you reconnect after sleep you should be okay Refer to my post for more details :)

    http://www.tonymacx86.com/el-capita...70-bcm4352-wifi-failure-after-wake-sleep.html
     
  3. vbo

    vbo

    Joined:
    Jul 13, 2014
    Messages:
    299
    Oct 5, 2015 at 2:39 AM #3
    vbo

    vbo

    Joined:
    Jul 13, 2014
    Messages:
    299
    Thanks for the reply mcschmoopy. I had seen your thread, but my issue was only with the transfer rate. Reconnection after sleep was fine, only speeds were a lot slower.

    I figured out a 'fix' for my issue based on the system logs: disable wake for wifi access in energy saver prefs. Since I don't need to remote wake this laptop, that's a good enough fix for me.

    In case someone finds this later, here's how you can tell if you have the same issue:
    On wake, you see a bunch of errors from the kernel ARPT/airportd in system.log, such as:
    Code:
    10/4/15 8:36:57.000 PM kernel[0]: ARPT: 160.845711: wl0: fatal error, reinitializing, total count of reinit's[1], @'wlc_ol_down':1426
    10/4/15 8:36:57.000 PM kernel[0]: ARPT: 160.909103: wl0: fatal error, reinitializing, total count of reinit's[2], @'wlc_verify_d3_exit':56001
    10/4/15 8:36:59.600 PM airportd[57]: __setPowerWithRetry: Retry setting power to ON, err = -3903 (Operation not supported). Remaining:5.
    
    You have a bunch of driver crash reports (one per wake) at:
    Code:
    ls /Library/Logs/CrashReporter/CoreCapture/com.apple.driver.AirPort.Brcm4360.0/
    [2015-10-03_03,40,24.336887]=reinit:9-FW_TRAP
    [2015-10-03_05,42,26.353615]=reinit:9-FW_TRAP
    [2015-10-03_06,43,33.352949]=reinit:9-FW_TRAP
    [2015-10-03_09,03,41.354465]=reinit:9-FW_TRAP
    [2015-10-03_10,43,12.357852]=reinit:9-FW_TRAP
    [2015-10-04_00,03,11.328240]=reinit:9-FW_TRAP
    [2015-10-04_01,04,15.330970]=reinit:9-FW_TRAP
    [2015-10-04_02,06,30.330046]=reinit:9-FW_TRAP
    [2015-10-04_03,14,10.330985]=reinit:9-FW_TRAP
    [2015-10-04_05,14,23.327866]=reinit:9-FW_TRAP
    [2015-10-04_07,15,11.330195]=reinit:9-FW_TRAP
    [2015-10-04_09,15,59.331360]=reinit:9-FW_TRAP
    [2015-10-04_11,16,46.331739]=reinit:9-FW_TRAP
    [2015-10-04_11,25,15.340904]=reinit:9-FW_TRAP
    [2015-10-04_17,01,21.310098]=reinit:9-FW_TRAP
    [2015-10-04_17,55,34.341637]=reinit:9-FW_TRAP
    [2015-10-04_18,36,22.349748]=reinit:9-FW_TRAP
    [2015-10-04_20,36,59.353899]=reinit:9-FW_TRAP
    
    All of these disappear for me when the wifi is powered down during sleep (i.e. when wake on wireless is off).
     
    interdasting likes this.
  4. cheasie

    cheasie

    Joined:
    Nov 22, 2015
    Messages:
    1
    Motherboard:
    asrock z77 pro4
    CPU:
    i5 3570k
    Graphics:
    evga 970
    Nov 24, 2015 at 1:24 AM #4
    cheasie

    cheasie

    Joined:
    Nov 22, 2015
    Messages:
    1
    Motherboard:
    asrock z77 pro4
    CPU:
    i5 3570k
    Graphics:
    evga 970
    I have the exact same issue, I just installed El Capitan as my first hackintosh.
    It has no problem reconnecting to wifi after wake from sleep, but the speed is extremely slow, going from 60Mbps to 1Mbps.

    Only way to get back the original speed is do a restart and never put it to sleep.
     
  5. vbo

    vbo

    Joined:
    Jul 13, 2014
    Messages:
    299
    Nov 24, 2015 at 1:40 AM #5
    vbo

    vbo

    Joined:
    Jul 13, 2014
    Messages:
    299
    Did you try disabling Wake for WiFi access in Energy Saver preferences?
     
  6. manhas

    manhas

    Joined:
    Aug 5, 2015
    Messages:
    20
    Motherboard:
    Asus H97i Plus
    CPU:
    i7 4790k
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    Nov 25, 2015 at 8:44 AM #6
    manhas

    manhas

    Joined:
    Aug 5, 2015
    Messages:
    20
    Motherboard:
    Asus H97i Plus
    CPU:
    i7 4790k
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    This thread is in the Laptop forum but I'm experiencing the same issue on my Desktop Hackintosh after I upgraded to El Capitan. I've just used El Capitan for two days but so far after sleep (not always) the WiFi is really slow, the only way to get it to function properly again that I've found is to restart the computer.

    When it "works" in the slow state my Internet goes from ~ 95/11mpbs to ~ 5/11mps and I have a lot packet losses if I ping www.google.com. So the download is heavily reduced but for some reason my upload speed is unchanged when I test the bandwidth.

    I haven't been able to test yet if the connection goes back and forth between slow and not working at all, or if it just works the initial seconds/minute. But most of the time I can't even connect to my own router and cannot resolve the host when I try to ping.

    During this time the only fixes I've applied are USB fixes to get USB 3.0 working: "change ECHx to EH0x", "installed
    FakePCIID.kext/FakePCIID_XHCIMux.kext" and "change the port limit from 15 to 20 in XHCI kext". I just discovered that it appears to be enough if I change the port limit, so I'm going to test if the WiFi issue gets better when the other USB fixes removed.

    I have similar logs as the ones user vbo posted expect for "__setPowerWithRetry: Retry setting power to ON, err = -3903" which I can't find. So I will try to turn off wake for wireless if the issue continues.


    I'm using a "iMac 802.11AC BCM94360CD BT4.0" card that works out of the box with the Hackintosh.
     
  7. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,828
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Nov 25, 2015 at 1:37 PM #7
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    185,828
    Motherboard:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Disable wake on WiFi in SysPrefs->Energy Saver.
     
  8. mtcollins05

    mtcollins05

    Joined:
    Aug 29, 2014
    Messages:
    27
    Motherboard:
    Asus Z97-A
    CPU:
    i7 4790k
    Graphics:
    GTX 770 EVGA SC
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Dec 4, 2015 at 3:24 PM #8
    mtcollins05

    mtcollins05

    Joined:
    Aug 29, 2014
    Messages:
    27
    Motherboard:
    Asus Z97-A
    CPU:
    i7 4790k
    Graphics:
    GTX 770 EVGA SC
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    You guys are the BEST! I could not figure this out on my CustoMacPro desktop. I was having the exact same issue. Disabling the wake for network access in Energy Saver worked perfect! :headbang::thumbup:
     
  9. Admir77

    Admir77

    Joined:
    Jun 7, 2016
    Messages:
    1
    CPU:
    Intel Core i3 Skylake
    Graphics:
    Intel HD520
    Aug 3, 2016 at 9:03 AM #9
    Admir77

    Admir77

    Joined:
    Jun 7, 2016
    Messages:
    1
    CPU:
    Intel Core i3 Skylake
    Graphics:
    Intel HD520
    My problem is just opposite. I have same Wifi card, speed is slow after bootup and after little trick, putting in sleep mode and rest, I have full speed. Does anybody know which is probably problem, tried every solution on internet and not jet solve problem.
     
    Last edited by a moderator: Aug 3, 2016
  10. fluxo

    fluxo

    Joined:
    Jul 26, 2012
    Messages:
    71
    Motherboard:
    Asus Zenbook UX330UA - Clover EFI
    CPU:
    Intel i5-7200U
    Graphics:
    Intel® HD Graphics 620, 1920x1080
    Mar 11, 2017 at 7:56 PM #10
    fluxo

    fluxo

    Joined:
    Jul 26, 2012
    Messages:
    71
    Motherboard:
    Asus Zenbook UX330UA - Clover EFI
    CPU:
    Intel i5-7200U
    Graphics:
    Intel® HD Graphics 620, 1920x1080
    i have the same problem that you, after sleep i get full speed, did you ever solve it?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice