Contribute
Register

Slow USB 3 ports in Mojave

Status
Not open for further replies.
Joined
Jul 3, 2013
Messages
36
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
i7-4770
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
All my USB 2.0 and USB 3.0 ports are working, the problem is all the USB 3.0 ports are slow.

DiskSpeedTest.png


Here is my MultiBeast configuration:

Screen Shot 2019-01-02 at 9.20.40 PM.png


Here's the system report

Screen Shot 2019-01-02 at 9.22.13 PM.png


Thanks!
 
Joined
Jul 30, 2017
Messages
15
Motherboard
MSI B150M Pro-vdh
CPU
i5-6600
Graphics
HD 7950
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. Android
what is the reported speed when you click on a device in system profiler connected to the usb3 hub?
 
Joined
Jul 30, 2017
Messages
15
Motherboard
MSI B150M Pro-vdh
CPU
i5-6600
Graphics
HD 7950
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. Android
well, there you go. usb2 speeds. should be up to 5gb not 480mb. use a guide to manually add the usb3 functionality to the ports using dsdt.
 
Joined
Jul 3, 2013
Messages
36
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
i7-4770
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
well, there you go. usb2 speeds. should be up to 5gb not 480mb. use a guide to manually add the usb3 functionality to the ports using dsdt.

I'm sorry looking like a lazy person. But can you point me to the guide? I've seen RehabMan's but I am stuck with the XHC thing.

I've patch DSDTs:

Screen Shot 2019-01-05 at 11.45.42 PM.png


I also added the -uia_ignore_rmcf in boot

Screen Shot 2019-01-05 at 11.47.05 PM.png


I've tried using IOReg the table under XHC won't detect any USB changes if I insert or remove USB devices:

Screen Shot 2019-01-05 at 11.48.23 PM.png


Changes only shows at EH01>PR11>HP15, HP16 and HP18 and EH02>PR21>HP25

Screen Shot 2019-01-05 at 11.50.52 PM.png


Am I doing something wrong?

Thanks for your time
 
Status
Not open for further replies.
Top