Contribute
Register

Slow/Dropped Wifi after Sleep with BCM943602BAED (DW1830)

Status
Not open for further replies.
Joined
Oct 23, 2014
Messages
688
Motherboard
Gigabyte GA-Z97x-UD3H
CPU
i7 4790k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
My desktop with 94360CD has this error, even if I ticked off "Wake for network access" in the power manager. But the difference is that it happens on occasion, that is, it does not happen after every wake from sleep. Usually, after several days of several times of sleep wake cycles, it finally happens.

Tom
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,933
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
My desktop with 94360CD has this error, even if I ticked off "Wake for network access" in the power manager. But the difference is that it happens on occasion, that is, it does not happen after every wake from sleep. Usually, after several days of several times of sleep wake cycles, it finally happens.

Tom

Off-topic.

Desktop questions are off-topic in the laptop forum.
Post your question in the appropriate desktop forum.
 
Joined
Sep 20, 2016
Messages
2
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
HD 630 / GTX 1050
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have solved BT/WIFI problems after wake up.
The solution is:
1, Confirm FakePCIID.kext/FakePCIID_Broadcom_WiFi.kext is added
2, Remove country code in config.plist/KernelAndKextPatches/KextsToPatch
3, Add "-lilubeta -brcmfxbeta brcmfx-country=#a" to config.plist/boot/arguments
4, Add AirportBrcmFixup.kext.

When I do this, BT/WIFI problem after wake up has sovled.
There is a small problem is: the country code and location is not show in System Report/Network/Wi-Fi
@litgle : Can you confirm that your solution still works?

Old but might still be useful. Try to update to latest Windows Dell drivers for the DW1830 card. That usually contains the required microcode to upgrade the card's firmware. Mine's currently identified as "Broadcom BCM43xx 1.0 (7.77.37.31.1a9)" after I upgraded its driver in Windows - didn't recorded the previous version but I'm pretty sure it was 7.21 as well.

This was the latest version I could find online: https://www.dell.com/support/home/u...1967003687&osCode=&productCode=&categoryId=NI

I also upgraded the Bluetooth portion as well, just because: https://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=7X3JX

Gonna try this update too. Hopefully this makes the card more reliable
 
Last edited:
Joined
May 5, 2014
Messages
189
Motherboard
X1 Carbon 6th
CPU
i7-8550U
Graphics
UHD620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@jaymonkey thanks for initiating the discussion for this issue. I have the issue recently notice at Catalina 10.15.1. change setting in SysPre not working for me either.

PS: still anyone has same issue at 10.15.1? ( I didn't notice this at HS 10.13.6)

Just found a quick solution: unplug the power supply and 3s then re-plugin.
To verify, I did Ping test to router, after sleep ping >100ms, unplug and re-plug return to <10ms!

Could anyone check and confirm?

But still would like to find the root cause and definitive solution....
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,985
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
@jaymonkey thanks for initiating the discussion for this issue. I have the issue recently notice at Catalina 10.15.1. change setting in SysPre not working for me either.

PS: still anyone has same issue at 10.15.1? ( I didn't notice this at HS 10.13.6)


@Cabriolet,

As detailed in the 03//2018 Update in Post #1, I have not seen this issue in a very long time, basically since switching to using Lilu + AirportBrcmFixup on High Sierra.

Since then I have not experienced WiFi slow down on Mojave or Catalina, my hardware has not changed, I just kept Clover, Lilu and its plug's up to date.

Did you try turning WiFi Off and then back On using by WiFi icon on the top menu bar ?

Cheers
Jay
 
Joined
May 5, 2014
Messages
189
Motherboard
X1 Carbon 6th
CPU
i7-8550U
Graphics
UHD620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks! you mean everytime just before go sleep turn off WiFi and after wake turn on? Not working for me and it is still awkward.

Since upgrade to Catalina, I have these 2 headaches after macOS wake: 1. WiFi speed drop; 2. BT module chipset changed from BCM20703A => BCM2045A0(cf. said both belong to DW1830), thus airdrop not working anymore but BT mouse no issue.

checking kext loading with kextstat | grep -i brcm: ( WiFi works natively for DW1830 w/o AirportBrcmFixup)
Code:
% kextstat|grep -i brcm
   91    0 0xffffff7f81a31000 0x7d5000   0x7d5000   com.apple.driver.AirPort.BrcmNIC (1400.1.1) E7D99C63-B581-3CFF-B979-8EEA0D08BAE0 <90 89 88 87 18 13 8 7 6 5 3 1>
  120    1 0xffffff7f83c22000 0x5000     0x5000     com.no-one.BrcmFirmwareStore (2.3.0d3) 8702AD8C-8188-3FCB-8A0F-8A98967EF889 <6 5 3>
  121    0 0xffffff7f83c27000 0x5000     0x5000     com.no-one.BrcmPatchRAM3 (2.3.0d3) 07322A73-A17B-34DF-8766-16C94DF8BC88 <120 27 6 5 3 1>

I tried repatch DSDT, and change different kext drivers(incl. from insanleymac), not resolved, finally I switch back to BCM4352z( Lenovo variant: VID_0489&PID_E07A), now all fine! I have to revised this, because using BCM4352z lost BT again (as 10.13.16 before), still desperate seeking solution, but using DW1830 it drops WiFi speed and airdrop n/a after wake-up from sleep.

Now I know it is all related to the WiFi/BT card & kext driver.

currently kext driver I am using:

WiFi: AirportBrcmFixup.kext ( 2.0.4)
BT: https://github.com/acidanthera/BrcmPatchRAM, latest 2.50 of :
  • BrcmBluetoothInjector.kext
  • BrcmFirmwareRepo.kext
  • BrcmPatchRAM3.kext
checking kext loading with kextstat | grep -i brcm:

Code:
% kextstat | grep -i brcm
   49    0 0xffffff7f845f9000 0x8000     0x8000     as.lvs1974.AirportBrcmFixup (2.0.4) 88D30B81-6FB9-3109-9692-B3E7192CF04A <42 18 13 8 6 5 3 2 1>
   91    0 0xffffff7f81a31000 0x7d5000   0x7d5000   com.apple.driver.AirPort.BrcmNIC (1400.1.1) E7D99C63-B581-3CFF-B979-8EEA0D08BAE0 <90 89 88 87 18 13 8 7 6 5 3 1>
   93    0 0xffffff7f82291000 0x586000   0x586000   com.apple.driver.AirPort.Brcm4360 (1400.1.1) 5B3F9150-E4F1-3E8D-AED6-A8C541B67479 <90 89 88 18 13 8 7 6 5 3 1>
  133    1 0xffffff7f841b5000 0x6000     0x6000     as.acidanthera.BrcmFirmwareStore (2.5.0) B78BB510-7CB1-30F8-AC08-9DA5E75420E4 <6 5 3>
  134    0 0xffffff7f841bb000 0x5000     0x5000     as.acidanthera.BrcmPatchRAM3 (2.5.0) A6812F3E-DF9B-36F3-966B-FE592C6EBFDA <133 27 6 5 3 1>


@Cabriolet

As detailed in the 03//2018 Update in Post #1, I have not seen this issue in a very long time, basically since switching to using Lilu + AirportBrcmFixup on High Sierra.

Since then I have not experienced WiFi slow down on Mojave or Catalina, my hardware has not changed, I just kept Clover, Lilu and its plug's up to date.

Did you try turning WiFi Off and then back On using by WiFi icon on the top menu bar ?

Cheers
Jay
 
Last edited:
Status
Not open for further replies.
Top