Slow Catalina on i5-6500 Desktop after some months (slow ssd speed almost for sure)

Not open for further replies.
Jun 20, 2020
asrock h110
i5 6500
Hi everyone, I finally decided to write something here (this is my first post) in order to seek help to do some good to my Hackintosh.

I installed macOS Catalina 10.15.5 this August. I was astonished by its speed compared to my 2017 MacBook and so I decided to use it for work.
Things went south pretty quickly since after a month it started to be slower and slower at the point that even opening chrome (with no tab) now takes about 8/10 seconds.
I started benchmarking with blackmagic since this behaviour smelled a lot like an SSD problem, since the symptoms weren't graphical lags (I'm using the IGPU, I'll list the build at the end of this post), but the loading cursor appeared or even a complete OS freeze that takes 3-4 seconds to unfreeze.
So the results are exactly what I was expecting:


But it's slow in a weird manner. The write speed starts very slow and after 3/4 seconds (which is obviously too much) goes up to 150 top but mostly 90/100.
To confirm this, I have a portable T5 Samsung SSD of 256gb that I use to back up the entire system and... guess what? When I boot the OS through the external drive (USB 3.0), things become fast as crazy again.
This of course happens on boot time too. With the internal SSD it requires something like 4 minutes (there might be other problems too, but I don't care much about the boot time honestly, the pc it's almost always on), with the samsung t5 it requires 25 secs.

I've read everything on the whole internet but anything that I tried could solve this problem.

Things tried with no success:

- Enabled TRIM manually with clover
- Enabled TRIM with trimforce enable

So, I might replace the ssd, but I'm actually scared that buying a new ssd would lead me to the same problems in a few weeks.
I also attached my clover config, bootlog and here is my build:

CPU: i5 6500
Main SSD with macOS: Crucial bx500 256gb
EGPU: gtx 1050 (completely disabled, not using it)
MOBO: Asrock h110m-itx (
RAM: 16GB ddr4 2133 (kingston hyperx)


    4.9 MB · Views: 30
  • bootlog.txt
    26.3 KB · Views: 31
Last edited:
Not open for further replies.