Contribute
Register

Sleep with fans activated and LEDs on

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,432
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I told you... if I put USB3 on SS03 and SS04 one port doesn't work


so it's right now?
What other steps do you think I should do now?

I don't know what's wrong with SS03 and SS04. You will lose USB3 functionality on those ports if you configure them as USB2.

You can remove the PXSX ports from Hackintool.
 
Joined
Aug 11, 2021
Messages
22
Motherboard
ROG STRIX Z370-E
CPU
i78700K
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. Android
normally would also see HS04 and HS03 set as USB3 on your XHC....
ok. With USBINJECTALL is

1630417947570.png


now, according to what you wrote is:
1630418030581.png


still don't work the sleep
 

Attachments

  • 1630415386983.png
    1630415386983.png
    516.5 KB · Views: 4
  • 1630415682717.png
    1630415682717.png
    524.9 KB · Views: 5
Joined
Aug 11, 2021
Messages
22
Motherboard
ROG STRIX Z370-E
CPU
i78700K
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. Android
it's a mess configuring this USB...
now
1630434695523.png

if I insert an HUN on a MB port it is detected on SS05...
If I insert ON THE SAME PORT an HUB then it is detected in the HS05!
And so I'm wondering if I miss something cutting the ports...
btw sleep always don't work...
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
6,585
Motherboard
Gigabyte Z490i Aorus Ultra - OC 0.6.8
CPU
i5-10600K
Graphics
GT710 - 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. Android
following the guide, using only the generated kext has no effect on USB.
View attachment 527990
wondering why

Hi all.

I can't answer the Sleep/Fans issue here directly but ...

There's a strangeness to how ASUS have configured this motherboard's USB ports.

Normally you'd expect the Z370 to do most of the heavy lifting USB-wise, but it doesn't, that job goes to the ASMedia controllers which provide a total of 22x ports:

ROG.png

So building a USBPorts.kext (or USBMap.kext, or SSDT-UIAC.aml) will not work as expected. Getting within the 15x Intel port limit is not even a concern here.

The Z370 chipset has standard 14x port USB2 and 10x USB3 stacks, but they don't appear to be fully utilised by ASUS here. Even the USB2 ports are supplied by ASMedia.

The Z370 USB stacks may be visible to Hackintool along with the ASMedia, but how the ACPI tables are written will dictate which port labels are assigned to which PXSX ASMedia ports.

Sorry that doesn't help directly. There's not enough to go on. We'd need an IOReg export to try and unpick this complicated set-up.

Having said that, I suspect the Sleep/Wake fan issue is not related to USB, but Power Management elsewhere. Happy to be proved wrong though, and also to help with USB. :thumbup:
 
Joined
Aug 11, 2021
Messages
22
Motherboard
ROG STRIX Z370-E
CPU
i78700K
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. Android
Hi all.

I can't answer the Sleep/Fans issue here directly but ...

There's a strangeness to how ASUS have configured this motherboard's USB ports.

Normally you'd expect the Z370 to do most of the heavy lifting USB-wise, but it doesn't, that job goes to the ASMedia controllers which provide a total of 22x ports:

View attachment 528122

So building a USBPorts.kext (or USBMap.kext, or SSDT-UIAC.aml) will not work as expected. Getting within the 15x Intel port limit is not even a concern here.

The Z370 chipset has standard 14x port USB2 and 10x USB3 stacks, but they don't appear to be fully utilised by ASUS here. Even the USB2 ports are supplied by ASMedia.

The Z370 USB stacks may be visible to Hackintool along with the ASMedia, but how the ACPI tables are written will dictate which port labels are assigned to which PXSX ASMedia ports.

Sorry that doesn't help directly. There's not enough to go on. We'd need an IOReg export to try and unpick this complicated set-up.

Having said that, I suspect the Sleep/Wake fan issue is not related to USB, but Power Management elsewhere. Happy to be proved wrong though, and also to help with USB. :thumbup:
You helped A LOT even for I don't think that I'm a dummy on this issue...
It's really complicated even because I want to find correctly the USB for the lights connected to the mb (for OpenRGB).
I'm also wondering why there is not a trusted repository of all the MBs kexts. Since I suppose that with this method the optimal result should be the same for each mb model. BTW I found other guides that are related on tables too, but are very complicated and time consuming.
I find more guides than kexts...
By the way I ALSO think that this usb remapping is not the point...
Thanks a lot for your post.
 
Joined
Aug 11, 2021
Messages
22
Motherboard
ROG STRIX Z370-E
CPU
i78700K
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. Android
I fixed USB but now the problem is another:
1630603828047.png

and I'm not able to wake up again.
The fans go off and quickly on again, and remains on. No way to make it start again
1630603905984.png
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,432
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I fixed USB but now the problem is another:
View attachment 528242
and I'm not able to wake up again.
The fans go off and quickly on again, and remains on. No way to make it start again
View attachment 528243

Launch activity monitor and see what pid 157 is.

Edit:
Enter the following in to Terminal and post the output:
Code:
pmset -g log | grep -i failure
 
Last edited:
Joined
Aug 11, 2021
Messages
22
Motherboard
ROG STRIX Z370-E
CPU
i78700K
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. Android
@pastrychef
2021-09-02 19:02:58 +0200 Failure Failure during wake: 0x00000021 : Failure while halting non-boot CPUs
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,432
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Top