Contribute
Register

Sleep with fans activated and LEDs on

Joined
Aug 11, 2021
Messages
22
Motherboard
ROG STRIX Z370-E
CPU
i78700K
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. Android
Hi, I have an iMac19,2, Big Sur 11.5.2.
I followed all the Dortania guide for opencore, I have OPENCORE 0.7.3.
Also the steps for the sleep fix.
But when it goes to sleep, the fans and LEDs continue to be on.
I also noticed, on my return, that it went from off to fans on, always with the monitor off.
I attach relative log:
2021-08-28 15:24:09 +0200 Wake Wake from Normal Sleep [CDNVA] : due to XDCI/HID Activity Using AC (Charge:0%) 611 secs
2021-08-28 15:34:20 +0200 Sleep Entering Sleep state due to 'Idle Sleep': Using AC (Charge:0%) 15 secs
2021-08-28 15:34:35 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 45 secs
2021-08-28 15:35:20 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 30 secs
2021-08-28 15:35:50 +0200 Wake Wake from Normal Sleep [CDNVA] : due to XDCI/HID Activity Using AC (Charge:0%) 633 secs
2021-08-28 15:46:23 +0200 Sleep Entering Sleep state due to 'Idle Sleep': Using AC (Charge:0%) 14 secs
2021-08-28 15:46:37 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 45 secs
2021-08-28 15:47:22 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 14 secs
2021-08-28 15:47:36 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 46 secs
2021-08-28 15:48:22 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 13 secs
2021-08-28 15:48:35 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 45 secs
2021-08-28 15:49:20 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 15 secs
2021-08-28 15:49:35 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 45 secs
2021-08-28 15:50:20 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 14 secs
2021-08-28 15:50:34 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 45 secs
2021-08-28 15:51:19 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 31 secs
2021-08-28 15:51:50 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 46 secs
2021-08-28 15:52:36 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 13 secs
2021-08-28 15:52:49 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 45 secs
2021-08-28 15:53:34 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 15 secs
2021-08-28 15:53:49 +0200 Wake Wake from Normal Sleep [CDNVA] : due to XDCI/HID Activity Using AC (Charge:0%) 624 secs
2021-08-28 16:04:13 +0200 Sleep Entering Sleep state due to 'Idle Sleep': Using AC (Charge:0%) 14 secs
2021-08-28 16:04:27 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 46 secs
2021-08-28 16:05:13 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 14 secs
2021-08-28 16:05:27 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 45 secs
2021-08-28 16:06:12 +0200 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 14 secs
2021-08-28 16:06:26 +0200 Wake Wake from Normal Sleep [CDNVA] : due to XDCI/HID Activity Using AC (Charge:0%)

Any ideas?
 
Last edited:

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
2,367
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
How do you have your systemwide power settings configured?

If you enter this command in to a Terminal window, sudo pmset -g

What result do you see?

Post a screenshot like the example below, so we can see what you are currently using:

Screenshot 2021-08-28 at 19.53.50.png

You may need to change the systemwide power settings so your system can sleep as you want it to. These are the Terminal commands I use when setting my systemwide power settings, my system sleeps with the fans etc. stopped:

Disable Hibernation
sudo pmset -a hibernatemode 0
sudo rm /var/vm/sleepimage
sudo mkdir /var/vm/sleepimage

Disable other hibernation options
sudo pmset -a standby 0
sudo pmset -a autopoweroff 0
sudo pmset powernap 0
sudo pmset proximitywake 0

You may find that using hibernate mode 3, 25 or 29 work better with your system, or matches the way you want your system to sleep. It is easy to try each option, just replace ‘hibernatemode 0’ with the number for the alternative mode you wish to try.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,472
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Did you fix USB?
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
2,367
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Joined
Aug 11, 2021
Messages
22
Motherboard
ROG STRIX Z370-E
CPU
i78700K
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. Android
How do you have your systemwide power settings configured?

If you enter this command in to a Terminal window, sudo pmset -g

What result do you see?

Post a screenshot like the example below, so we can see what you are currently using:

View attachment 527958

You may need to change the systemwide power settings so your system can sleep as you want it to. These are the Terminal commands I use when setting my systemwide power settings, my system sleeps with the fans etc. stopped:

Disable Hibernation
sudo pmset -a hibernatemode 0
sudo rm /var/vm/sleepimage
sudo mkdir /var/vm/sleepimage

Disable other hibernation options
sudo pmset -a standby 0
sudo pmset -a autopoweroff 0
sudo pmset powernap 0
sudo pmset proximitywake 0

You may find that using hibernate mode 3, 25 or 29 work better with your system, or matches the way you want your system to sleep. It is easy to try each option, just replace ‘hibernatemode 0’ with the number for the alternative mode you wish to try.
Yes, but I just ran the command for the proximitywake that was 1, now 0 as you can see. I didn't want to change other setting, for example autopoweroff, because I don't see them and I don't know its current status in order to backup.

System-wide power settings:
Currently in use:
standby 1
Sleep On Power Button 1
womp 0
autorestart 0
hibernatefile /var/vm/sleepimage
proximitywake 0
powernap 0
networkoversleep 0
disksleep 10
standbydelayhigh 86400
sleep 10
hibernatemode 3
ttyskeepawake 1
displaysleep 10
highstandbythreshold 50
standbydelaylow 86400

Now, setting hibernatemode with 0 stops the fans. But there is no way to wake up. Pressing the case power button turned it off.
 
Last edited:

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
2,367
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Have a look at the Hackintool > Power tab to see what that shows.

Screenshot 2021-08-28 at 21.00.50.png Hackintool > Power tab readings

Use the sudo pmset -a standby 0 command to change Standby from 1 to 0
Use the sudo pmset -a autopoweroff 0 command to set it to 0, if Hackintool shows it is set to 1.

You might also want to set ttyskeepawake to 0 using this command - sudo pmset ttyskeepawake 0
 
Joined
Aug 11, 2021
Messages
22
Motherboard
ROG STRIX Z370-E
CPU
i78700K
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. Android
Have a look at the Hackintool > Power tab to see what that shows.

View attachment 527962 Hackintool > Power tab readings

Use the sudo pmset -a standby 0 command to change Standby from 1 to 0
Use the sudo pmset -a autopoweroff 0 command to set it to 0, if Hackintool shows it is set to 1.

You might also want to set ttyskeepawake to 0 using this command - sudo pmset ttyskeepawake 0
I made

sudo pmset -a standby 0
sudo pmset -a autopoweroff 0
sudo pmset -a hibernatemode 0
sudo rm -r /var/vm/sleepimage
sudo mkdir /var/vm/sleepimage
1630223465363.png

and this is the result
2021-08-29 09:49:30 +0200 Sleep Entering Sleep state due to 'Software Sleep pid=154': Using AC (Charge:0%) 13 secs
2021-08-29 09:49:43 +0200 DarkWake DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 5 secs
2021-08-29 09:49:48 +0200 Wake DarkWake to FullWake from Normal Sleep [CDNVA] : due to UserActivity Assertion Using AC (Charge:0%)

It goes in a state that turns off the fan and the lights, then - very soon - it goes automatically to a state with fan and lights are turned on.

Please note that I didn't made the USB optimization for my machine already.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,472
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Did you fix USB?
 
Top