Contribute
Register

Sleep mode and fan controllers

Status
Not open for further replies.
Joined
Jul 8, 2016
Messages
11
Motherboard
Z170 Pro Gaming
CPU
i5-6600K
Graphics
Vega 64
Hi,

I got my hackintosh working quite nicely.
One problem that still persists is sleep mode. Once I send the hackintosh to sleep, the display turns off immediately, the rest follows after a few seconds.
Then, again just a few seconds later, the pc boots again (monitor still black, but fans and cooling and lights start again). It then stays at this mode.
Waking is no problem, either with bluetooth-connected trackpad or usb-devices.
Any ideas how to get the sleep working? dark wake flag?
My cooling fans, pump, and lights are all controlled via an USB device. Does mackintosh sleep still powers the usb? is there a way to disable that?

Cheers
 
Joined
Jul 24, 2011
Messages
127
Motherboard
Gigabyte GA-Z97X-UD5H
CPU
Intel Core i7 4790k
Graphics
Nvidia GTX 980Ti
Mac
  1. MacBook Air
Classic Mac
  1. LC
  2. Power Mac
  3. Quadra
Mobile Phone
  1. Android
  2. iOS
You probably have a usb device that is causing the wake problems try disconnecting one at a time and see which one is causing the issue. It may be the sub fan controller
 
Joined
Jul 8, 2016
Messages
11
Motherboard
Z170 Pro Gaming
CPU
i5-6600K
Graphics
Vega 64
Well I did disconnect my Broadcom USB, the problem persists. I also tried disconnecting my USB hubs (fronpanel, but nothing plugged in) to no avail.
The rest of my USB is used in conjunction with fan / pump control. I really can't disconnect that without risking thermal failure :-/
I let the mackintosh "sleep" for a while now to see if the pattern repeats, and it does. pattern is something like:

1) press sleep, monitor off immediately, pc shuts down
2) pc off for 2-3 seconds, goes on again, monitor stays of
3) pc shuts down after some 30 seconds, rinse and repeat at 2)
 
Status
Not open for further replies.
Top