Contribute
Register

Sleep issues

Joined
Sep 17, 2012
Messages
170
Motherboard
Asus Prime Z490-A
CPU
Intel i9-10850k along with Noctua NH-D15 SSO2 D-Type Premium CPU Cooler
Graphics
Primary: Sapphire Pulse RX 570, Secondary: UHD 630
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I've been dealing with hackintosh boxes since Apple switched to Intel years ago. This is approximately my 5th build but never had this problem before.

Whenever I activate Sleep the monitor shuts off then about 12 seconds later the PC shuts down then about 2 seconds later it starts back up. Something is starting it back up on its own. In Energy Saver I unchecked "Wake for Ethernet network access" so I know its not my Ethernet card.

Currently here is what I have attached to my mobo both USB and PCIe:

1. M-Audio C400 (I doubt this would cause wake from sleep). I do not have any onboard sound enabled as I use the C400 for my audio for DAW purposes.

2. GTX 750 TI (I doubt this would cause wake from sleep).

3. HighPoints RocketRaid 640l setup in Raid 0 (Again I doubt this would cause wake from sleep)

4. A USB 3, 4 port PCIe card. (At the moment nothing is attached to it.)

So, what would cause it to go to sleep and 2 seconds later wake up?

Any help is appreciated as this is my last issue that I need resolving. Also I have tried enabling and disabling darkwake=0 to no avail....

Also here is the output from pmset -g assertions:

2017-07-25 11:56:26 -0400
Assertion status system-wide:
BackgroundTask 0
ApplePushServiceTask 0
UserIsActive 1
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
ExternalMedia 1
PreventUserIdleSystemSleep 0
NetworkClientActive 0
Listed by owning process:
pid 45(powerd): [0x0000000700088000] 00:06:28 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"
pid 100(hidd): [0x000000b6000980ad] 00:03:33 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968424.17"
Kernel Assertions: 0x4=USB
id=500 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a100000 owner=IOUSBHostDevice
id=501 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d100000 owner=IOUSBHostDevice
id=504 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a110000
id=505 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d170000 owner=Keyboard Hub
id=507 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a130000 owner=Integrated USB Bridge
id=508 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d180000 owner=USB Optical Mouse
id=509 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a150000 owner=Generic USB Hub
id=511 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a151000 owner=iLok
id=512 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a152000 owner=CodeMeter-Stick
id=513 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a154000 owner=eLicenser
id=514 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a153000 owner=eLicenser
Idle sleep preventers: IODisplayWrangler
 
Joined
Sep 17, 2012
Messages
170
Motherboard
Asus Prime Z490-A
CPU
Intel i9-10850k along with Noctua NH-D15 SSO2 D-Type Premium CPU Cooler
Graphics
Primary: Sapphire Pulse RX 570, Secondary: UHD 630
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Okay so look at post #5 here. It appears my USB 3 PCIe adapter is the root of the cause...The card is actually an ORICO Storm PCI Express to USB3.0 Controller Adapter Card...ORICO says it works with OS X without any drivers or kext which they are correct but its messing up the sleep. So onward to see if I can come up with a fix or find one...
 
Top