Contribute
Register

Sleep doesn't work!

Joined
Apr 14, 2017
Messages
8
Motherboard
Asus B85M-G
CPU
Intel Core i5 4460
Graphics
PNY GTX 1060 6GBs
Mobile Phone
  1. Android
Hello there!

I've been trying to make my hackintosh perfect fixing every problem that I could find, but i've got stuck in a sleep problem. After going to sleep (the power led turns orange and everything shuts down, like fans and display), the orange power led blinks one time and turns blue (on), and everything turns on again, but the system restarts. Can someone help me?

My specs are:
-Laptop (Acer E5-571-54MC)
-I5 4210u
-HD Graphics 4440
-AR9565 (Wireless card)
-Running OSX 10.12 (10.12.4 breaks wifi)

Everything except bluetooth, that I don't use much and sleep is working with these configurations:
*Clover files (Attachment);
*System drivers (Attachment);

-Removed IO80211Family.kext and IO80211FamilyV2.kext from /System/Library/Extensions/;
-Latest VoodooHDA is installed;
-Clover installed in the System disk.

What i've already tried? -
-Removing NullCPUPowerManagement.kext from CLOVER/others;
-Changing darkwake settings in Clover;
-Allowing hibernation in Clover (It works! If It goes to sleep, it still blinks orange one time and restarts, but allows me to start from where I was before!);

Note: If I close the lap's screen or make it sleep forcefully on the apple menu, it stills like nothing happened for about 30~50 seconds, just shutdown screen. If in this moment I press a key or click, the screen instantly turns on again. It seems to happens the same in autosleep.

Thank you very much in advance for any help!
 

Attachments

  • Clover files.zip
    6 MB · Views: 67
  • System drivers.zip
    309 KB · Views: 65

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,718
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Moved to Laptop Support.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello there!

I've been trying to make my hackintosh perfect fixing every problem that I could find, but i've got stuck in a sleep problem. After going to sleep (the power led turns orange and everything shuts down, like fans and display), the orange power led blinks one time and turns blue (on), and everything turns on again, but the system restarts. Can someone help me?

My specs are:
-Laptop (Acer E5-571-54MC)
-I5 4210u
-HD Graphics 4440
-AR9565 (Wireless card)
-Running OSX 10.12 (10.12.4 breaks wifi)

Everything except bluetooth, that I don't use much and sleep is working with these configurations:
*Clover files (Attachment);
*System drivers (Attachment);

-Removed IO80211Family.kext and IO80211FamilyV2.kext from /System/Library/Extensions/;
-Latest VoodooHDA is installed;
-Clover installed in the System disk.

What i've already tried? -
-Removing NullCPUPowerManagement.kext from CLOVER/others;
-Changing darkwake settings in Clover;
-Allowing hibernation in Clover (It works! If It goes to sleep, it still blinks orange one time and restarts, but allows me to start from where I was before!);

Note: If I close the lap's screen or make it sleep forcefully on the apple menu, it stills like nothing happened for about 30~50 seconds, just shutdown screen. If in this moment I press a key or click, the screen instantly turns on again. It seems to happens the same in autosleep.

Thank you very much in advance for any help!

It is "instant wake".
It is covered in the ACPI patching guide.
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello there!

I've been trying to make my hackintosh perfect fixing every problem that I could find, but i've got stuck in a sleep problem. After going to sleep (the power led turns orange and everything shuts down, like fans and display), the orange power led blinks one time and turns blue (on), and everything turns on again, but the system restarts. Can someone help me?

My specs are:
-Laptop (Acer E5-571-54MC)
-I5 4210u
-HD Graphics 4440
-AR9565 (Wireless card)
-Running OSX 10.12 (10.12.4 breaks wifi)

Everything except bluetooth, that I don't use much and sleep is working with these configurations:
*Clover files (Attachment);
*System drivers (Attachment);

-Removed IO80211Family.kext and IO80211FamilyV2.kext from /System/Library/Extensions/;
-Latest VoodooHDA is installed;
-Clover installed in the System disk.

What i've already tried? -
-Removing NullCPUPowerManagement.kext from CLOVER/others;
-Changing darkwake settings in Clover;
-Allowing hibernation in Clover (It works! If It goes to sleep, it still blinks orange one time and restarts, but allows me to start from where I was before!);

Note: If I close the lap's screen or make it sleep forcefully on the apple menu, it stills like nothing happened for about 30~50 seconds, just shutdown screen. If in this moment I press a key or click, the screen instantly turns on again. It seems to happens the same in autosleep.

Thank you very much in advance for any help!

"instant wake".
Patch ACPI (appropriate _PRW patch).
See guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
The iMac15,1 (MSI Z97 Gaming 7) can not sleep after restart or reboot for Sierra.
Any ideas are welcome.

Off-topic.
This forum is for laptops only.
 
Top