Skylake Intel HD 530 Integrated Graphics Working as of 10.11.4

Not open for further replies.
So I managed to make a stable build. Everythong works except HDMI audi. I'm using iGPU Intel HD 530. Can you help me?
Hi there,

I would like to suggest a simple help for anyone with black screen.
I can confirm HD 530 full working with that simple steps:

1 - make sure to disable any Graphic injection in Clover.
2 - boot and when at the Clover boot page select Options, than on the Graphic injection page, set the right Port.

In my case, I'm coming near crazy because my setup was = Port=01. In my mobo that mean HDMI.
As i have DVI only, I just set Port=00 and boot perfectly.

As a side note, in my case I can't boot wthout the Piker's patch, I need for proper boot still in 10.11.4!

Hope to save some time spent for someone, thank to all for your helps!

Ah, I forgot my setup:

- asrock Z170m pro s4
- i5 6600k integrated HD 530
- 16 GB ddr4 2133

All the best!

That was my (almost) perfect solution! Thank you
I plugged a TV to the HDMI and I had my display from the integrated Intel HD530

But...I have an "old" Cinema Display by Apple that only supports DVI so I tried your method of changing displayport in Clover, as you described, but I don't have the option to modify the display port in my clover version (3548) under Graphics.
(I would not change my Clover version because every time I updated it I had major problems and I had to reinstall...)

Is that possible that I can change it in Clover's config.plist? and, if yes, how?

Thanks in advance for any help about that :oops::thumbup:
hello i bought a hisense 4k tv and would like to use as monitor
i connected it and it only worked at 1080 ful hd
i tried the pixel clock patch and the resolutions show up in the preferences panel i clicked my tv resolution and i went black screen ( maybe i had to change to 30hz ) the problem is that i cant go back i treid to do it with voice over function with no luck
how can i go back ?

when i connect my old monitor it works, then i plug the new tv and works but it thinks its the old one, when i press detect monitor i goes blank.


  • Screen Shot 2016-11-30 at 2.38.04 PM.png
    Screen Shot 2016-11-30 at 2.38.04 PM.png
    43.3 KB · Views: 142
  • Screen Shot 2016-11-30 at 2.38.40 PM.png
    Screen Shot 2016-11-30 at 2.38.40 PM.png
    17.3 KB · Views: 147
Last edited:
Hey all. After some days to research, I'v given up with VGA port.
Confirm again that: VGA port never get full acceleration.
I buy a cable DVI - HDMI and tada... :headbang:
It's work, really work. And do the thing in #1 or choose option HD530 in Multibeast to get 100% acceleration.
And I have now:
Screen Shot 2016-12-01 at 8.27.16 PM.png

Screen Shot 2016-12-01 at 8.30.22 PM.png
Not going to read 40+ pages


I will confirm that this works on a DELL Optiplex 3040 with an i5 3.2Ghz (6500?)

Optiplex 3040, i5-6500, Sierra 10.12.1

How did you get it working?

I have only 7Mb showing

I have followed this, patch is applied, using HDMI, but nothing changed

Could you share your config.plist for Optiplex 3040?

Attached IORegistryExplorer created as per this in case somebody can help futher



    308.4 KB · Views: 124
Last edited:
Hi, I was able to get almost everything working with a GA-Z170XP-SLI mobo and i7-6700K build, except for the Intel HD 530 graphics. Under the Graphics/Displays menu of the System Information, the Display 7 mb VRAM shows up, but the Intel HD 530 also shows up with the full 1536 mb. However, when I go to "About This Mac" it says it is using only the Display 7 mb.

How can I make it so that it uses the Intel graphics instead? I followed the directions exactly and used Multibeast for the 530 patch. Also, the 530 graphics only shows up in the menu if I go to Internal Graphics in the BIOS and change it from "Auto" to "Enabled"


  • HD350.png
    95.4 KB · Views: 361
  • Display7mb.png
    107.5 KB · Views: 363
Last edited:
It was vital to upgrade to build 16B2657 from here

Now with ig-platform-id 19120000 in Clover 530 graphics work fine!
Just found out that while sleep is not working, hibernate does, when enabled through the Terminal:
sudo pmset -a hibernatemode 25

I tried this and macOS doesn't wake up from hibernate. When I press the power button, BIOS loads Clover and Clover recognizes that macOS is in hibernate mode. Then there is a progress bar, different than the one during normal boot, which seems to go almost immediately to about 95% and then it gets stuck there.
Hey Guys,

tried to patch the kext to get the dual monitor setup, but I face an weird problem...

I have a Dell Optiplex 5040 with a HD 530 and two 27" Dell monitors
only one works and when trying to find the ports, I face the following problem. Both port 6 and 7 have the same connector type (because they are both DP)
So how can I patch the KextsToPatch ??

AppleFramebuffer@0: connector-type 10 00 00 00, port-number 0x0
AppleFramebuffer@1: connector-type 00 08 00 00, port-number 0x5 - HDMI
AppleFramebuffer@2: connector-type 00 04 00 00, port-number 0x6 - DP left
AppleFramebuffer@3: connector-type 00 04 00 00, port-number 0x7 - DP right

I plugged one monitor with DP, and the other with HDMI and it worked. Dual monitor OK
But now I have that black glitch in the top left corner (never had it before) of the main screen and some weird pixels in any of the windows drop shadow...

EDIT2: the black glitch has been solved using this trick
Last edited:
Not open for further replies.