Contribute
Register

Skylake Intel HD 530 Integrated Graphics Working as of 10.11.4

Joined
Feb 24, 2013
Messages
2,667
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Hi Guys!

On El Cap currently and Intel HD530 works fine. I'm using a 27" Apple Display via DisplayPort.

Once in a while after inactivity, the display goes out and I see lines in the middle and I have to do a hard boot to come back to OS X. I tried disabling/enabling Graphic Standby option in iGPU but didn't help.

Is there a patch I have to do?

FYI I have sleep completely disabled.
 
Joined
Sep 20, 2015
Messages
2
Motherboard
MSI Z170A Krait Gaming 3X
CPU
Intel Core i7 6700k
Graphics
Intel HD 530
Mobile Phone
  1. Android
Awesome! What about dual monitors?
I'm gonna try when I arrive home
 
Joined
Jul 27, 2014
Messages
4
Mac
Classic Mac
Mobile Phone
Hello Everyone, I've successfully installed HD530 on a custom Mac 6,1 type with i7 6700k and a z170x gaming 5 motherboard. However, I use a 4k Samsung TV as monitor, and Sierra sees it as a TV popping out the AirPlay little menu trail icon and allows my monitor to output only 1920x1080. How can I fix this and get the full 4k resolution working? (The cable is hdmi 2.0)

EDIT: this happens when using the id 0x19120000, if I delete this id, I get to 4k resolution but with practically no hardware acceleration (it says HD530 with 4 MB Ram instead of the 1530 with 0x19120000 profile)

EDIT: putting again the 0x19120000 profile did not revert nothing, I've no gpu acceleration and only 2 resolution available (4k and 1080) but the 1080 input is still 4k but only with retina icons and stuff! Help!
 
Last edited:
Top