Contribute
Register

Skylake Intel HD 530 Graphics Glitch Fix

Joined
Feb 18, 2017
Messages
12
Motherboard
H110M Gaming
CPU
i3 6100
Graphics
HD 530, MSI GTX 970 Gaming
Mac
MacBook
Mobile Phone
iOS
In my setup I used ig-platform-id 0x19120000 and Inject Intel true, however you might try different values. The most important config part is below.

Add to clover config:
Code:
<key>Devices</key>
<dict>
    <key>AddProperties</key>
    <array>
        <dict>
            <key>Device</key>
            <string>IntelGFX</string>
            <key>Key</key>
            <string>AAPL,GfxYTile</string>
            <key>Value</key>
            <data>
            AQAAAA==
            </data>
        </dict>
    </array>
</dict>
View attachment 218567

Thanks to PikerAlpha for discovering AAPL,GfxYTile

Thank you, working perfectly on i3 6100 + H110M Gaming
 
Joined
Dec 7, 2016
Messages
70
Motherboard
Asus Z170M-PLUS
CPU
Intel i5 6500
Graphics
HD530
Mac
iMac
Mobile Phone
iOS
In my setup I used ig-platform-id 0x19120000 and Inject Intel true, however you might try different values. The most important config part is below.

Add to clover config:
Code:
<key>Devices</key>
<dict>
    <key>AddProperties</key>
    <array>
        <dict>
            <key>Device</key>
            <string>IntelGFX</string>
            <key>Key</key>
            <string>AAPL,GfxYTile</string>
            <key>Value</key>
            <data>
            AQAAAA==
            </data>
        </dict>
    </array>
</dict>
View attachment 218567

Thanks to PikerAlpha for discovering AAPL,GfxYTile
Hi I'm trying to install Sierra but when I tryed to boot in my bootable usb installer it froze in the middle of the charging bar I have tryed to set the id 0x19120000 and than I had a permanent apple logo glitch. Here you can see the verbose mode
 

Attachments

Joined
Oct 9, 2016
Messages
15
CPU
Intel i5 6600K
Graphics
Intel HD 530, NVIDIA GeForce GTX 960 4095 MB
Mac
iMac
The glitch disappeared after update to 10.12.4 (16E195)
 
Joined
Aug 19, 2010
Messages
515
Motherboard
GA-Z390 Designare
CPU
i7 9900K
Graphics
UHD630 & Radeon VII
Mac
MacBook Air, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
The glitch disappeared after update to 10.12.4 (16E195)
Are you saying that in 10.12.4 the glitch is gone, even without any clover patches or other "glitch fix" methods?
What about when using a discrete GPU along with HD530?

Thanks,
g\
 
Joined
Aug 13, 2013
Messages
72
Motherboard
GA-Z170X-UD5 TH
CPU
i7-7700K
Graphics
Integrated Graphics Processor with MegaChips MCDP2800
Mac
iMac
I have upgraded to Serra 10.12.4 but glitch is NOT gone unfortunately:(
Board GA-Z170X-UD5 TH
 

aol

Joined
Apr 14, 2011
Messages
514
Motherboard
GA-Z370-HD3P
CPU
i7-8700K
Graphics
RX570
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I have upgraded to Serra 10.12.4 but glitch is NOT gone unfortunately:(
Board GA-Z170X-UD5 TH
I am using a DVI monitor and an HDMI monitor on a 530 (no discrete GPU). I was using a series of patches to enable the 530 and to fix the Sierra glitches. With the 10.12.4 update, I removed ALL fixes/patches related to the 530 and have dual monitors working without glitches on Sierra (dual monitors requires only one monitor on during boot/POST).

lordstar did you remove and/or disable ALL fixes/patches?
- rename GFX to IGPU patch: remove/disable
- 4 port patch: remove/disable
- inject intel: uncheck
- ig_platform_id: clear value
- Sierra "glitch" patches: remove/disable
- port/connector patches that assign a specific connector type to specific ports mainly required for dual monitors: remove/disable

I use a SMBIOS (iMac14,2) that does not seem to require the ADGPFix for dual monitors and I have not reapplied it on 10.12.4. I believe this patch is still required for dual monitors on some SMBIOSes (MacPro 6,1; iMac17,x).
 
Joined
Aug 13, 2013
Messages
72
Motherboard
GA-Z170X-UD5 TH
CPU
i7-7700K
Graphics
Integrated Graphics Processor with MegaChips MCDP2800
Mac
iMac
no problem aol thank you, I have already done! now I only with my 960 pro m.2 SSD unhappy because of speed is very poor:(
 
Joined
Aug 19, 2010
Messages
515
Motherboard
GA-Z390 Designare
CPU
i7 9900K
Graphics
UHD630 & Radeon VII
Mac
MacBook Air, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Can anyone who has hd530 working without glitches in 10.12.4, and without patches, also test with a secondary discrete card? One monitor on iGPU and one on discrete GPU. That would be amazing if this is finally resolved.
Thanks,
g\
 
Top