Contribute
Register

Skylake HWP Enable

Joined
Jun 20, 2014
Messages
979
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
Same result, HWP not work after wakeup, use Hackintool to resume HWP functional, work fine.
Made a silly mistake. Please try the attached one. Should definitely get sleep/wake messages now.
 

Attachments

Joined
Jun 24, 2016
Messages
84
Motherboard
ASUS ROG STRIX Z390-F GAMING
CPU
i9-9900K
Graphics
GT 710
I have been using HWPEnable on my Skylake i7 6700k since I first saw it here, but now I am buying a new computer with an i9-9900k, and am just wondering if this is useful for that processor as well?
 
Joined
Jun 19, 2010
Messages
3
CPU
i7-2760QM
Graphics
HD 3000
Mac
iMac, Mac mini, Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
I've commit my changes to GitHub with release binaries.
I used your version HWPEnabler.kext with my Skylake i5-6500.
HWP works before I upgraded to Catalina.
Now HWP only works before the system sleeps.
My computer always reboots after waked up.
When I remove HWPEnabler.kext, sleeping works again.
 
Joined
Jun 19, 2010
Messages
3
CPU
i7-2760QM
Graphics
HD 3000
Mac
iMac, Mac mini, Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
I used your version HWPEnabler.kext with my Skylake i5-6500.
HWP works before I upgraded to Catalina.
Now HWP only works before the system sleeps.
My computer always reboots after waked up.
When I remove HWPEnabler.kext, sleeping works again.
I found OpenCore has a solution to patch the kernel.
 
Joined
Jan 25, 2011
Messages
42
Motherboard
Gigabyte GA-Z270P-D3
CPU
I5-6600K
Graphics
R9 290X
Mac
Mac Pro
Mobile Phone
Android, iOS
@shuhung did you try this with opencore ? Whenever i set CpuIdData 0xA0060300 and CpuIdMask 0xFFFFFFFF, it fails to boot. I did various tests and the only way to enable hwp in opencore is by disabling plugintype=1 so that acpi_smc_platformplugin loads instead of x86platformplugin. This way hwp can work normally but I lose gpu power management.
Edit:
Actually after I did some more tests, it appears that gpu power management is controlled from bios since I have ASPM enabled. The gpu idles at around 300 mHz and goes to 1040 mHz under load.
 
Last edited:
Top