Contribute
Register

Sign in app store issues after 10.6.8 & Lion

Status
Not open for further replies.

eelhead

Super Moderator
Joined
Mar 1, 2011
Messages
3,117
Motherboard
GA-Z170X-Designare
CPU
i5 7600k
Graphics
GTX 1070
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
This is after updating to 10.6.8

Ok for the app store sign in issues here is a simple fix.

First go to Extra folder and check your com.apple.Boot.plist (or Library/Preferences/System Configuration if its not in extra folder)
to make sure that this string is in it,

<key>EthernetBuiltIn</key>
<string>Yes</string>

If it isn't add it restart and see if that fixes it.

__________________________________________________________________
If it is in there or if adding it didn't help you need to remove some other items
Go to,
System preferences/Network
You'll want to highlight each one and remove it by clicking the - tab at bottom of box.

Then go to,
Library/Preferences/System Configuration
and delete or place on desktop the NetworkInterfaces.plist


Then restart system.

After you restart you will want to go back to System Preferences/Network and
add all the things you removed starting with ethernet.
___________________________________________________________
If those steps don't work then try;

adding the following to your com.apple.Boot.plist:

<key>PCIRootUID</key>
<string>1</string>

Then remove the NetworkInterfaces.plist and rebooted



What I had noticed is that the ethernet was labeled en0 and Airport card was en1 and after update the numbers got switched. It was only switched in the NetworkInterfaces.plist but stayed the same in every other settings so it was give conflicting things while trying to log into the app store.

Thanks Lnx2mac :D
 
Joined
Apr 14, 2011
Messages
106
Motherboard
GA-P55M-UD2
CPU
Intel Core i7 870
Graphics
ASUS 5770
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
Re: Sign in app store issues after 10.6.8 update Fix

Just to note I did not have to delete the NetworkInterfaces.plist file, just add the EthernetBuiltIn into com.apple.Boot.plist.
 

eelhead

Super Moderator
Joined
Mar 1, 2011
Messages
3,117
Motherboard
GA-Z170X-Designare
CPU
i5 7600k
Graphics
GTX 1070
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Re: Sign in app store issues after 10.6.8 update Fix

bwhinnen said:
Just to note I did not have to delete the NetworkInterfaces.plist file, just add the EthernetBuiltIn into com.apple.Boot.plist.
Sweet, that's one option if it's not in the boot plist :)
I'll also edit first to have people check it first.
 
Joined
May 26, 2010
Messages
2
Motherboard
Mac OSX Lion 10.7.4
CPU
intel i7-930
Graphics
EVGA GTX 460
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Re: Sign in app store issues after 10.6.8 update Fix

eelhead said:
This is after updating to 10.6.8

Ok for the app store sign in issues here is a simple fix.

First go to Extra folder and check your com.apple.Boot.plist to make sure that this string is in it,

<key>EthernetBuiltIn</key>
<string>Yes</string>

If it isn't add it restart and see if that fixes it.

If it is in there or if adding it didn't help you need to remove some other items
Go to,
System preferences/Network
You'll want to highlight each one and remove it by clicking the - tab at bottom of box.

Then go to,
Library/Preferences/System Configuration
and delete or place on desktop the NetworkInterfaces.plist


Then restart system.

After you restart you will want to go back to System Preferences/Network and
add all the things you removed starting with ethernet.

What I had noticed is that the ethernet was labeled en0 and Airport card was en1 and after update the numbers got switched. It was only switched in the NetworkInterfaces.plist but stayed the same in every other settings so it was give conflicting things while trying to log into the app store.

Thanks Lnx2mac :D

My com.apple.Boot.plist was in Library/Preferences/System Configuration so I think you should add that location to this helpful guide.

And thanks for the info it worked perfectly after editing the .plist!
 
Joined
Jun 22, 2011
Messages
12
Mac
Classic Mac
Mobile Phone
Re: Sign in app store issues after 10.6.8 update Fix

The above tips aren't working for me :(

The following was already set in /Extra/com.apple.Boot.plist :

<key>EthernetBuiltIn</key>
<string>Yes</string>

..and I tried the following:

- remove all connections from System Preferences -> Network (I had 2 - 1 x Ethernet and 1 x IPSec VPN which I have for connecting to work).
- remove /Library/Preferences/System Configuration/NetworkInterfaces.plist
- reboot
- add Ethernet connection via System Preferences -> Network
- Open App Store and attempt purchase

I've tried the above 3 times, and on the 3rd attempt I even used Kext Utility to rebuild the caches before the reboot, but still the problem persists.

Any other suggestions?

Mark
====
 
Joined
Jun 1, 2011
Messages
21
Motherboard
Asus P5B-E 4GB DDR2
CPU
Intel> Need model # > See Rules!
Graphics
HD 6850
Mobile Phone
  1. iOS
Re: Sign in app store issues after 10.6.8 update Fix

Blokie said:
The above tips aren't working for me :(

I've tried the above 3 times, and on the 3rd attempt I even used Kext Utility to rebuild the caches before the reboot, but still the problem persists.

Any other suggestions?
====

Same here, didn't initially find the problem and then realised the GUID error. Hope we can fix, or it is back 10.6.7 for me!
 
Joined
Feb 22, 2011
Messages
3
Motherboard
Asus P5Q3
CPU
Intel Core 2 Duo 3 GHz
Graphics
NVIDIA GeForce GTS 450
Mac
Classic Mac
Mobile Phone
  1. iOS
Re: Sign in app store issues after 10.6.8 update Fix

I'm also still experiencing this after trying all proposed solutions. Would love to get this fixed if anyone knows anything else to try.
 

eelhead

Super Moderator
Joined
Mar 1, 2011
Messages
3,117
Motherboard
GA-Z170X-Designare
CPU
i5 7600k
Graphics
GTX 1070
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Re: Sign in app store issues after 10.6.8 update Fix

Guys make sure that when your adding the Ethernet (en0) back in that it's not getting added back in as Ethernet Device (en0). Even the name being different will mess up the authentication.
 
Joined
Jun 22, 2011
Messages
12
Mac
Classic Mac
Mobile Phone
Re: Sign in app store issues after 10.6.8 update Fix

eelhead said:
Guys make sure that when your adding the Ethernet (en0) back in that it's not getting added back in as Ethernet Device (en0). Even the name being different will mess up the authentication.

Thanks for the quick reply. Do you mean just changing the name / description of the adaptor when you add it after the restart? If so, for the first install I left the name as default "Ethernet Device (en0)", but I changed it to simply "LAN" for the 2nd and 3rd tries, and same result.
 
Status
Not open for further replies.
Top