Contribute
Register

Sidecar

Status
Not open for further replies.
Joined
Apr 1, 2012
Messages
444
Motherboard
MSI MPG Z490 Gaming Plus
CPU
i7 10700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
The BIOS gives the option of IGPU or PCIe based or auto. I have it set to auto. This is may be a dumb question but if I set the BIOS to the IGPU will I still see the boot information if the monitors are connected to the AMD GPU? It is not easy to get to the cables to switch them if I get a black screen while connected to the AMD GPU or I would experiment to find the answer.
 
Joined
Mar 10, 2011
Messages
345
Motherboard
Gigabyte Designare TRX40
CPU
Ryzen 3970x
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
The BIOS gives the option of IGPU or PCIe based or auto. I have it set to auto. This is may be a dumb question but if I set the BIOS to the IGPU will I still see the boot information if the monitors are connected to the AMD GPU? It is not easy to get to the cables to switch them if I get a black screen while connected to the AMD GPU or I would experiment to find the answer.

In my BIOS version (it is a maximus a little later, but always maximus is) iGPU can be enabled or disabled (iGPU multi monitor, the second menu item) and when it is enabled other options appear, including the one related to memory. The first field (Primary Display) must be set to Auto (attention because when the second field is enabled, it moves to IGFX and is not good.
So you don't even miss the video in the first part of the startup, keeping the cable connected to the DGPU (RX 580).
It is strange that if you enable the iGPU it will not give you the possibility to do the other relative configurations.
I found on youtube a video about the BIOS of the Maximus VIII and the options correspond to the Maximus X, maybe your problem is that you only acted on the first field and not on the iGPU multi monitor field.
 
Joined
Apr 1, 2012
Messages
444
Motherboard
MSI MPG Z490 Gaming Plus
CPU
i7 10700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
Didn't work. Setting the BIOS to dual display loads the Intel driver in Windows though.
 
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Since you said you tried to change various system profiles, in the end, which one did you stay with?
Try those for processors with iGPU.
 
Joined
Jul 16, 2011
Messages
112
Motherboard
Gigabyte Z490 D
CPU
i9 10900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hello

here i can't find my ipad pro in cataline
Config : Gygabyte Z270 with i5 7600K and RX580
Clover : smbios 18.2
Airplay detects apple tv but not the ipad
I paired through bluetooth the ipad and hackintosh, and use the same icloud account

Well > ipad detected; i was using old bluetooth chip > i used a more recent usb chip > ipad detected
Now the issue is about "device has expired" even if my igpu is detected in hacintool
 
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Now the issue is about "device has expired" even if my igpu is detected in hacintool

Does it report the same error even if you try to connect the iPad via USB cable?

(I've never tried the Sidecar connection via bluethooth, always used Wi-Fi, I didn't even know it was possible, I'll try, thanks)
 
Joined
Jul 14, 2014
Messages
2
Motherboard
ASUS Z10PE-D16 WS
CPU
Xeon E5-2618L V3
Graphics
RX560
Mobile Phone
  1. iOS
If you do a little research on google with "how to enable older Macs in Sidecar on Catalina" you can find different indications to a terminal command that should enable them.
That didn't works, I tried.
 
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Well > ipad detected; i was using old bluetooth chip > i used a more recent usb chip > ipad detected
Now the issue is about "device has expired" even if my igpu is detected in hacintool
I tried only with Bluethooth but it gives me an error message and tells me that without Wi-Fi on, it cannot be connected.
 
Status
Not open for further replies.
Top