Contribute
Register

Sidecar

Status
Not open for further replies.
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Sidecar is working well for me. I have the iPad tethered - haven't actually tried it wireless, as it's a test device that is permanently on my desk.

From what I can read your configuration is very similar to mine: same motherboard and same processor, different video card.
We're both on beta 6, and I think you keep the iPadOS beta up to date.
Using the cable there should be no difference or lack of data transmission, so what could prevent mine from working properly?
On iPad the error is -401, and is the same in cable and in Wi-Fi (when Wi-Fi was working, in beta 4).
In the few seconds it connects, before reporting the error, even if there is a black screen, the ipad dock icon controls the dock on the Mac, so even the partial functionality seems to be there.
Do you have a Wi-Fi card mounted, if so which one?
Do all your USB ports on Catalina work as well as on Mojave?
If you go to the system information and open the panel with the system report: under USB, selecting the connected iPad, the detail of the information which speed indicates you?
 
Last edited:
Joined
Mar 10, 2011
Messages
345
Motherboard
Gigabyte Designare TRX40
CPU
Ryzen 3970x
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
mine starting working tonight
ipad OS beta 7 17A5572a
and Catalina beta 6 19A536g
you must have Intel GPU enabled in BIOS or you get poor connection on the iPad
 
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
First of all, thanks for sharing.
My versions of Catalina and iPadOS are the same: the latest ones available, to date.
I had begun to do timid tests to enable the iGPU but without results and with problems because I moved the display port cable and instead of putting the function on Auto I put it on IGFX and therefore I made a disaster with the rx 580 ... let's forget ... .
The desire to try came to me looking at the configuration of Samdeane which is practically different from mine only because of the lack of the rx 580 and consequently its obvious enabling of the iGPU.
My problem is that I am in SMBIOS 1.1 configuration for the features with the DRM (on Mojave) that I described and in order to work with the enabled iGPU I have to switch to another one.
Now on Catalina (which is the system of experiments anyway) I tried to set the 19.1 which is not the specific one for my set (it should be more 18.3), but the system started without problems and Sidecar has begun to function completely.
The problem is to enable or disable the iGPU each time, passing from Catalina to Mojave, because in any case I would not like to lose the functionality of the DRM sites with Safari on Mojave in 1.1 and that now here on Catalina, with 19.1 have taken some steps ahead (with the 1.1 they played that strange trick of losing the functionality of the mouse buttons and then restarting the system), in the sense that no longer crash the system, but still do not display the videos.
In short, in my situation, if things do not change or an alternative solution does not come out, it seems that in the future, with Catalina as the official system, I would earn Sidecar and the news, but in any case I would lose the DRM on Safari and this annoys me a lot, because on the browsers in which it works anyway, it does it in low quality.
One step at a time ... until 10.15.3 there is time and a lot can change.
Thanks again.

edit:
I tried to set SMBIOS to 18.3, but Sidecar does not work well and not immediately, but after a little while it creates the same error -401 that it gave without iGPU, as well as not working properly as a second screen, but only as a duplication.
On the DRM front no improvement compared to before, so I go back to 19.1 hoping not to discover other problems for the stretched configuration compared to my components.
 
Last edited:
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
With the new update to IpadOS 13.1 beta 2 Sidecar has stopped working; in the last versions 13.0 it worked perfectly, I have not verified the 13.1 beta 1.
Return this message on the PC: "Sidecar requires a newer version of macOS."
My current Catalina version is the beta 7: (19A546d).
Does it work properly for those with the same versions?
Thanks in advance.
 
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
With the new update to Catalina beta 8: (19A558d) and the new update of the iPadOS 13.1 beta 3, Sidecar is back in perfect working order.
Apparently I'll never know if the previous version stopped working just for me or it was a common thing ... :)
 
Joined
Apr 18, 2011
Messages
1,442
Motherboard
<< need manufacturer and model # >> See Forum Rules !!
CPU
<< need model # >> See Forum Rules !!
Graphics
<< need model # >> See Forum Rules !!
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Has anyone gotten sidecar to work with the iMacPro SMBIOS? I’m assuming we’ll need to somehow emulate the T2 chip for this to work since the iMac Pro (and upcoming Mac Pro) don’t have an integrated gpu. :(
 
Joined
Jul 14, 2014
Messages
2
Motherboard
ASUS Z10PE-D16 WS
CPU
Xeon E5-2618L V3
Graphics
RX560
Mobile Phone
  1. iOS
Oh hell.. looks like no luck on old CPUs, even my Mac mini '14 doesn't works with SideCar.
 
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Oh hell.. looks like no luck on old CPUs, even my Mac mini '14 doesn't works with SideCar.

If you do a little research on google with "how to enable older Macs in Sidecar on Catalina" you can find different indications to a terminal command that should enable them.
I haven't been looking for this command for more than a month, so I don't know what's new in its operation.
We talk about Mac and not about Hackintosh, as your Mac mini seems to be.
Also here on this discussion you can find something a little further back.
My problem to make it work was different and surely it will be so also for many others with the Hachintosh.
 
Joined
Apr 1, 2012
Messages
444
Motherboard
MSI MPG Z490 Gaming Plus
CPU
i7 10700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
Now that the final version of Ipad OS is available I still can't get Sidecar to work. My ipad Pro is recognized but no matter what system profile I use I get the 402 error. I see conflicting information about whether or not Sidecar will work with a Skylake CPU with some users claiming no problems.
 
Joined
Jan 23, 2019
Messages
190
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Now that the final version of Ipad OS is available I still can't get Sidecar to work. My ipad Pro is recognized but no matter what system profile I use I get the 402 error. I see conflicting information about whether or not Sidecar will work with a Skylake CPU with some users claiming no problems.

Have you activated the IGPU in the BIOS?
 
Status
Not open for further replies.
Top