Contribute
Register

Solved > Shutdown & Power Management don't work after Clover 5120+ & OCQuirks

Joined
Jan 4, 2014
Messages
75
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. Android
I need some help with shutdown and sleep that don't work anymore after I have updated Clover with the OCQuirks stuff. (so now I switched back to Clover 5119 and the good old OsxAptioFix2Drv-free2000.efi)

I am pretty sure the problem is somehow casued by the "new" OCQuirks, since if I put back the OsxAptioFix2Drv-free2000.efi, it works fine even on Clover 5120.

The config of my hackintosh is the one on my profile, and I have attached the 5122 EFI that boots just fine, but doesn't allow me to shutdown or to put the system to sleep/wape up.
I hope someone can figure what's going on with this!
 

Attachments

  • EFI.zip
    3.5 MB · Views: 42

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,813
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
good old OsxAptioFix2Drv-free2000.efi

Screenshot 2020-10-10 at 12.20.33.png
 
Joined
Jan 4, 2014
Messages
75
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. Android
I didn't know the free2000 could be so terrible! I also never had such severe hardware issues he's mentioning.

By the way, I have tried replacing it and using AptioMemoryFix and OsxAptioFix3Drv, but I have the shutdown issue with these too, same as using OCQuirks. The only memory driver that allows me reboot or shutdown is OsxAptioFix2Drv-free2000.
So the issue might be somewhere else in my config...
 
Joined
Jan 4, 2014
Messages
75
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Ok, I've found a solution myself!
Googling some more, I've found that a missing EmuVariableUefi.efi could lead to some NVRAM issues, also related with the shutdown process.
Adding it solved my problem.
Now the system can correctly shutdown with OCQuirks stuff. :)
 
Joined
Mar 9, 2011
Messages
672
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Ok, I've found a solution myself!
Googling some more, I've found that a missing EmuVariableUefi.efi could lead to some NVRAM issues, also related with the shutdown process.
Adding it solved my problem.
Now the system can correctly shutdown with OCQuirks stuff. :)
Really? I tried it and it didn't work for me :(
 
Joined
Mar 9, 2011
Messages
672
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Yes, I have shutdown / reboot / sleep again. Did it worked with your previous memory driver before OCQuirks?
Yes it did work. I was using the naughty OsxAptioFix2Drv-free2000.efi I still am until I can sort the shutdown thing. I might try your efi folder with emuvariable
 
Joined
Jan 4, 2014
Messages
75
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Yes it did work. I was using the naughty OsxAptioFix2Drv-free2000.efi I still am until I can sort the shutdown thing. I might try your efi folder with emuvariable
Yes, you can try it. The emuvariable is the only difference with my actual EFI. I would suggest you to backup somewhere your actual EFI before trying this!
 
Top