Contribute
Register

Solved > Shutdown and sleep issues with Fenvi FV-T919 WiFi card

Joined
Nov 8, 2013
Messages
60
Motherboard
Gigabyte Z370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
128K, Color Classic, Portable, Power Mac, PowerBook, SE/30
Mobile Phone
iOS
Hi there,

Up until now my Hackintosh was running fine with the recommended TP-Link Archer T9E WiFi card. I just replaced it with a Fenvi FV-T919 so I could get Continuity and Handoff working. All is fine on that side!

But now it won't sleep anymore, and restarts by itself after a shutdown. Note that I updated my SSDT file to reflect the use of an internal USB port for Bluetooth. I guess it's USB related, as are most sleep issues. Any idea where to start to sort this out?

I can provide any relevant log and files… Thanks in advance for your help!

EDIT: I thought I had found the solution thanks to this thread. I added the EmuVariable-Uefi-64.efi driver and enabled the slide=0 bootfalg in config.plist, but nothing changed. Anybody knows what I'm missing?
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
8,752
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 5700 XT
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Are you using OsxAptioFix2Drv-free2000?
 
Joined
Nov 8, 2013
Messages
60
Motherboard
Gigabyte Z370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
128K, Color Classic, Portable, Power Mac, PowerBook, SE/30
Mobile Phone
iOS
Did you check box next to FixUSB in clover?
I hadn't. Just tried, but sadly it doesn't seem to change anything…

Also, ErP setting set to enable in bios should help.
Just tried, and doesn't seem to change anything neither… Thanks anyway for your help, I appreciate it!
 
Joined
Nov 8, 2013
Messages
60
Motherboard
Gigabyte Z370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
128K, Color Classic, Portable, Power Mac, PowerBook, SE/30
Mobile Phone
iOS
Are you using OsxAptioFix2Drv-free2000?
I was using OsxAptioFix2Drv-64.efi. I hadn't tried OsxAptioFix2Drv-free2000, since in the other thread you were advising to try it in cas of an allocation error I don't have. I just tried it now, but sadly it doesn't change. The Hackintosh still robots itself when I shut it down, and wakes up immediately after going to sleep… Thanks anyway for your help!
 
Joined
Nov 8, 2013
Messages
60
Motherboard
Gigabyte Z370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
128K, Color Classic, Portable, Power Mac, PowerBook, SE/30
Mobile Phone
iOS
Problem finally solved.
I ditched the Fenvi FV-T919 WiFi/BT card and replaced it with the cheaper Fenvi FV-HB1200. As I hoped, my Hackintosh shuts down fine and sleeps like a baby…
 
Joined
Mar 5, 2020
Messages
10
Motherboard
Gigabyte Z390 UD
CPU
i3-9100
Graphics
UHD 630
Mac
iMac, Mac mini
Classic Mac
Apple, Performa, PowerBook
Mobile Phone
iOS
@superpantoufle Wow, that's all!? I just got the Fenvi T919 and am having the same issue on a Gigabyte Z390 UD. Just curious, what led you to trying the HB1200 instead? Did you have to do anything else to keep the HB1200 from interfering with sleep/shutdown? (For example, did you have to keep EmuVariableUEFI.efi?) Mine also will occasionally get stuck in a reboot loop before it even loads the Gigabyte splash screen, which leads me to believe the motherboard itself doesn't like this card for some reason, even though it works perfectly fine when MacOS is running.
 
Top