Contribute
Register

Setup Guide for Gigabyte BRIX and BRIX Pro using Clover

Joined
Dec 14, 2014
Messages
39
Motherboard
GB-BXi7-4770R
CPU
i7-4770R
Graphics
Iris Pro 5200
Mac
Classic Mac
Mobile Phone
Anyone ever put 32GB of RAM into the 4770R Brix Pro?

I hit my head up against the 16GB RAM recently and wondered if it was possible to put it in and recognize it in macOS. I don't have this kind of RAM laying around and wondered if anyone else has tried it.

Also, there's some new Brix's on the way... http://www.gigabyte.us/Mini-PcBarebone/GB-BNi7HG6-1060-rev-10
Would love a dedicated GPU, but not sure how this would work with macOS and hackintoshing.
 
Joined
Dec 14, 2014
Messages
39
Motherboard
GB-BXi7-4770R
CPU
i7-4770R
Graphics
Iris Pro 5200
Mac
Classic Mac
Mobile Phone
Just updated clover to 4114 and then updated to 10.12.6 with no issues on my BrixPro 4770R. Just FYI.
 
Joined
Jan 6, 2011
Messages
25
Motherboard
GA-Z97X-UD7-TH
CPU
i7 4790K
Graphics
Gigabyte GTX 970 Gaming 1
Mac
Classic Mac
Mobile Phone
Anyone has been able to get 4K in High Sierra?
 
Joined
Sep 13, 2012
Messages
3
Motherboard
ASUS G551
CPU
i7 4770HQ
Graphics
GTX 860m
Mac
Classic Mac
Mobile Phone
Anyone gotten their hands on a beta of High Sierra and loaded to a Brix Pro 4570/4770 yet? Isnt the final build supposed to come out next week? Instructions available if completed successfully? Planning on wrecking my current box (10.12.6) testing once the final High Sierra build is available otherwise.
 
Joined
Sep 13, 2012
Messages
3
Motherboard
ASUS G551
CPU
i7 4770HQ
Graphics
GTX 860m
Mac
Classic Mac
Mobile Phone
Anyone gotten their hands on a beta of High Sierra and loaded to a Brix Pro 4570/4770 yet? Isnt the final build supposed to come out next week? Instructions available if completed successfully? Planning on wrecking my current box (10.12.6) testing once the final High Sierra build is available otherwise.
09/27/17:
SO, I successfully installed High Sierra final. Updated from 10.12.5 -> 10.13. Fresh installed 10.12.5 from a flash drive (testing only; F'd up my system first time around due to stupidity), loaded Multibeast to get audio/NiC working and followed Tony Mac's upgrade guide here.

**Please note that I am using an SSD as hopefully most people are for their system drives. I followed instructions for APFS as its supposed to be made for SSD. I can confirm my SSD was converted to APFS during the install. Tony's note says Multibeast 9.21 doesn't work with APFS. I am using Multibeast 9.10 which apparently does.

For clarification, I needed to add some of the kexts from my previous post so if you already have them in place, you should just need to follow Tony Mac's guide. Just make sure you have the following prerequisites in place:

1. Downloaded newest clover 2.4K_r4220 from here and installed. Rebooted.

2. Downloaded EFI Mounter v3 from here, launched and mounted EFI volume (you'll need this for next couple steps)

3. If files not already there, downloaded FakeSMC, RTL8111, NullCPUPowerManagement from here, copied to /EFI/CLOVER/kexts/Other/

4. Used link from Headkaze and downloaded HFSPlus.efi
https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
Copy HFSPlus.efi to EFI/CLOVER/drivers64UEFI

5. Per Tony Mac, downloaded APFS.efi from here and also copied to EFI/CLOVER/drivers64UEFI

6. Followed Tony Mac's guide which is basically at this point just downloading High Sierra from App Store, launching, and selecting "Boot from update on Sierra". Watch your system reboot itself a couple times and take 30-40 mins to complete.

Notes: NiC working. HDMI audio working after install until rebooted a couple times, then it disappeared. Found updated script from Toleda here which also got me headphone and digital audio back. Download and run.
 
Last edited:
Joined
Jun 20, 2014
Messages
854
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
Anyone has been able to get 4K in High Sierra?
I'll quote my post from the High Sierra thread for your convenience:
Successfully updated to macOS 10.13 High Sierra.

- Dual boot High Sierra + Windows 10
- 4k 1080p60 HiDPI working (using CoreDisplayFixup)
- I opted to keep the file system as HFS+ (using --converttoapfs NO)
- Ran audio_cloverALC-130_v0.3.command to restore audio

Had a few issues along the way:
- An error occurred while verifying firmware
- The path /System/Installation/Packages/OSInstall.mpkg appears to be missing or damaged

To solve the above two issues run the latest version of Clover Configurator and re-select your system configuration to update the SMBIOS info (I recommend pasting back your Serial Number if you've already got iMessage etc. working).

For working 4k I compiled the latest versions of Lilu 1.2, Shiki, IntelGraphicsFixup and CoreDisplayFixup. You can download my compiled versions here: Lilu 1.2 + Plugins.zip.
 
Last edited:
Joined
Dec 14, 2014
Messages
39
Motherboard
GB-BXi7-4770R
CPU
i7-4770R
Graphics
Iris Pro 5200
Mac
Classic Mac
Mobile Phone
I'll quote my post from the High Sierra thread for your convenience:
I'm considering wiping my install and starting over with APFS rather than taking the upgrade path. I assume that I can just copy over my clover data and still keep the same system profile for the iMessage stuff (rather than create a new one). Anyone done this recently?
 
Joined
Jan 6, 2018
Messages
19
I have a working Brix i7-5770. Would you like my config.plist to get you going?
That would be awesome!. Thanks in advance. One question, is this broadwell or haswell? I see Brix has i7-4770 (Haswell) or i7-5775(Broadwell). Haven't seen a i7-5770 ?
 
Top