Contribute
Register

Setup Guide for Gigabyte BRIX and BRIX Pro using Clover

Joined
Jun 20, 2014
Messages
978
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
If you have an Iris Pro 5200 and it's crashing in macOS Sierra when viewing video in Safari, check out the following post. So far it is working for me.
While there were no crashes I would get graphics glitches sometimes after my PC came out of sleep which would require a reboot to fix. So I don't recommend this patch for HD 5200 anymore.

Now I'm trying IntelGraphicsFixup.kext (along with Lilu.kext and Shiki.kext) using Clover injection.

Apparently it:
- Fixes boot logo on all known Intel Graphics.
- Fixes PAVP freezes on Intel Azul Graphics.

I'll report back any issues.
 
Last edited:
Joined
Aug 7, 2011
Messages
21
Mac
Classic Mac
Mobile Phone
Successfully updated from 10.11.6 to 10.12 (final) on BRIX GB-BXi5-4570R!

*Changed system definition to iMAC 15,1 (Multibeast) for App store to allow download
*Installed Clover 2.3k_r3716 (3751 and 3761 boot looped my system)

-Followed Tony Mac's guide:
http://www.tonymacx86.com/threads/direct-update-to-macos-sierra-using-clover.201465/

-For #2, downloaded FakeSMC, RTL8111, NullCPUPowerManagement, copied to /EFI/CLOVER/kexts/Other/

-Used link from Headkaze and downloaded HFSPlus.efi
https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
Copy HFSPlus.efi to EFI/CLOVER/drivers64UEFI

-Start upgrade, system will reboot.
Highlight "Boot macOS Install", press space bar and select these options:
*Boot without caches
*Inject kexts
*Verbose
*Start with above options
Newest version of clover removed boot without cache and inject next option and I'm having a lot of issues upgrading my brix i7 5775. I'm coming from 10.11.6 and followed the instructions as best I could but get stuck at the spinning colored cursor after the grey apple logo.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
21,629
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Newest version of clover removed boot without cache and inject next option and I'm having a lot of issues upgrading my brix i7 5775. I'm coming from 10.11.6 and followed the instructions as best I could but get stuck at the spinning colored cursor after the grey apple logo.
Grey screen and spinning wheel while upgrading is usually caused by not having FakeSMC.kext in /EFI/CLOVER/kexts/Other.
 
Joined
Aug 7, 2011
Messages
21
Mac
Classic Mac
Mobile Phone
Grey screen and spinning wheel while upgrading is usually caused by not having FakeSMC.kext in /EFI/CLOVER/kexts/Other.
I added FakeSMC, RealtekRTL8111, and NullCPUPowerManagement into Other already. Still doing it.
 
Joined
Aug 7, 2011
Messages
21
Mac
Classic Mac
Mobile Phone
Alright folks I'm spinning my wheels here. Managed to update to Sierra but now I am unable to boot unless I am in safe mode. I looked up some info and after I disabled VTd in the bios the apple logo comes up with the loading bar which reaches about 98% of the way then the system locks up. If VTd is enabled, I get only half way with the progress bar.

-v says something about AppleHDADriver. I am not sure if this means it is missing or what. I dont know how else to proceed. Any help would be appreciated.

Gigabyte i7 5775
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Alright folks I'm spinning my wheels here. Managed to update to Sierra but now I am unable to boot unless I am in safe mode. I looked up some info and after I disabled VTd in the bios the apple logo comes up with the loading bar which reaches about 98% of the way then the system locks up. If VTd is enabled, I get only half way with the progress bar.

-v says something about AppleHDADriver. I am not sure if this means it is missing or what. I dont know how else to proceed. Any help would be appreciated.

Gigabyte i7 5775
Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I cant boot anymore. I can't collect anymore information except the picture I attached of booting using -v. I use to be able to boot into safe mode but I just tried and it doesnt work. I pressed F2 F4 and that doesnt seem to be doing anything.
You will need to still provide verbose boot photo and the EFI/Clover you're trying to use.
You should have a working USB that can be used to boot your system, or if you're trying to boot from USB, it should be quite easy to collect EFI/Clover from that USB and upload it.
 
Joined
Aug 7, 2011
Messages
21
Mac
Classic Mac
Mobile Phone
You will need to still provide verbose boot photo and the EFI/Clover you're trying to use.
You should have a working USB that can be used to boot your system, or if you're trying to boot from USB, it should be quite easy to collect EFI/Clover from that USB and upload it.
I don't have a working USB. My system has been working flawlessly for months and in that time I have lost my only 8gb usb drive. I posted a pic of the system in verbose mode. I'll see if I can find another USB drive.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I don't have a working USB. My system has been working flawlessly for months and in that time I have lost my only 8gb usb drive. I posted a pic of the system in verbose mode. I'll see if I can find another USB drive.
Then in order to provide the files required, you would need to attach the HDD to a working computer such that you can upload the data.

Your verbose boot shows a pile of potential causes... some of which might be mistakes on your system partition, which would not even be diagnosable with EFI/Clover.
 
Top