Contribute
Register

Setup Guide for Gigabyte BRIX and BRIX Pro using Clover

Status
Not open for further replies.
Joined
Jul 30, 2013
Messages
10
Motherboard
GA-H110M-S2H
CPU
Intel Skylake Processeur Core i7-6700K 4.0 GHz
Graphics
MSI GeForce® GTX 960 Gaming 2G
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. SE
Mobile Phone
  1. iOS
Joined
Jul 3, 2011
Messages
2
Motherboard
Make/model
CPU
i7-2600K
Graphics
HD 6850
So, I recently bought the brix pro I7 version and managed to get osx installed following all the guides to the letter. Then, I used the attached ssdt and all the kexts as well as the config file and did with them what i was supposed to. I am currently facing two problems. 1. HDMI audio is not working (it is not listed as an output in system prefs). 2. Upon boot my display shows white noise before it reaches the login screen. I appreciate any help i can receive and let me know if you need anything from to figure out just what the issue is.

Thanks
 
Joined
May 8, 2014
Messages
4
Motherboard
Brix Pro
CPU
i5-4570R
Graphics
Iris Pro 5200
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I just got everything working with Mavericks and my Brix Pro i5. I bought a cheap used Atheros wi-fi card and am going to order a Bluetooth 4 usb thingy. Also, there is no audio working with the headphone, but I just use a usb-headphone jack adaptor to get that going. Everything is good so far.
 

nobodynose

Moderator
Joined
Sep 29, 2012
Messages
3,931
Motherboard
ASRock Z370M Pro4
CPU
i7-8700
Graphics
RX 560
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iBook
  2. iMac
  3. Quadra
Mobile Phone
  1. Android
  2. iOS
1. Follow main Install OS X Mavericks using Clover guide here:
http://www.tonymacx86.com/mavericks...-how-install-os-x-mavericks-using-clover.html

When editing/replacing files on the Clover USB in STEP 2 and STEP 4:

2. Place attached SSDT.aml in /Volumes/EFI/EFI/CLOVER/ACPI/patched/

3. Place attached config.plist in /Volumes/EFI/EFI/CLOVER/

4. Place attached kexts in /Volumes/EFI/EFI/CLOVER/

Just to share my experience with the Brix BXPi3-4010 Projector model - I tried for 2 weeks to get it working with Mac OS X, and failed. I couldn't get the projector to work, nor power management, northern ALC269 audio. I finally gave up and returned it for an Intel Haswell NUC, the i3-4010U model. That also was a mistake, as I never could get audio nor power management working. I tried several guides, using Clover, Chimera, and Chameleon but nothing I tried worked. So I returned that also and have ordered a previous generation NUC, the i3-3217U model, which I know I'll be able to get running since there are multiple guides available here. Kind of disappointing, but the Ivy Bridge CPU will serve my needs. I just wish it had USB 3.0; having only USB 2.0 seems like a glaring omission in this day and age.
 
Joined
Jun 16, 2012
Messages
59
Motherboard
Lenovo x270
CPU
i7-7500
Graphics
HD 620
Hi,

I want to make one of these. I just want to make sure that if I purchase the 4770r version of this, that it will work. Also, do you know if everything is working (sleep, turbo to 3.9 ghz, etc.).

Please let me know.

Thanks.
 
Joined
Jun 16, 2012
Messages
59
Motherboard
Lenovo x270
CPU
i7-7500
Graphics
HD 620
Hello,

I bought the 4770r version recently. I got everything to work perfectly last night. I started play with confit.plist in an attempt to get iMessage working and it killed my install. I finally finished reinstalling, but cannot get networking to go for some reason. I placed the 2 kext's in the EFI drive, in the 10.9 folder. I then reboot and the Ethernet controller does not show up in setup.

Networking does work in windows.

Could someone point me in the right direction to troubleshoot?

Thanks.
 
Joined
Jun 16, 2012
Messages
59
Motherboard
Lenovo x270
CPU
i7-7500
Graphics
HD 620
Hi,

I just wanted to follow up because my issue has just been solved. I needed to boot without caches. If you press the spacebar on the item you want to boot, the option will come up.

Thanks.
 
Joined
Jun 16, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
Hello,
Apologies should this reply be posted in the wrong thread but I'm completely new to this and would really like to be able to install OSX on a Gigabyte BRIX XM12-3227. Is this possible and how do I go about this please?
Thank you.
 
Joined
Jun 16, 2012
Messages
59
Motherboard
Lenovo x270
CPU
i7-7500
Graphics
HD 620
Hi gang,

So far this system works beautifully. Everything just works and it's stable, except for one thing. Sleep and wake works most of the time for me. Every now and then, I will attempt to put my brix pro to sleep, but it ends up rebooting.

Have any of you seen this behavior?

Any clues on how to remove this last and FINAL bug?

Thanks.
 
Joined
Jul 3, 2012
Messages
7
Motherboard
Put you hackintosh motherboard make/model # here
CPU
Intel processor make/model #
Graphics
Radeon 6970 x 2 Crossfire
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Apologies if this has been answered before, I searched and couldn't find a clear answer. I was wondering if there is any additional info related to dual-booting windows 7 with OSX Mavericks on the gigabyte brix pro? Has anyone achieved this or know of any special instructions to watch out for? I'm haven't had a lot of experience with Hackintosh, I sucessfully installed OSx on my Dell mini 9 many years ago, but haven't had a system compatible with it until now. It looks like many users are successfully installing OSX Mavericks on Brix, and I would love to give it a go. I have an installation USB ready having followed the Clover instructions and placed kexts etc in appropriate folders, I am assuming I will just need to partition the hard drive with 2 partitions, one for OSX and one for windows, and install OSX to the mac partition? Any help is most appreciated, I would really like to get the info before I start the project as time is a factor, I can't really afford to have the Brix down for too long :) (I realise this might be wishful thinking, as the Dell Mini 9 project took me an entire weekend of messing around to get it finally up and running!)

Thanks in advance!
 
Status
Not open for further replies.
Top