Contribute
Register

[SEMISUCCESS] Yosemite - Asus h97-plus - i5 4690 - intel 4600

Joined
Feb 19, 2014
Messages
13
Motherboard
Asus h97-plus
CPU
intel i5 4590
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone
[SUCCESS] Yosemite - Asus h97-plus - i5 4690 - intel 4600

Hi! I'm new here but not in hackintosh world, this is my third hackintosh.

I've been able to install Yosemite via unibeast: It boots from usb even without the -v, using 2 RAM modules (2x8gb).
I installed Yosemite on the SSD (Crucial mx100 256gb) and I have Snow leopard and windows 7 in the standard hd (they come from the previous hackintosh).
I used Multibeast to install some kext.

I wrote SEMISUCCESS because i have some troubles:
- can't boot without USB memory with unibeast
- no audio (hda 887)
- fcpx hangs (similar to http://www.tonymacx86.com/401-install-bootloader-extra-efi-partition/comments4.html#comments)

I've tried with the guide posted here (http://www.tonymacx86.com/401-install-bootloader-extra-efi-partition.html#comments) but i still have the boot0 error.

Can someone please help me?
Thanks
 
Last edited:
Joined
Feb 19, 2014
Messages
13
Motherboard
Asus h97-plus
CPU
intel i5 4590
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,494
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
Hi! I'm new here but not in hackintosh world, this is my third hackintosh.

I've been able to install Yosemite via unibeast: It boots from usb even without the -v, using 2 RAM modules (2x8gb).
I installed Yosemite on the SSD (Crucial mx100 256gb) and I have Snow leopard and windows 7 in the standard hd (they come from the previous hackintosh).
I used Multibeast to install some kext.

I wrote SEMISUCCESS because i have some troubles:
- can't boot without USB memory with unibeast
- no audio (hda 887)
- fcpx hangs (similar to http://www.tonymacx86.com/401-install-bootloader-extra-efi-partition/comments4.html#comments)

I've tried with the guide posted here (http://www.tonymacx86.com/401-install-bootloader-extra-efi-partition.html#comments) but i still have the boot0 error.

Can someone please help me?
Thanks
Snow Leopard? If this was working on a previous build then the Snow Leopard boot loader will over ride the Yosemite boot loader. So you will need the boot loader from Your Yosemite USB to get access to the new Yosemite installation.

Remove the HDD (Snow Leopard and Windows) from the board and see if it boot correctly.
 
Joined
Feb 19, 2014
Messages
13
Motherboard
Asus h97-plus
CPU
intel i5 4590
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone
I've already tried to remove the HDD without success.
I've tried installing clover on the EFI partition of the SSD where I installed yosemite, but the result is always the same: boot0 error.

The strange thing is when I select "disable CSM" and then reboot, the system is unable to find any bootable device, even the yosemite USB.
When I put "AUTO CSM" the system can boot at least from USB.
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,494
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
I've already tried to remove the HDD without success.
I've tried installing clover on the EFI partition of the SSD where I installed yosemite, but the result is always the same: boot0 error.
Did you try using the Boot0 guide:
http://www.tonymacx86.com/25-boot0-error-official-guide.html

The strange thing is when I select "disable CSM" and then reboot, the system is unable to find any bootable device, even the yosemite USB.
When I put "AUTO CSM" the system can boot at least from USB.
I am not so familiar with the Asus UEFI options. I expect that if you are able to load optimised defaults and then check these settings then you should be good to go:
http://www.tonymacx86.com/user-buil...ild-z97-i3-4340-hd4600-thunderbolt-ex-ii.html
 
Joined
Feb 19, 2014
Messages
13
Motherboard
Asus h97-plus
CPU
intel i5 4590
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone
[SUCCESS] Yosemite - Asus h97-plus - i5 4690 - intel 4600

Hi Adrian, sorry for the late answer.
Using the guide for boot0 error I was able to boot to yosemite without using the installation usb memory but without clover.
Finally, using multibeast and chimera installation, now i'm able to boot to chimera and select the multiple os that i have in the HDD.
Anyway, using boot menu, i'm able to select to boot from the efi partition using clover, but i'm not able to load yosemite due to the error "unable to find driver for this platform: "ACPI\".n"@/SourceCache/xnu/xnu-1504.15.2/iokit/Kernel/IOPlatformExpert.cpp:1378"

Using toleda method i have audio. So this hack is now a SUCCESS :)

The only thing that i'm trying to improve is the boot time. Using the ssd i was expecting a faster boot time. What can i do to resolve this?
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,494
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
Hi Adrian, sorry for the late answer.
Using the guide for boot0 error I was able to boot to yosemite without using the installation usb memory but without clover.
Finally, using multibeast and chimera installation, now i'm able to boot to chimera and select the multiple os that i have in the HDD.
Anyway, using boot menu, i'm able to select to boot from the efi partition using clover, but i'm not able to load yosemite due to the error "unable to find driver for this platform: "ACPI".n"@/SourceCache/xnu/xnu-1504.15.2/iokit/Kernel/IOPlatformExpert.cpp:1378"

Have you managed to sort this problem? If using Clover then I suggest posting in the Alternate boot loader section:
http://www.tonymacx86.com/alternate-bootloaders/

Using toleda method i have audio. So this hack is now a SUCCESS :)
Good that audio is working well. :thumbup:

The only thing that i'm trying to improve is the boot time. Using the ssd i was expecting a faster boot time. What can i do to resolve this?
What sort of time does it take to boot Yosemite from the boot menu before you get to the login or desktop? I do find Yosemite a little slower that Mavericks or Mountain Lion - it is much bigger in size.
 
Joined
Feb 19, 2014
Messages
13
Motherboard
Asus h97-plus
CPU
intel i5 4590
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone
[SUCCESS] Yosemite - Asus h97-plus - i5 4690 - intel 4600


What sort of time does it take to boot Yosemite from the boot menu before you get to the login or desktop? I do find Yosemite a little slower that Mavericks or Mountain Lion - it is much bigger in size.
about 20 seconds
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,494
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
about 20 seconds

Seems a little long for an SSD - unless it is a budget orientated model like the Kingston v300 range. You can try booting using -v flag to see if it is sticking at a point before moving on. Also can try using Black Magic Speed test:
https://itunes.apple.com/gb/app/blackmagic-disk-speed-test/id425264550?mt=12
http://www.tonymacx86.com/bat-cave/...chmarks-using-blackmagic-disk-speed-test.html

I think my boot times are a little over 30 seconds on my Yosemite test installation which is on a spare HDD at present as I do not have a spare SSD to hand for this purpose at present.
 
Joined
Feb 19, 2014
Messages
13
Motherboard
Asus h97-plus
CPU
intel i5 4590
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone
The ssd is a crucial mx100, not a budget one :)
blackmagic disk speed test says 331 mb/s write and 492 mb/s read

Using the verbose boot i'm not able to see if the system hangs waiting for something.
Using console otherwise i see something:

06/11/14 21:55:45,359 configd[25]: network changed.
06/11/14 21:55:45,373 networkd[196]: networkd-411 pid 196
06/11/14 21:55:50,000 kernel[0]: ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
06/11/14 21:55:50,000 kernel[0]: WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3c
06/11/14 21:55:50,000 kernel[0]: -- power management may be incomplete or unsupported

a lot of:

06/11/14 21:55:55,000 kernel[0]: BUG in process suhelperd[258]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external)
 
Top