Contribute
Register

Seeking help with Thunderbolt/Audio issues - Lenovo ThinkPad P53 15.6" 4K OLED - Coffee Lake i7-9750H - Intel UHD 630

Joined
Jan 10, 2020
Messages
2
Motherboard
Lenovo ThinkPad P53 15" Laptop - 1.19 - Clover
CPU
i7-9750H
Graphics
UHD 630 + Quadro T2000, 3840x2160
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
Hey guys,

I have a ThinkPad P53 that is able to dual boot and I am seeking some help to get my current SSDT/hotpatch tweaked so my internal speakers and Thunderbolt are functional. As of this post I am successfully dual booting Windows 10 and macOS 10.15.2 (running on separate NVMe drives). I was planning to use my Hackintosh for music production, paired with my Slate Digital VRS8 Thunderbolt audio interface.

Initially, I had trouble getting the OS to boot. After messing around with Unibeast and trying a bunch of different configurations that I put together from various threads / Google searches (with no luck), I stumbled across a GitHub repo (ThinkPad-P52-Hackintosh) that provided a pre-configured Clover build (r5100) for the Lenovo ThinkPad P52, my laptop’s direct predecessor:

https://github.com/liuyishengalan/ThinkPad-P52-Hackintosh-10.15.x/releases/download/2.7/EFI.zip

After replacing my (frankenstein-ed) Clover folder with a fresh copy of the 2.7 release above, I used the provided 4k config (config 8750H-8850H.plist) and I was able to boot immediately! I noticed that my RAM was reporting incorrectly as 88 GB in About This Mac, so I modified config.plist to match my physical RAM configuration. Worked like a charm!


Now that I can boot, is there anyone who can help me with the following items below? I understand the general concept of DSDTs and SSDTs, but I am weary of deviating from the “stock” build from GitHub (my Frankenstein Clover configs would result in a frozen Apple logo at boot or a blank screen):
  1. Adjusting hotpatch config so that it aligns with ThinkPad P53 instead of ThinkPad P52 — The original author of the config was able to get Thunderbolt to work flawlessly so I think Lenovo may have rearranged some things between models.

  2. Getting built-in audio hardware to work — audio does not work at all on Windows or macOS when booting from Clover (audio is restored when Windows boots directly)

  3. Touchscreen support — on my first attempt (pre-GitHub build) macOS was accepting touch input., but the built-in trackpad was disabled. Weirdly, I haven’t been able to get it to work since.

  4. WiFi / Bluetooth / iCloud / iMessage - looking for recommendation to replace my WiFi 6 card with a Mac-compatible card without sacrificing performance/quality

  5. HDMI, Display brightness, SD card reader - appears to be a problem with 4K coffee lake laptops in general (and SD card readers connected via PCIe). Not sure if there's any hope as of now but putting this out there just in case :)

I’ve attached my gen_config ZIP file and included screenshots in the archive for reference.


Working:
  • Boots to macOS Catalina with no visible error
  • Trackpad working with gestures
  • Keyboard
  • 4K resolution on built-in display
  • USB ports
  • Ethernet
  • Internal drives correctly identified as NVMe (with incorrect vendor)
  • Sleep / 0wake (screen flickers, occasional glitches)
  • Shutdown / restart

Known Issues:
  • The system will get stuck on the Apple logo and will NOT boot when a Thunderbolt device is connected to the laptop. I’ve tested this using my Lenovo Thunderbolt Dock as well as my Thunderbolt Audio Interface (Slate Digital VRS8).

  • When booting via Clover, audio does not work in both Windows and MacOS. When booting from the Windows drive directly, audio functionality is restored.
 

Attachments

Last edited:
Top