Contribute
Register

Solved > Screen sleep stopped working after update to mac os Catalina 10.15.4

Joined
Sep 2, 2016
Messages
8
Motherboard
nuc-kit-nuc6i3syh
CPU
i3-6100
Graphics
integrated
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
igfxonln=1 and removing the connector flag worked for me on Intel HD 520 graphics. The flag UseIntelHDMI kinda worked. I only get HDMI audio by disconnecting the HDMI cable, and then replacing it, then I get HDMI audio appearing in the 'sound' panel

I'm going to investigate more.
 
Last edited:
Joined
Mar 14, 2018
Messages
8
Motherboard
Laptop make & model # > See Rules!
CPU
i5-8250U
Graphics
UHD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
igfxonln=1 and removing the connector flag worked for me on Intel HD 520 graphics. The flag UseIntelHDMI kinda worked. I only get HDMI audio by disconnecting the HDMI cable, and then replacing it, then I get HDMI audio appearing in the 'sound' panel

I'm going to investigate more.
I have the same issue. igfxonln=1 can bring up the video but not audio. I need to turn off and on the monitor to get the audio back. And without igfxonln=1, I can also bring both the video and audio back by turning off and on the monitor. It seems igfxonln=1 only works for video signal but not audio.
 
Joined
Dec 26, 2018
Messages
15
Motherboard
GIGABYTE H370M D3H
CPU
i3-8100
Graphics
UHD Graphics 630
Mobile Phone
  1. Android
I was having this problem too after updating from 10.15.2 to 10.15.6 two days ago. At first HDMI didn't work at all, so I was using the VGA port while I looked for a solution. I've seen today that WhateverGreen released a new version (1.4.1) which made the HDMI port work again, but I got the problem of the monitor not returning from sleep.

I found this thread and the igfxonln=1 argument did solve it. I don't use HDMI audio, so I'm not sure if it works correctly.
 
Top