Contribute
Register

Screen Size and Resolution too large

Joined
Sep 27, 2014
Messages
6
Motherboard
Gigabyte z97-D3H
CPU
Intel i7-4790K
Graphics
EVGA Geforce GTX 1060 6GB SSC
Hi all,

Recently inherited an Asus GTX 680 and a 43 inch LG 4k TV and having some issues getting them to play right in High Sierra.

Basically, MacOS thinks the screen is a 107 inch (6720x3780) screen in About This Mac. It thinks it is a 5k (5120x2880) within system report.

Screen Shot 2018-06-13 at 14.31.06.png Screen Shot 2018-06-13 at 15.00.17.png

Within the display preferences it gives me all the options up to 6720x3780, which obviously looks terrible on this screen. The 4k resolution option also looks terrible, text isn't clear etc, presumably because it is trying to scale down from a large resolution and mouse is quite laggy. As a side note, yesterday I was getting a different interface within the display preferences, rather than the list of resolutions, it was pictures with the text "more space" and "larger text". Here is the display preferences screen...

Screen Shot 2018-06-13 at 14.34.17.png

Tried a few things, including changing the system definition to MacPro6,1. I have the lilu and NvidiaGraphicsFixup kexts installed. I tried it in windows, and the 4k screen seems to work fine, very minor lag, but nearly unnoticeable. Will probably upgrade the graphics card if I can get it working with the macOS, so I can take advantage of HDMI 2.0 and the extra power.

Another side note, if I try to load up a 4k YT video it doesn't give me the option for anything past 1080p quality, no matter what resolution the mac has. 1440p and 4k qualities were available in W10.

Not sure what i'm missing and haven't found anything that has helped on the forums yet, but I'll continue looking.

Any suggestions would be greatly appreciated. Pretty much out of ideas at the moment.

Below is the clover config in case that helps.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>ACPI</key>
    <dict>
        <key>DSDT</key>
        <dict>
            <key>Debug</key>
            <false/>
            <key>DropOEM_DSM</key>
            <false/>
            <key>Name</key>
            <string>DSDT.aml</string>
            <key>ReuseFFFF</key>
            <false/>
        </dict>
        <key>SSDT</key>
        <dict>
            <key>DropOem</key>
            <false/>
            <key>Generate</key>
            <dict>
                <key>CStates</key>
                <false/>
                <key>PStates</key>
                <false/>
            </dict>
        </dict>
    </dict>
    <key>Boot</key>
    <dict>
        <key>Arguments</key>
        <string>dart=0 nvda_drv=1</string>
        <key>DefaultVolume</key>
        <string>El Capitan</string>
        <key>Legacy</key>
        <string>PBR</string>
        <key>Log</key>
        <true/>
        <key>Secure</key>
        <false/>
        <key>Timeout</key>
        <integer>3</integer>
        <key>XMPDetection</key>
        <false/>
    </dict>
    <key>Devices</key>
    <dict>
        <key>Audio</key>
        <dict>
            <key>Inject</key>
            <string>1</string>
        </dict>
        <key>FakeID</key>
        <dict>
            <key>ATI</key>
            <string>0x0</string>
            <key>IMEI</key>
            <string>0x0</string>
            <key>IntelGFX</key>
            <string>0x0</string>
            <key>LAN</key>
            <string>0x0</string>
            <key>NVidia</key>
            <string>0x0</string>
            <key>SATA</key>
            <string>0x0</string>
            <key>WIFI</key>
            <string>0x0</string>
            <key>XHCI</key>
            <string>0x0</string>
        </dict>
        <key>USB</key>
        <dict>
            <key>FixOwnership</key>
            <false/>
            <key>Inject</key>
            <false/>
        </dict>
    </dict>
    <key>DisableDrivers</key>
    <array>
        <string>Nothing</string>
    </array>
    <key>GUI</key>
    <dict>
        <key>Hide</key>
        <array>
            <string>Windows</string>
            <string>\EFI\BOOT\BOOTX64.EFI</string>
        </array>
        <key>Language</key>
        <string>en:0</string>
        <key>Mouse</key>
        <dict>
            <key>Enabled</key>
            <true/>
            <key>Speed</key>
            <integer>8</integer>
        </dict>
        <key>Scan</key>
        <dict>
            <key>Entries</key>
            <true/>
            <key>Legacy</key>
            <string>First</string>
            <key>Tool</key>
            <true/>
        </dict>
        <key>ScreenResolution</key>
        <string>1920x1080</string>
        <key>Theme</key>
        <string>embedded</string>
    </dict>
    <key>Graphics</key>
    <dict>
        <key>Inject</key>
        <dict>
            <key>ATI</key>
            <false/>
            <key>Intel</key>
            <false/>
            <key>NVidia</key>
            <false/>
        </dict>
        <key>LoadVBios</key>
        <false/>
        <key>ig-platform-id</key>
        <string>0x</string>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
        <key>AppleIntelCPUPM</key>
        <true/>
        <key>AppleRTC</key>
        <true/>
        <key>KernelCpu</key>
        <false/>
        <key>KernelLapic</key>
        <false/>
        <key>KernelPm</key>
        <true/>
        <key>KernelXCPM</key>
        <false/>
        <key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>External icons patch</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                RXh0ZXJuYWw=
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>Name</key>
                <string>AppleAHCIPort</string>
                <key>Replace</key>
                <data>
                SW50ZXJuYWw=
                </data>
            </dict>
        </array>
    </dict>
    <key>RtVariables</key>
    <dict>
        <key>BooterConfig</key>
        <string>0x28</string>
        <key>CsrActiveConfig</key>
        <string>0x3</string>
    </dict>
    <key>SMBIOS</key>
    <dict>
        <key>BiosReleaseDate</key>
        <string>02/02/2018</string>
        <key>BiosVendor</key>
        <string>Apple Inc.</string>
        <key>BiosVersion</key>
        <string>MP61.88Z.0122.B00.1802021814</string>
        <key>Board-ID</key>
        <string>Mac-F60DEB81FF30ACF6</string>
        <key>BoardManufacturer</key>
        <string>Apple Inc.</string>
        <key>BoardSerialNumber</key>
        <string>F5K711207QXF5021F</string>
        <key>BoardType</key>
        <integer>11</integer>
        <key>BoardVersion</key>
        <string>1.0</string>
        <key>ChassisAssetTag</key>
        <string>Pro-Enclosure</string>
        <key>ChassisManufacturer</key>
        <string>Apple Inc.</string>
        <key>ChassisType</key>
        <string>0x02</string>
        <key>Family</key>
        <string>MacPro</string>
        <key>FirmwareFeatures</key>
        <string>0xE80FE137</string>
        <key>FirmwareFeaturesMask</key>
        <string>0xFF1FFF3F</string>
        <key>LocationInChassis</key>
        <string>Part Component</string>
        <key>Manufacturer</key>
        <string>Apple Inc.</string>
        <key>Mobile</key>
        <false/>
        <key>PlatformFeature</key>
        <string>0x04</string>
        <key>ProductName</key>
        <string>MacPro6,1</string>
        <key>SerialNumber</key>
        <string>F5KTFZ70F9VM</string>
        <key>Version</key>
        <string>1.0</string>
    </dict>
    <key>SystemParameters</key>
    <dict>
        <key>InjectKexts</key>
        <string>Detect</string>
        <key>InjectSystemID</key>
        <true/>
        <key>NvidiaWeb</key>
        <true/>
    </dict>
</dict>
</plist>
Thanks in advance for any help!
 
Last edited:
Top