Contribute
Register

Sapphire RX580 Black Screen after Wake

Joined
Dec 11, 2018
Messages
43
Motherboard
Gigabyte Z370N WiFi
CPU
i5-8500
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Hi,
My hackintosh can be waked (the LED is on) but the monitor goes black screen. I am using HDMI port. The EFI is uploaded in the attaching. So is there any solution to solve it? Thanks in advance!
 

Attachments

Joined
Nov 16, 2016
Messages
6
CPU
6700HQ
Graphics
HD530 980M
have the same problem as well. using a Sapphire RX590
 
Joined
Dec 11, 2018
Messages
43
Motherboard
Gigabyte Z370N WiFi
CPU
i5-8500
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
have the same problem as well. using a Sapphire RX590
After changing some places of config.plist RX580 works well now:)
 
Joined
Dec 11, 2018
Messages
43
Motherboard
Gigabyte Z370N WiFi
CPU
i5-8500
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
could you please share your config? i tried that but failed
But there is a problem that make my hackintosh crash unexpectedly. I'm checking where is wrong and suspecting the config.plist is the real reason. After I find the solution, I will upload.
 
Joined
Nov 16, 2016
Messages
6
CPU
6700HQ
Graphics
HD530 980M
But there is a problem that make my hackintosh crash unexpectedly. I'm checking where is wrong and suspecting the config.plist is the real reason. After I find the solution, I will upload.
I had kernel panic after booting and solved by injecting custom ssdt for usb.
If you have the same problem, just give that a shot.
 
Joined
Dec 11, 2018
Messages
43
Motherboard
Gigabyte Z370N WiFi
CPU
i5-8500
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I had kernel panic after booting and solved by injecting custom ssdt for usb.
If you have the same problem, just give that a shot.
Hi, I solved it eventually. My EFI folder is attached below. The kexts I installed are listed in here.
 

Attachments

Top