Contribute
Register

<< Solved >> Sapphire Radeon RX 580 Pulse wake up black screen

Status
Not open for further replies.
Joined
Jul 16, 2015
Messages
57
Motherboard
ASUS Z370-G
CPU
i7-8700K
Graphics
Sapphire Radeon RX 580 Pulse
Mac
  1. iMac
Hello everyone!

I recently upgrade my rig from GTX 970 to RX 580 also upgrade from 10.13.6 High Serria to 10.15.2 Catalina.
Every thing is fine except wake up.
The rig can sleep successfully but once I wake it up by key stroke or power botton, chassis light & memory light will be on but displays will be off.
Mobo boot posted light in yellow.
At this suitation I can not turn this machine off via power botton, I have to turn off the power.
Sleep function works fine with Windows.


I use @pastrychef 's EFI as major reference.
I've upload my EFI folder as well as IORegistry file.

Things I tried:
1. Use only 1 DP port
2. Update WEG/Lilu to newest version
3. Inject ATI, FBname and ReDeInit flag, specify video ports number to 5
4. Update Arbitrary
5. Use SSDT-RX580.aml (to update port number)

Thanks for any suggestions!

SOLVED BY:
---------------Feb 08 2020 Update --------

Based on this post #6
Add EmuVariableUefi-64.efi has fixed my issue! (not yet)

--------------Feb 10 2020 Update ---------
I did futher test, my machine won't wake if a specific DP cable was used.
I replaced my dp cable and it work like a charm.
No longer need EmuVariableUefi


-------------Feb 12 2020 update----
Upgrade from 10.15.2 to 10.15.3
Back to black screen issue - after screen loading bar at 75%, screen go black

Solved by adding FB name=Orinoco and injectATI=True
meanwhile keep using WEG.
Credit to : Stork
--------------------------------------------

Mobo: Asus ROG Strix Z370-G Gaming (WI-FI AC)
CPU: Intel i7-8700K
Graphic: Sapphire Radeon RX 580 Pulse
Wifi/Bluetooth: BCM94360CS2

pmset -g
Code:
System-wide power settings:
Currently in use:
standby              0
Sleep On Power Button 1
womp                 0
autorestart          0
hibernatefile        /var/vm/sleepimage
proximitywake        0
powernap             0
networkoversleep     0
disksleep            10
standbydelayhigh     86400
sleep                0 (sleep prevented by backupd, backupd, useractivityd, sharingd, backupd-helper)
autopoweroffdelay    28800
hibernatemode        0
autopoweroff         0
ttyskeepawake        1
displaysleep         20
highstandbythreshold 50
standbydelaylow      86400


pmset -g log
Code:
Time stamp                Domain                  Message                                                                        Duration      Delay
==========                ======                  =======                                                                        ========      =====
UUID: 0C80B75F-4486-4256-BB04-40FD2D02EE19
2020-02-04 16:35:18 -0600 Sleep                   Entering Sleep state due to 'Software Sleep pid=1401': Using AC (Charge:0%)
2020-02-04 16:35:21 -0600 PM Client Acks          Delays to Sleep notifications: [com.apple.apsd is slow(3091 ms)]
2020-02-04 16:39:30 -0600 ShutdownCause           SMC shutdown cause: 5: Software initiated shutdown
2020-02-04 16:39:31 -0600 HibernateStats          hibmode=0 standbydelaylow=0 standbydelayhigh=0                                           0
Sleep/Wakes since boot at 2020-02-04 16:31:29 -0600 :0   Dark Wake Count in this sleep cycle:1

Time stamp                Domain                  Message                                                                        Duration      Delay
==========                ======                  =======                                                                        ========      =====
UUID: Unknown UUID
2020-02-04 16:39:31 -0600 Failure                 Failure during sleep: 0xFFFFFFFF0000001F : EFI/Bootrom Failure after last point of entry to sleep
Sleep/Wakes since boot at 2020-02-04 16:31:29 -0600 :0   Dark Wake Count in this sleep cycle:1

Time stamp                Domain                  Message                                                                        Duration      Delay
==========                ======                  =======                                                                        ========      =====
UUID: (null)
2020-02-04 16:39:31 -0600 Start                   powerd process is started
2020-02-04 16:39:31 -0600 Assertions              Summary- [System: No Assertions] Using AC
2020-02-04 16:39:31 -0600 Assertions              PID 118(powerd) Created ExternalMedia "com.apple.powermanagement.externalmediamounted" 00:00:00  id:0x0x800008000 [System: No Assertions]
2020-02-04 16:39:31 -0600 Assertions              PID 208(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008001 [System: PrevDisp kDisp]
2020-02-04 16:39:31 -0600 Assertions              PID 118(powerd) Created InternalPreventDisplaySleep "com.apple.powermanagement.delayDisplayOff" 00:00:00  id:0x0x1000008003 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:31 -0600 Assertions              PID 208(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008001 [System: BGTask IntPrevDisp kDisp]
2020-02-04 16:39:31 -0600 Assertions              PID 224(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008005 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:31 -0600 Assertions              PID 224(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008005 [System: BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 231(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008006 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 231(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008006 [System: BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 234(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008007 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 234(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008007 [System: BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 240(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008008 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 240(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008008 [System: BGTask IntPrevDisp kDisp]
 

Attachments

  • EFI.zip
    23.2 MB · Views: 66
  • iMac.ioreg
    6.1 MB · Views: 44
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,289
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hello everyone!

I recently upgrade my rig from GTX 970 to RX 580 also upgrade from 10.13.6 High Serria to 10.15.2 Catalina.
Every thing is fine except wake up.
The rig can sleep successfully but once I wake it up by key stroke or power botton, chassis light & memory light will be on but displays will be off.
Mobo boot posted light in yellow.
At this suitation I can not turn this machine off via power botton, I have to turn off the power.
Sleep function works fine with Windows.


I use @pastrychef 's EFI as major reference.
I've upload my EFI folder as well as IORegistry file.

Things I tried:
1. Use only 1 DP port
2. Update WEG/Lilu to newest version
3. Inject ATI, FBname and ReDeInit flag, specify video ports number to 5
4. Update Arbitrary
5. Use SSDT-RX580.aml (to update port number)

Thanks for any suggestions!


Mobo: Asus ROG Strix Z370-G Gaming (WI-FI AC)
CPU: Intel i7-8700K
Graphic: Sapphire Radeon RX 580 Pulse
Wifi/Bluetooth: BCM94360CS2

pmset -g
Code:
System-wide power settings:
Currently in use:
standby              0
Sleep On Power Button 1
womp                 0
autorestart          0
hibernatefile        /var/vm/sleepimage
proximitywake        0
powernap             0
networkoversleep     0
disksleep            10
standbydelayhigh     86400
sleep                0 (sleep prevented by backupd, backupd, useractivityd, sharingd, backupd-helper)
autopoweroffdelay    28800
hibernatemode        0
autopoweroff         0
ttyskeepawake        1
displaysleep         20
highstandbythreshold 50
standbydelaylow      86400


pmset -g log
Code:
Time stamp                Domain                  Message                                                                        Duration      Delay
==========                ======                  =======                                                                        ========      =====
UUID: 0C80B75F-4486-4256-BB04-40FD2D02EE19
2020-02-04 16:35:18 -0600 Sleep                   Entering Sleep state due to 'Software Sleep pid=1401': Using AC (Charge:0%)
2020-02-04 16:35:21 -0600 PM Client Acks          Delays to Sleep notifications: [com.apple.apsd is slow(3091 ms)]
2020-02-04 16:39:30 -0600 ShutdownCause           SMC shutdown cause: 5: Software initiated shutdown
2020-02-04 16:39:31 -0600 HibernateStats          hibmode=0 standbydelaylow=0 standbydelayhigh=0                                           0
Sleep/Wakes since boot at 2020-02-04 16:31:29 -0600 :0   Dark Wake Count in this sleep cycle:1

Time stamp                Domain                  Message                                                                        Duration      Delay
==========                ======                  =======                                                                        ========      =====
UUID: Unknown UUID
2020-02-04 16:39:31 -0600 Failure                 Failure during sleep: 0xFFFFFFFF0000001F : EFI/Bootrom Failure after last point of entry to sleep
Sleep/Wakes since boot at 2020-02-04 16:31:29 -0600 :0   Dark Wake Count in this sleep cycle:1

Time stamp                Domain                  Message                                                                        Duration      Delay
==========                ======                  =======                                                                        ========      =====
UUID: (null)
2020-02-04 16:39:31 -0600 Start                   powerd process is started
2020-02-04 16:39:31 -0600 Assertions              Summary- [System: No Assertions] Using AC
2020-02-04 16:39:31 -0600 Assertions              PID 118(powerd) Created ExternalMedia "com.apple.powermanagement.externalmediamounted" 00:00:00  id:0x0x800008000 [System: No Assertions]
2020-02-04 16:39:31 -0600 Assertions              PID 208(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008001 [System: PrevDisp kDisp]
2020-02-04 16:39:31 -0600 Assertions              PID 118(powerd) Created InternalPreventDisplaySleep "com.apple.powermanagement.delayDisplayOff" 00:00:00  id:0x0x1000008003 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:31 -0600 Assertions              PID 208(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008001 [System: BGTask IntPrevDisp kDisp]
2020-02-04 16:39:31 -0600 Assertions              PID 224(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008005 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:31 -0600 Assertions              PID 224(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008005 [System: BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 231(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008006 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 231(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008006 [System: BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 234(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008007 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 234(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008007 [System: BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 240(fsck_apfs) Created PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008008 [System: PrevDisp BGTask IntPrevDisp kDisp]
2020-02-04 16:39:32 -0600 Assertions              PID 240(fsck_apfs) Released PreventUserIdleDisplaySleep "Running FSCK" 00:00:00  id:0x0x500008008 [System: BGTask IntPrevDisp kDisp]

Why do you need the SSDT-RX580.aml? WhateverGreen should enable all the ports.

In /EFI/CLOVER/drivers/UEFI/, you don't need the following:
NvmExpressDxe.efi
VBoxHfs.efi

In config.plist > Graphics, disable Inject ATI and disable RadeonDeInit. Also, get rid of "Orinoco" FB Name.
In config.plist > RT Variables > MLB, leave it blank.
In config.plist > System Parameters > Custom UUID, leave it blank.

I never needed "Darkwake=0" boot argument.

Your pmset log shows EFI/Bootrom failure. Try clearing NVRAM or CMOS.
 
Joined
Jul 16, 2015
Messages
57
Motherboard
ASUS Z370-G
CPU
i7-8700K
Graphics
Sapphire Radeon RX 580 Pulse
Mac
  1. iMac
Why do you need the SSDT-RX580.aml? WhateverGreen should enable all the ports.

In /EFI/CLOVER/drivers/UEFI/, you don't need the following:
NvmExpressDxe.efi
VBoxHfs.efi

In config.plist > Graphics, disable Inject ATI and disable RadeonDeInit. Also, get rid of "Orinoco" FB Name.
In config.plist > RT Variables > MLB, leave it blank.
In config.plist > System Parameters > Custom UUID, leave it blank.

I never needed "Darkwake=0" boot argument.

Your pmset log shows EFI/Bootrom failure. Try clearing NVRAM or CMOS.

Thanks chef, I messed up my gear.
Now even the fresh usb made from unibeast can not boot. I also tried system installer with your EFI - they all failed into black screen issue after loading bar.

I've tried clean CMOS, BIOS, NVRAM. Still not working.

I start to concern the clover issue or hardware issue.
Have you use the clover 5103?

Thanks!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,289
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thanks chef, I messed up my gear.
Now even the fresh usb made from unibeast can not boot. I also tried system installer with your EFI - they all failed into black screen issue after loading bar.

I've tried clean CMOS, BIOS, NVRAM. Still not working.

I start to concern the clover issue or hardware issue.
Have you use the clover 5103?

Thanks!

I have Clover r5103 in my latest EFI folder on my Z370 build thread.

Just put my EFI on the EFI partition of your USB flash drive and boot from it.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,289
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Joined
Oct 10, 2015
Messages
1,051
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
You could try this for both of your USB stick and internal drive.

 
Joined
Jul 16, 2015
Messages
57
Motherboard
ASUS Z370-G
CPU
i7-8700K
Graphics
Sapphire Radeon RX 580 Pulse
Mac
  1. iMac
Does it boot to the macOS installer?
Hi @pastrychef,

I refreshed BISO with usb drive and use ur r5.1.7 EFI to boot the installer and revocered the system from Time Mahcine.

Everything back to origin.

Sleep still not working after USB fix(rig can sleep but die on wake - can't pass POSTed, even I've cleaned nvram before sleep or press F11 in clover)
Also looks like rx850 can not be recongized - based on this rx 580 rig post, I supposed to see rx 580 in Graphics Card Model.
The result is - one of my DP port will output 4k@30fps and it used to 4K@60fps with other fix(not sure which attemp I did)
So I still think this may related to rx 580 didn't being reconized properly
Please advised! Thanks!!
Snipaste_2020-02-07_19-24-48.png
 
Joined
Jul 16, 2015
Messages
57
Motherboard
ASUS Z370-G
CPU
i7-8700K
Graphics
Sapphire Radeon RX 580 Pulse
Mac
  1. iMac
You could try this for both of your USB stick and internal drive.

Thanks!
I refreshed my BIOS to get back to origin - I'll try this if I got it again!
 
Status
Not open for further replies.
Top