<< Solved >> Sapphire Radeon HD 7750 Ultimate 1GB not fully working with Catalina 10.15.7

Not open for further replies.
Jul 9, 2012
HIS 4670 1GB passive
Classic Mac
Mobile Phone
I'm trying Catalina 10.15.7 using latest Lilu 1.5.1 + WhateverGreen 1.4.8 with radpg=15.
My GPU is Sapphire 7750 Ultimate 1GB (fanless) and I'm getting the following behaviour: HDMI works, DVI doesn't work (black screen / signal out of range), untested DP.

Boot flag -raddvi doesn't help to get DVI working neither, but according to WEG logging it's supposedly correcting the DVI digital transmitter for good.

With HDMI + DVI both connected, HDMI still works but some graphical glitches appears onscreen, and I can see DVI display correctly identified and active in IORegistryExplorer.

BTW, my card doesn't appear to have an UEFI rom: I don't get the "EFI Driver Version" on System Report -> Graphics/Displays, and GPU-Z on Windows agrees.
Maybe this could be an additional problem in my case, 'cause WEG FAQ states:

* What are the hardware requirements for WhateverGreen?
Full UEFI without CSM. You are strongly recommended to flash a UEFI-compatible ROM unless your card already has it. Failing to do so will quite likely result in issues in multi-monitor configurations and possibly even in single-monitor configurations. It may stil work for non-UEFI motherboards, try at your own risk. There are known issues when using 2 or more GPUs in multi-monitor configurations.

I've attached BIOS decoding output and WEG debug logs.

Any help will be greatly appreciated!


  • Sapphire Radeon HD 7750 Ultimate - radeon_bios_decode_hotplug.txt
    903 bytes · Views: 94
  • Sapphire Radeon HD 7750 Ultimate - redsock_bios_decoder.txt
    891 bytes · Views: 91
  • WEG-log.txt
    4.7 KB · Views: 80
Following up, I got it working :)

First I discovered that booting with HDMI display only connected (already working), then sleep -> wake, then hotpluging DVI / DP, everything worked ok (displays come alive).

So I reinforced the idea of a GPU re/initialization problem.

As suspected, the problem was indeed the non-UEFI support in GPU rom.
I added UEFI GOP (Graphics Output Protocol) to GPU rom using a tool by lordkag: GOPUpd_v1.9.6.5

The lordkag tool produced a binary identical (padding aside) rom to this one:
(just in case someone wanna try [no warranty, try at your own risk] and skip the dump+mod process for this same GPU brand/model)

Before modding, booting with CSM=disabled in GA-Z77-D3H bios automatically reverted back to CSM=enabled (with legacy support).
Now after modding the GPU rom with GOP UEFI support, the UEFI CSM in GA-Z77-D3H stays disabled during boot.

A new behaviour after modding is that only one screen display gets initialized during the AMI bios boot screen / bios setup in my HDMI+DVI connected setup, before mod both screens were on displaying this.
After initial AMI boot/post screen, everything stays like before, only HDMI displaying OpenCore boot, osx log, etc, but then UI comes alive in ALL SCREENS without sleep+wake trick, without gfx glitches, all good...

Sleep & wake still works ok with no problems like before. BTW, DP works but may still require some fine tunning / fixes, it's misbehaving sometimes while hotpluging it (switching monitor inputs, turn on / off display may get it working I believe <- I will not investigate this further as I don't plan to use DP anyway for now).

Finally, this eGPU only required CAIL_DisableGfxCGPowerGating=true, so no need for radpg=15 (which enables CAIL_DisableDrmdmaPowerGating, CAIL_DisableGfxCGPowerGating, CAIL_DisableUVDPowerGating and CAIL_DisableVCEPowerGating) to make it work.
As suspected, the problem was indeed the non-UEFI support in GPU rom.
I added UEFI GOP (Graphics Output Protocol) to GPU rom using a tool by lordkag: GOPUpd_v1.9.6.5
My HD7750 is now able to work with Opencore, thank you @watercoke.
I was surprised that it worked on Clober r5119 but not on Opencore.

I simply added UEFI to his VBIOS, so in my case I got a yellow screen without 'radpg = 15'.
Not open for further replies.