Contribute
Register

Sapphire Pulse Vega 56 8GB

Joined
Feb 9, 2013
Messages
40
Motherboard
Asus ROG Maximus X Hero
CPU
i7 8700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Hello everyone,

It's my first real hackintosh after quite some time and I'm planning to get the most compatible components I can.
Most of my build is already quite set according to the guide from Pastrychef – sadly I still need some advice considering the graphics card. I heard the Sapphire 580 would be the best one in terms of compatibility but I think I need a bit more power – that's why I opted for the Vega 56 series. I heard they are supported as eGPUs which makes them a nice fit. Recently I also heard about issues considering the fans with these cards. It seems like they're always running at full speed if you don't fix it yourself.
An update to this should've come with the past few 10.13 releases (especially 10.13.4 / 10.13.5) but I haven't found anyone that has my specific graphics card and has reported the issues and a potential fix.

I'd love if someone could chime in that already has this card!
 
Joined
Mar 23, 2014
Messages
27
Motherboard
Gigabyte GA-Z87MX-D3H
CPU
i7-4770K
Graphics
Vega 56
Mac
iMac, MacBook Pro
I have that card and didn't get everything to work 100% yet. With 10.13.6 the fans spin, but not much. However, the fans are not supposed to spin at all when idling. This is fixed in the Mojave Betas already. Card is silent, correctly recognized. Everything seems to work, but when I export videos in Final Cut they have artefacts sometimes. Seems to be related to stabilized footage. So while this might not be an important use case for you, it's my primary one and I'm still hoping to find a solution for this.
 
Joined
Mar 23, 2014
Messages
27
Motherboard
Gigabyte GA-Z87MX-D3H
CPU
i7-4770K
Graphics
Vega 56
Mac
iMac, MacBook Pro
Thanks, that thread doesn't help much though. Would be nice to have at least one success story of Vega + Final Cut with all the features working as expected.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,117
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
There are success stories of Vega 56 working with FCPX all over the place.
 
Joined
Jul 13, 2016
Messages
1,819
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
I currently have the same card as Pastrychef and it works. however, I have a XFX Vega 64 coming in the next day or so that card is recommended by apple for eGPU. Look at my post about Vega cards me and pastry just were discussing this very question. Wolax also chimed in over there.
 
Joined
Aug 27, 2011
Messages
18
Motherboard
Z97X-UD5H
CPU
i7
Graphics
Vega 56
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
I moved from Nvidia to the AMD Radeon Vega 56 Pulse and then upgraded to Mojave. Removed the Nvidia Webdrivers, updated Clover, Lilu and added Whatevergreen (just because). Rebooted and then ran the regular Mojave process. Went without a hitch and card is recognised by Mojave. Actually, this was one of the slickest updates/changes I've ever done in my hackintosh history.
 
Joined
Jun 15, 2014
Messages
80
Motherboard
Gigabyte Z87MX-D3H
CPU
i7 4770K
Graphics
VEGA 56
Mobile Phone
Android
I moved from Nvidia to the AMD Radeon Vega 56 Pulse and then upgraded to Mojave. Removed the Nvidia Webdrivers, updated Clover, Lilu and added Whatevergreen (just because). Rebooted and then ran the regular Mojave process. Went without a hitch and card is recognised by Mojave. Actually, this was one of the slickest updates/changes I've ever done in my hackintosh history.
Hi,

What system definions would you recommend for the sapphire pulse vega 56? I have a haswell CPU.

Thanks,
 
Joined
Jul 13, 2016
Messages
1,819
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
Hi,

What system definions would you recommend for the sapphire pulse vega 56? I have a haswell CPU.

Thanks,
I could be wrong but I believe that I read somewhere system definitions are for your motherboard/CPU mostly. While the OS has the drivers for things like video cards and such. So you could likely just put the card in and keep your system the way it is without any issue. If you do not have WE installed you might need that.
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,673
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Recently I also heard about issues considering the fans with these cards. It seems like they're always running at full speed if you don't fix it yourself.

@thesamesons,

Vega GPU's are currently the most powerful Supported GPU's in MacOS ... Either Vega 56 or Vega 64 are a fine choice.

However not all Vega's are made equal especially when it comes to the VBIOS, best to stick with one that is based on the AMD reference design as some of the Gaming O/C variants can be problematic.

If in any doubt get a Sapphire one as they always follow the AMD Reference design.

If the Fans are a issue then use the VGTab utility see this guide for more info :-

https://www.tonymacx86.com/threads/...vega-power-and-fan-control-properties.267519/

Thanks, that thread doesn't help much though. Would be nice to have at least one success story of Vega + Final Cut with all the features working as expected.

@Wolax,

I have Vega 64 running in my i7 4790K Video Editing system (HD 4600 IGPU configured as headless) main use of system is FCPX and it runs great on the Vega, BruceX Test comes it at around 18 seconds, previously I had Nvidia 980 Ti which gave a BruceX Test time of around 41 seconds.

I edit all my videos on the system and have never had any issues with FCPX.

I think the key to making FCPX run well on a Hack is to ensure that the IGPU is enabled and configured as headless as FCPX load balances across the IGPU and dGPU.

Cheers
Jay
 
Top