Contribute
Register

Saphire RX580 Pulse poor FCPX performance [SOLVED]

Status
Not open for further replies.
Joined
May 6, 2013
Messages
12
Motherboard
Gigabyte X99-UD4
CPU
E5-1650v3
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello! Im not newbie in hackintosh, but recently I bought new videocard Saphire RX580 Pulse 8gb. After installing it works perfect, no lags, sleep, wake, HDMI sound.

Problems:

1. If I want to record video from my webcam in quicktime at normal quality, after 5 seconds my screen freezes completely, but sound is going on.
2. When I exporting video in latest Final Cut (with latest compressor), simple minute video converting for 20-30min, this is really abnormal

What i try:

1. Latest Lilu + WhateverGreen + Shiki = nothing is changing(kexts loaded)
2. My card is GFX0 (fixed in clover)
3. Add IMEI
4. Make SSDT for WhateverGreen = nothing
5. Pathing bios if my RX580 to MacEdition (113-1E3870U-O49 to 113-4E353BU-O4E)

Bruce X bench - 70seconds

And my CPU doesnt have integrated graphics...

My specs:

Macos 10.13.4
SMBIOS: MacPro 6.1
CPU: Xeon E5-2683v3 14-core
RAM: 32GB 2666 ddr4
MB: Gigabyte x99-ud4 rev.1.1 f22
Latest Clover

Please help :banghead::!:

Снимок экрана 2018-05-20 в 15.20.32.JPEG Снимок экрана 2018-05-20 в 15.28.23.jpg
 
Last edited:
Joined
May 6, 2013
Messages
12
Motherboard
Gigabyte X99-UD4
CPU
E5-1650v3
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I think this might be the same issue seen here:

- Vega+FCPX H.264 export breaks with whatevergreen/vegafixup
- Sapphire RX580 freezes with com.apple.DumpGPURestart

What do you have connected to the RX580? I'm routing two display ports through my Gigabyte Alpine Ridge rev2.0 Thunderbolt 3 card, out to a single LG 5K UltraFine display.

Thank for reply

I use 2 DP ports

Solved!



The only thing is need to generate new SMBIOS with

SMB_BIOS_VERSION "IM191.88Z.0058.B00.1705091711"
SMB_PRODUCT_NAME "iMac19,1"
SMB_BOARD_PRODUCT "Mac-CF21D135A7D34AA6"


This make H.264 work/ whatevergreen+shiki make work H.265 at full throttle!
 
Joined
Jun 29, 2016
Messages
193
Motherboard
ASUS Prime X299 Deluxe
CPU
i9-7900X
Graphics
Vega 64
That's great to hear! Unfortunately, I don't think I can switch to that SMBIOS for my X299 system - it's configured to look more like an iMacPro1,1.
 
Joined
May 6, 2013
Messages
12
Motherboard
Gigabyte X99-UD4
CPU
E5-1650v3
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
That's great to hear! Unfortunately, I don't think I can switch to that SMBIOS for my X299 system - it's configured to look more like an iMacPro1,1.

I tried iMacPro SMBIOS, but this useless for me

I think you can try :yawn:
 
Status
Not open for further replies.
Top