Contribute
Register

Samsung 970 EVO M.2 NVMe SSD

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,212
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I picked up a Samsung 970 EVO m.2 NVME SSD 250GB for $109 US today. It works well in High Sierra.

It is rated at 2500 read and 1500 write. But I'm getting 2900 read and 1400 write.
The 500GB model specs at 3500 read and 2500 write. This is a great buy and its actually less expensive than the 960 EVO M.2 drives.

Screen Shot 2018-05-19 at 11.26.25 PM.png
 
Last edited:

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,654
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Nice find! Newegg has it for $110 USD with free shipping.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,212
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Nice find! Newegg has it for $110 USD with free shipping.

The 500 gb model should be real nice. They are rated at 30% increases performance over the 960 NVME. 3000/2500 for less than the last model thIs is great.
 
Joined
Apr 6, 2018
Messages
3
Motherboard
GA-Z170X-Gaming 7
CPU
I7-7700K
Graphics
GTX 1060
Mac
  1. iMac
Hi.
Tell me please, installation without problems?

This really works faster, than on SATA connection?


Thanks.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,212
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
In High Sierra I did not need any fixes, just used my 2.5” SSD drive to clone copy to NVMe then installed clover using NVMe as target drive (you could also use MultiBeast) and then copied my config.plist and Kexts folder to new drive. And apfs in drivers64efi folder. It was as simple as any standard drive install I’ve done before.

I did have to format it like a normal drive but once I did the system recognized it natively.

This is for High Sierra - older software will probably require fixes.
 

LSP

Joined
Feb 11, 2011
Messages
97
Motherboard
Gigabyte Z170X-UD5 th
CPU
i7 6700K
Graphics
RX580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
In High Sierra I did not need any fixes, just used my 2.5” SSD drive to clone copy to NVMe then installed clover using NVMe as target drive (you could also use MultiBeast) and then copied my config.plist and Kexts folder to new drive. And apfs in drivers64efi folder. It was as simple as any standard drive install I’ve done before.

I did have to format it like a normal drive but once I did the system recognized it natively.

This is for High Sierra - older software will probably require fixes.

I used the same procedure for a Samsung 960 NVME m.2 and no issues. Its actually faster than my Samsung 850 pro that I using previously. I'll add that I'm running HFS+ rather than APFS.
 
Joined
Oct 27, 2012
Messages
8
Motherboard
Gigabyte Z370M D3H
CPU
i7-8700K
Graphics
MSI 1060 3G
Mac
  1. Mac Pro
Just cloned High Sierra from Kingston 200V to 970 EVO.
CCC won't restore EFI to the new disk which is formatted to APFS.
Need to reinstall Clover but too many glitches.
Finally just do a clean install but boy the 500G is really fast.
Write 2380, read 3041
 

Attachments

  • Screen Shot 2018-05-26 at 11.39.14 PM.png
    Screen Shot 2018-05-26 at 11.39.14 PM.png
    686.5 KB · Views: 1,918
Joined
Jul 20, 2011
Messages
8
Motherboard
OSX LION
CPU
INTEL Q6600
Graphics
ATI HD5770
Mac
Classic Mac
Mobile Phone
Just cloned High Sierra from Kingston 200V to 970 EVO.
CCC won't restore EFI to the new disk which is formatted to APFS.
Need to reinstall Clover but too many glitches.
Finally just do a clean install but boy the 500G is really fast.
Write 2380, read 3041

Hi tanelmo,

Can you confirm the 970 EVO m.2 NVME 500 GB working with any problem ?
 
Last edited:
Joined
Oct 27, 2012
Messages
8
Motherboard
Gigabyte Z370M D3H
CPU
i7-8700K
Graphics
MSI 1060 3G
Mac
  1. Mac Pro
Hi tanelmo,

Can you confirm the 970 EVO m.2 NVME 500 GB working with any problem ?

Been running for over 2 weeks. So far it's working great.
I first installed high sierra on a old SSD for test installation.
Then I added 970 EVO for cloning. Disk Utility recognised the disk and formatted to APFS.
 
Joined
May 30, 2011
Messages
55
Motherboard
AsRock Z370 Fatal1ty Gaming ITX/ac
CPU
i5-9600K
Graphics
UHD 630
Mac
  1. iMac
Mobile Phone
  1. Android
In High Sierra I did not need any fixes, just used my 2.5” SSD drive to clone copy to NVMe then installed clover using NVMe as target drive (you could also use MultiBeast) and then copied my config.plist and Kexts folder to new drive. And apfs in drivers64efi folder. It was as simple as any standard drive install I’ve done before.

I did have to format it like a normal drive but once I did the system recognized it natively.

This is for High Sierra - older software will probably require fixes.

Been running for over 2 weeks. So far it's working great.
I first installed high sierra on a old SSD for test installation.
Then I added 970 EVO for cloning. Disk Utility recognised the disk and formatted to APFS.

SO both of you guys were able to install High Sierra without faults or problems related to this SSD, right?

Cause it's been common knowledge that they have been problematic for a while.

I just need solid confirmation cause I'm about to order them.

Thanks in advance.
 
Top