Contribute
Register

Samsung 960 pro running a little slower

Joined
Jul 27, 2013
Messages
39
Motherboard
Gigabyte Aorus Ultra Gaming z370
CPU
Intel Core i7 8770K
Graphics
Gigabyte RX580
hi , i have Samsung 960 pro installed as a boot drive, for about a year i was getting good read/write speeds for it. recently i tested it with Blackmagic, and its read write are half speed. about 1700 read/write
any clues?
i had a thunderbolt card on PCIEX4 which i thought for some reason would slow the M2 drive, so i took it out still same result.

any clues?

Running: High Sierra
Mobo: Aorus z370 Ultra Gaming
 
Joined
Nov 3, 2018
Messages
305
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
i was getting good read/write speeds for it
how good was it, was it tested on macOS or windows?

its read write are half speed. about 1700 read/write
check if trim is enabled for your SSD, it should be enabled by default for nvme ssd. turn off the PCI-E ASPM in your bios, set PCI-E version to 3.0 in your bios.

macOS Mojave 10.14.5 has much better support for your hardware, better APFS performance, consider an upgrade, update clover, kexts before doing that
 
Joined
Jul 27, 2013
Messages
39
Motherboard
Gigabyte Aorus Ultra Gaming z370
CPU
Intel Core i7 8770K
Graphics
Gigabyte RX580
how good was it, was it tested on macOS or windows?

check if trim is enabled for your SSD, it should be enabled by default for nvme ssd. turn off the PCI-E ASPM in your bios, set PCI-E version to 3.0 in your bios.

macOS Mojave 10.14.5 has much better support for your hardware, better APFS performance, consider an upgrade, update clover, kexts before doing that
Was tested on mac, never had windows on it , was bang on advertised speeds.

trim is enabled but i will try the other settings you mentioned so thanks for that. i cant update to Mojave yet due to software support issues also i dont use APFS.
 
Top