Safe boot only need help for next step

Not open for further replies.
gfx is next i have tested 0,1 id on my mobo both work for the hd4000 make sure u have 32/64/94mb shared in bios for the hd4000 also use MacMini,6,1 for hd4000 mine for example has flash player issues with mm6,1 so i use MacBookPro9,2 now flash is perfect good luck also u have to set your max res for your monitor example GraphicsMode=1600x900x32 in the .plist in the extra folder. if u have more issues boot with flag -v and use my fixit guide

I have disabled the vt-d but can't see where to do anything about the HD4000 settings or share the 32/6494mb in bios. I have tried to boot using PCIRootUID= 4 and 5 and will try the others but still only get to the bluetooth notice and the system hangs.
Also I do not know how to do anything with the plist. I tried to go to terminal and uncover library as per the internet but library did not appear so maybe I did not enter the correct code. I also tried to showall but then found out I need to write True instead of Yes and False instead of no. So I wonder if codes change with each new version of OSX.

I loaded -x so I could send this message and investigate perhaps other solutions.

I obviously have a gfx problem but not sure where to go next
Hi Stehor

I noticed on your paste bin section that you suggested to disable ieee 1394 on my BIOS there was a 1394 but not ieee. I disabled anyway but next two boots went to panic mode so took the battery out of the motherboard so it could reset it self (I read early that this also helps to clear panics) and made the 1394 enabled.

I booted again and sometimes HDA comes before the Bluetooth and sometimes after Bluetooth but still hangs. -x still gets me through and I can investigate things but cannot load my programs or get sound.

Hope we can find a solution

I have now tried all PCI 0 to 5 but none get me through a normal boot.
To set igpu to primary display in bios do I make the choice as PEG or IGFX or Auto. I could not find a setting that gave the choice to make igpu to primary display.

I took a picture of the final screen on an -v boot. Perhaps this will help to discover the problem with the graphics.

i also upgraded my mother board to version F 15q. Not sure if this will call any issues


I have copied the last page when I boot with -f and -v

I also upgraded my Motherboard to F15q when it was f7, not sure if this will correct any other problems. Went back and disabled 1394 and the picture is after disabling this.

Cant think what else to change. Other comments I have received suggest changing the plist but don't know where to find this.

The graphics was set to igfx

I will try anything even starting again
Hi insidiator,

Have not heard for a while and thought I would ask a few questions.

I have progressed in two ways.

I can still boot in safe boot using the Hitachi Hard drive that is partitioned in two with Apple and MSDOs , Safe Boot only but I can access the internet, no sound tested yet but recognises my Brother printer so almost there.

I then thought why not try the SSD Samsung and I put the power to it and connected it to SATA 2 & 3 at different stages and chose it as the hard drive. It booted straight no Safe boot but don't know why, so I loaded all software eg Microsoft Office 11 but there is no internet. I downloaded the upgrade for Mountain Lion on my safe boot computer copied it to a USB and then copied that to my SSD. When I load it the system recognises my printer so again 90% there, but no internet.

I really don't understand how one computer cannot load the full system but can the internet and another connected to the same computer boots no problem but with no internet. The computer is connected directly to the modem by ethernet cable that blinks at the back of the computer and shows as connected on the modem, a Cisco Linksys x3000

Is there a setting in BIOS or when into the SSD can I check my settings so can duplicate on the Hitachi.

Really exciting to have have two computers in one box.

When I start again on the Hitachi and try to boot from the SSD i get the error
boot0: GPT
boot0: test
boot0: test
boot0: GPT
boot0: test
boot0: test
boot0: error
I then boot to the Hitachi -x get out and connect the SSD and I can connect normally but no internet.

Any suggestions, anybody?

After installing Multibeast, and the package 10.8.4 combo and updating my plist with the following

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">
<string>7f0000000100000001000000730000000200000002 010c00d041030a000000000101060000027fff04002c000000 4100410050004c002c00690067002d0070006c006100740066 006f0072006d002d0069006400000008000000050062011400 00006800640061002d0067006600780000000d0000006f6e62 6f6172642d31</string>
<key>Kernel Flags</key>
<key>Legacy Logo</key>
<key>Graphics Mode</key>

I get the above boot problem when just booting.

What do all the bits mean.

Where do I go to edit to get a clean (Not Safe Boot) start. I must be close but cant see the problem
Last edited by a moderator:
Hi cwchce,

Sorry for not being more responsive recently; life got in the way. I have a couple of followup suggestions/questions that will hopefully move you in the right direction.

1) What kind of Mac did you tell MultiBeast to pretend your Customac is (iMac, Mac Pro, Mac mini)? My setting for this motherboard and my processor is MacPro 3,1 (this is in the 'Customization>System Definitions part of MultiBeast; I've read that 4,1 and 5,1 are unstable). This is important (and I guess I forgot to mention this earlier) because you can tell your computer to pretend to be any kind of Mac you want, but doing so affects the functionality of your computer (not to mention I only know my BIOS & MultiBeast settings work for the system definition I used). You can check your definition by going to the Apple Menu then clicking 'About this Mac' then 'More info...' then 'System Report.' The 'Hardware' option on the left hand side of the window should be highlighted by default and the first and second bits of information in the window on the right should be Model Name (which for me is 'Mac Pro') and Model Identifier (for me 'MacPro3,1'). If you have your system definition set to something else you can always change it by re-running MultiBeast in Safe Mode and selecting MacPro 3,1 in the System Definitions part of MultiBeast.

2) I noticed the number in the 'key' field for 'device-properties' has some spaces in it when I think it's supposed to be one very long, continuous string of characters. I don't know if that's an artifact of copy-pasting into your post (or from my post if that's where you got it). I would check your boot.plist file and make sure it is in fact one long string of characters (remove the spaces).

3) If you use that string for the 'key' field following 'device properties' did you make sure you have the correct amount of memory dedicated to graphics. For that string the amount of video dedicated to integrated graphics has to be 32mb IN THE BIOS or it won't work.

I hope these help. I'll try to check back more frequently. We'll get your Customac humming along yet!
Not open for further replies.