Contribute
Register

Safe boot only need help for next step

Status
Not open for further replies.
This is a reply from the new computer.

Yes I started again and all goes OK but now I won't turn the computer off or I will have to start again. I have not tried sound or anything else.

This time I have downloaded Multibeast with the second and third options all ticked. downloaded Skype but have not tested.

Just so happy to have got this far. Thanks for the advice on the screen. I would have gone forever on a VGA connection and never got anywhere.

Will do more testing tomorrow.

Just out of interest can I have more than one email account similar to iPad and iPhone?

Regards
Charles
 
I have used UniBeast to install. How do you use Multi-Beast? I thought MultiBeast was for use once you have installed the Mountain Lion on the hard drive.


I have downloaded and installed Multi-Beast on the new computer which on first boot after loading ML from Unibeast I can access the internet. On reboots, still in Safe Boot mode no internet available. Have noticed on reboots when I go to preferences and Network it says no firewire cable (I think)installed but it does not give other options e.g. ethernet cable. On the first boot it recognises that I have connected an ethernet cable. I will check I have put the ethernet cable in the correct place.

I have tried lots of combinations of GraphicEnabler, PCIRootUID and npci but the only -x works on the initial boot and the reboot.

I am just so impressed to have a working MAC that I don't want to turn off but feel I must persist until I get a fully working Mac.

Any other suggestions to try or add. When I am can access the internet is there something I should download onto the hard drive to help the process?
 
Hi, Thanks for the reply. Do I try just PCIRootUID=0 on its own or with other options e.g. GraphicEnabler & npci and -f -v.

I have just successfully rebooted and although only in safe boot it did recognise the ethernet cable (I changed to another connection) so I have been able to set up emails etc.

How do I make the options permanent on the BIOS so I don't have to go through the Chimera (TonyMac screen)?
 
re run mulibeast per screenshot. then copy and paste the .plist i edited for u in the extra folder note u might need to change GraphicsMode for your max res
 

Attachments

  • org.chameleon.Boot.plist
    565 bytes · Views: 280
  • Screen Shot 2013-07-22 at 11.41.27 AM.png
    Screen Shot 2013-07-22 at 11.41.27 AM.png
    180.9 KB · Views: 154
  • Screen Shot 2013-07-22 at 11.44.44 AM.png
    Screen Shot 2013-07-22 at 11.44.44 AM.png
    116.5 KB · Views: 136
As you are not using a dedicated graphics card you just have to boot with PCIRootUID=0. GraphicsEnabler=No is default in chimera. It is always good to boot in -v while trouble shooting. So do this:

PCIRootUID=0 -v

Also check this guy out. He has the same motherboard as you: http://www.youtube.com/watch?v=gsSAOH0UFDk (after 2 hours he also encounter problems)

You could also try to disable vt-d in bios. Did you set up you bios like this? http://www.tonymacx86.com/99-quick-guide-configuring-uefi-gigabyte-s-7-series-lga-1155-boards.html

Also what port are you using on you motherboard to your monitor? Do not use VGA as apple hasn't supported it in a very long time!

Good luck!:):D
 
I keep seeing the 'PCIRootUID=0' thing pop up and I think it may be a bit of a distraction in a lot of cases. Based on my browsing around it seems to be more of a problem with unsupported graphics cards, and given that you're working with integrated graphics I don't think it's necessary.

The contents of my org.chameleon.Boot.plist file is listed below and my system (same motherboard, same graphics) is good and stable. Note that I have GraphicsEnabler=Yes and no mention of PCIRootUID. The 'device-properties' bit below GraphicsEnabler is the EFI string injection method for telling the computer what video port layout I have (basically, where it needs to send the video signals). Supposedly this approach is unnecessary these days, but that was the only way for me to get my display working properly (it's a VGA display connected to the DisplayPort port via a Monster DisplayPort-to-VGA adapter; probably the only way to use a VGA display).

Please note: for this particular string injection to work, the amount of memory dedicated to your integrated graphics in your BIOS must be set to 32Mb, not the default of 64Mb. If everything is working it will still show up as more graphics memory in your system profiler (mine shows as 512Mb, but then I have 32Gb of RAM). If you want more details on the injection method (including the different required BIOS integrated graphics memory settings for the different strings), check dta's post here.

My org.chameleon.Boot.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>device-properties</key>
<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000005006201140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>darkwake=0</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>"1920x1080x32"</string>
</dict>
</plist>

Given that we have the same motherboard and are using the same graphics setup and my setup works (although your processor is different), you might consider copy-pasting everything above between <dict> and </dict> (or at least the GraphicsEnabler and device-properties bits). Another thing you could try is simply replicating my MultiBeast settings (below) and THEN doing the EFI injection thing to sort out your graphics.

If there's a more straightforward way to get this motherboard running with integrated graphics, I don't know what it is, and I spent plenty of time trying before I figured it out. Maybe the new Multibeast (5.4) fixed it?

My Multibeast 5.3 settings:
55613d1367888869-insidiators-grow-into-build-core-i7-3770k-ga-z77x-ud5h-32gb-ram-multibeastimage.jpg
 
Hi insidiator

Just thought I would give you an update.

I started again, but still can only boot in Safe Boot mode. I read in the forum that you could update the bios so I did that and now have Version F15q a big leap from F7. But still cannot get anywhere other than with -x.
My printer is working again but don't have sound and it seems unless I can get a regular boot won't be able to have sound because nothing is loaded.
I am still not sure how to find the plist files but suppose I must go through terminal.
I read a post by bigbluemini which was quite helpful, that is where I learned how to upgrade my bios, but still Safe Boot is all I get.
When I loaded Chameleon if just a straight boot or -f -v or just -v It got through to[AGPM controller] unknown platform and Panic. In -x Safe Boot is OK.
Any more suggestions would be graetly received
 
I keep seeing the 'PCIRootUID=0' thing pop up and I think it may be a bit of a distraction in a lot of cases. Based on my browsing around it seems to be more of a problem with unsupported graphics cards, and given that you're working with integrated graphics I don't think it's necessary.

this is bad info different mobos use different ids aka PCIRoot=0,1,2,3,4,5 example the nvida 470 on an x79 needs 4
 
Thanks for the information. I do not have any added graphics card but use the internal graphics. Should I be trying PCIRootUID with 0 to 5 as options? I have tried 0 and 1 but not 2, 3, 4 or 5. It is very frustrating being so close to a normal boot. Is there anything else to look for? If I boot -v the system stops after saying the Bluetooth is completed, what comes after Bluetooth?
 
Status
Not open for further replies.
Back
Top