Contribute
Register

Safari Crashing Webkit 10.12.6 Sierra problem?

Status
Not open for further replies.

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
7,582
Motherboard
ASUS Z490-G Gaming (Wi-Fi) - OC 0.6.8
CPU
i3-10320
Graphics
RX560
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
I'm beginning to wonder if it's related to Graphics. Using Onboard HD 4000 doesn't have the crash in 10.12.6. We're all using Nvidia Graphics here. I'm beginning to wonder if the Native Drivers for my 760 have become buggy in Sierra. If you noticed that the crash is relating to Video. It's a interesting one.

Hmm. I'm leaning towards your previous conclusion that it is the latest Safari causing the crashes. I'm only using the Nvidia web-driver so for me it isn't the native drivers.

:)
 
Joined
Jun 9, 2013
Messages
10,703
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Hmm. I'm leaning towards your previous conclusion that it is the latest Safari causing the crashes. I'm only using the Nvidia web-driver so for me it isn't the native drivers.

:)

My desktop is running version 10.1.2 of Safari with 10.12.6. Ill try and downgrade it sometime.
 
Joined
Jun 9, 2013
Messages
10,703
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Update. Some of my Friends which are on the Z87 Platform with the GTX760 using iMac 14,2 is having the same problem. Crashing related to Webkit. Heres what I've noticed on my Hardware. Leave Facebook open in a Tab -> Open another Tab -> Youtube -> Go back to the Tab which has Facebook open, This causes Safari to Crash but heres the interesting thing Safari is not properly crashing only Video Extension relating to Playback. Im guessing this is a issue with Safari itself or Sierra.

I now know this isn't a Graphics heres why Genuine Macs with both Nvidia & Radeon Graphics are suffering with this problem. Im guessing this bug is across the board wether its a Genuine Mac or a Hack not a Hackintosh related problem.

(Chrome) Works Fine.
(FireFox) Works Fine.
Older Versions of Safari works fine.
Latest Version of Safari 10.1.2 (Suffers from Crashing on certain Sites)

A friend of mine she has a iMac 14,2 2013 model with Nvidia GeForce GT 755M, i5 4570 Model and is also suffering with the same problem after upgrading to 10.12.6.

My Sister with the iMac 2013 i7-4771 model is also having the same problem after upgrading to 10.12.6.

I have reported this problem to Apple themselves. They've had a lot of reports regarding this problem.
 
Last edited:

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
7,582
Motherboard
ASUS Z490-G Gaming (Wi-Fi) - OC 0.6.8
CPU
i3-10320
Graphics
RX560
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
A quick P.S to your problem @VioletDragon

I am now getting regular Safari crashes while typing text into an input text-box. Sounds odd I know. Don't know if it is related but I can spend time typing in some review or other and then - bam! - the system crashes and reboots.

Depending on the site I'm on the text might or might not get restored when Safari comes back up. Most recent I'd lost everything. Kicking myself for not simply copying to clipboard more often.

Hasn't been crashing doing other stuff for hours on end, just text input via Safari ... :rolleyes:
 
Joined
Jun 9, 2013
Messages
10,703
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
A quick P.S to your problem @VioletDragon

I am now getting regular Safari crashes while typing text into an input text-box. Sounds odd I know. Don't know if it is related but I can spend time typing in some review or other and then - bam! - the system crashes and reboots.

Depending on the site I'm on the text might or might not get restored when Safari comes back up. Most recent I'd lost everything. Kicking myself for not simply copying to clipboard more often.

Hasn't been crashing doing other stuff for hours on end, just text input via Safari ... :rolleyes:

The crashing on my Desktop has just disappeared after a clean install wether its from Cold Boot or Sleep. All i can recommend to do is try a fresh install or revert to 10.12.5.
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
7,582
Motherboard
ASUS Z490-G Gaming (Wi-Fi) - OC 0.6.8
CPU
i3-10320
Graphics
RX560
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
The crashing on my Desktop has just disappeared after a clean install wether its from Cold Boot or Sleep. All i can recommend to do is try a fresh install or revert to 10.12.5.

Yes, I know. It's too hard to pin down, isn't it? Think I'll just muddle through until the next update/upgrade. Reverting doesn't appeal. Could use Chrome instead... Sigh!

:)
 
Joined
Jul 24, 2015
Messages
2,236
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
I tried to recreate the issue opening many Facebook and YouTube tabs playing videos.
 
Joined
Jun 9, 2013
Messages
10,703
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Yes, I know. It's too hard to pin down, isn't it? Think I'll just muddle through until the next update/upgrade. Reverting doesn't appeal. Could use Chrome instead... Sigh!

:)

Im running 10.12.6 along with Safari version 10.1.2 on my Intel DH67BL Desktop which uses Intel HD 3000 and have never had that crash same with my HP Probook 4530s which also uses Intel HD 3000 no Crash. My Probook 4540s which uses Intel HD 4000 is still on 10.12.5 not upgraded that but no Crash. I might move my Main Desktop to HD 4000 and see what the outcome is.

Screen Shot 2017-08-31 at 22.19.30.png
 
Joined
Oct 8, 2014
Messages
19
Motherboard
Gigabyte GA-Z87X-OC
CPU
Intel i7 4770K
Graphics
Asus Direct CU II GTX 760 2GB
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I am facing this same issue with Safari. Web Kit crashes when I am browsing Facebook.
The second thing is I want to highlight is, I was using Chrome earlier, every 20/30 mins I faced an 'aw snap' issue. It was too annoying and so I switched to Safari.

After using Safari for a while, I started facing the WebKit issue.
I am running OSX 10.12.6 on GA-Z87X-OC Motherboard with a GTX 760. (Have disabled my onboard intel graphics since it's interfering with my GTX 760.

I am also using a MacBook Pro with OS 10.12.0 and Safari and Chrome works fine on it. Is it OS version specific issue?


(A little off topic point - Google Chrome on my machine worked fine with Windows 10 Creator's Update. On a random day, Windows UI got corrupted I had to reinstall from a disk which had a very old version of Windows 10 which started giving me 'Aw Snap' errors on Google Chrome and often crashed while updating)
 
Last edited:
Joined
Oct 15, 2011
Messages
963
Motherboard
ASUS Gryphon Z87
CPU
i7-4770K
Graphics
HD 4600 & RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Apple
I also get crashes with etc web driver. Using the iGPU works better here.
 
Status
Not open for further replies.
Top