Contribute
Register

RX580 on a Mac Pro 3,1 - Mojave (SOLVED)

Joined
Aug 3, 2011
Messages
5
Motherboard
OSX
CPU
i7 4790K
Graphics
Nvidia 660
Mac
Classic Mac
Mobile Phone
Edit: The answer is that Xeon chips will not support the AMD drivers for the RX580 due to a lack of SSE4.2 instructions. NVIDIA Kepler GPUs, like GTX 680/770/780 can be used to drive a 4K monitor on a Mac Pro 3,1 in Mojave.


Hi,

I am trying to get a RX580 card working on a Mac Pro 3,1 with Mojave installed via DosDude1's methods. The previous card was a Nvidia 710 which ran perfectly. However, I need to drive a 4K monitor and the 710 only had HDMI 1.4.

When trying to boot with the RX580 alone, the system appears to boot correctly and the screen comes on after about 30 seconds. But instead of seeing the login screen, it is just a black screen. The monitor stays on however so it is clearly getting some sort of signal from the card.

I have also tried to boot with both the 710 and the RX580 installed. The monitor with the RX580 shows the same as before. The monitor with the 710 shows a black screen with a single white text cursor (i.e. white square) in the top left. However, the system does not responds to keyboard or mouse input.

The RX580 card has been tested on a Hackintosh running Mojave and it works fine.

Any suggestions on what I am doing wrong?

Thanks.
 
Last edited:
Joined
Jun 30, 2011
Messages
1
Motherboard
10.6.8
CPU
Core 2 Quad 8300
Graphics
ATI HD 5680
Mac
Classic Mac
Mobile Phone
iOS
If you using dosdude1 Mojave patcher in your macpro tower, you cannot use a newer AMD/ATI card. It calls the SSE 4.2 instruction set that is not on your processor. You absolutely have to use an nVidia card. The GTX 680 is native. If you’re a bit cautious with your purchase you can grab up on that is easily flushable for boot screen. That’s what I did. It runs like a dream.


Edit: The answer is that Xeon chips will not support the AMD drivers for the RX580 due to a lack of SSE4.2 instructions. NVIDIA Kepler GPUs, like GTX 680/770/780 can be used to drive a 4K monitor on a Mac Pro 3,1 in Mojave.


Hi,

I am trying to get a RX580 card working on a Mac Pro 3,1 with Mojave installed via DosDude1's methods. The previous card was a Nvidia 710 which ran perfectly. However, I need to drive a 4K monitor and the 710 only had HDMI 1.4.

When trying to boot with the RX580 alone, the system appears to boot correctly and the screen comes on after about 30 seconds. But instead of seeing the login screen, it is just a black screen. The monitor stays on however so it is clearly getting some sort of signal from the card.

I have also tried to boot with both the 710 and the RX580 installed. The monitor with the RX580 shows the same as before. The monitor with the 710 shows a black screen with a single white text cursor (i.e. white square) in the top left. However, the system does not responds to keyboard or mouse input.

The RX580 card has been tested on a Hackintosh running Mojave and it works fine.

Any suggestions on what I am doing wrong?

Thanks.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,958
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Yes, the 3,1, when using dosdude1's patcher for Sierra, High Sierra and/or Mojave no longer support AMD cards because of the AMD drivers require processors that support SSE4.2 instruction set.

I have to replace my AMD HD 7850 with a GTX 680 which works flawlessly in High Sierra. Both cards are flashed PC cards.
 
Top