Contribute
Register

RX580 Interference/Visual Noise (Mojave)

Joined
Mar 31, 2016
Messages
111
Motherboard
Gigabyte GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
RX 580
Mac
  1. MacBook Pro
I'm trying to troubleshoot a graphical issue before I send my new GPU back for a replacement.

-I bought a new display for a CustoMac mATX build (100% based on the Buyer's Guide).
-The display is a BenQ 28 inch 4K HDR Monitor (EL2870U).
-GPU is a Sapphire RX580 Pulse 8GB, as per the Buyer's Guide.

I'm getting some faint interference on the display. It looks like an overlay of faint red and green pixels, dancing randomly like TV snow.

-I tried a known good display hooked up to the same new build. No issues, but it's running at a lower resolution (2k) so it may not be equivalent.

-I tried the same new (4k) display on another Hack workstation running Sierra, w/ a 1050ti. No interference there.

-I tried a newly purchased HDMI 2.0 cable to rule that out as the culprit. No change.

I'm trying to isolate the faulty component. Sounds like the GPU, no? Should I return it for a replacement? What do you think?

Thanks.
 
Joined
Mar 31, 2016
Messages
111
Motherboard
Gigabyte GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
RX 580
Mac
  1. MacBook Pro
Since my original post I've had the opportunity to try a new RX580. Same issue.

I've ruled out the GPU, the display, and the cable. So the problem must be rooted in software, I think.

I notice that the interference or whatever's going on only appears once the system is booted into macOS (post Clover, after the 1st apple progress bar).

A real head-scratcher.
 
Joined
Mar 31, 2016
Messages
111
Motherboard
Gigabyte GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
RX 580
Mac
  1. MacBook Pro
I haven't tried DisplayPort at this point so I'll do that. However, on the older machine (10.12.6, NVidia 1050ti) it worked fine over HDMI.

The display has inputs for HDMI and DP.
 
Joined
Mar 31, 2016
Messages
111
Motherboard
Gigabyte GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
RX 580
Mac
  1. MacBook Pro
I tried using a DP output from the RX580 today. Looked pretty good! Then the machine went to sleep and when it came back there were all kinds of artifacts in the image.
 
Joined
Mar 31, 2016
Messages
111
Motherboard
Gigabyte GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
RX 580
Mac
  1. MacBook Pro
So, there are some sleep/wake issues that are hard to reproduce. But another interesting development is that despite improving the image, switching to displayport out breaks WiFi from my TPLink AC1900.
 
Top