RX560 4GB Brand HIS

Discussion in 'Graphics' started by hotbullet79, Oct 7, 2017.

  1. hotbullet79

    hotbullet79

    Joined:
    Jun 20, 2016
    Messages:
    7
    Oct 7, 2017 at 5:10 PM #1
    hotbullet79

    hotbullet79

    Joined:
    Jun 20, 2016
    Messages:
    7
    Hi I have read that most of the rx560 works oob..

    so I pulled the trigger on HIS RX560 4GB version and it is not working
    do I have to inject any fake id?

    my current system is
    motherboard gigabyte z170gaming7
    cpu i57500

    if I use igpu injecting intel igpu works fine.

    if I disable the igpu or boot with pcie1 in bios


    what I get from the boot is
    gioscreen lock3 and reboot

    for my HIS RX560 Green 4 GB RAM

    the system reports detects as
    Vendor: ATI (0x1002)
    Device ID: 0x67ff
    Revision ID: 0x00cf
    EFI Driver Version: WEAR-104-2017-08-27

    thanks.

    here is my config
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>ACPI</key>
    <dict>
    <key>DSDT</key>
    <dict>
    <key>Debug</key>
    <false/>
    <key>DropOEM_DSM</key>
    <false/>
    <key>Fixes</key>
    <dict>
    <key>FixShutdown_0004</key>
    <true/>
    </dict>
    <key>Name</key>
    <string>DSDT.aml</string>
    <key>Patches</key>
    <array>
    <dict>
    <key>Comment</key>
    <string>change _OSI to XOSI</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    X09TSQ==
    </data>
    <key>Replace</key>
    <data>
    WE9TSQ==
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>Rename HDAS to HDEF</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    SERBUw==
    </data>
    <key>Replace</key>
    <data>
    SERFRg==
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>EHCI to EH01</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    RUhDMQ==
    </data>
    <key>Replace</key>
    <data>
    RUgwMQ==
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>EHCI2 to EH02</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    RUhDMg==
    </data>
    <key>Replace</key>
    <data>
    RUgwMg==
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>change XHCI to XHC</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    WEhDSQ==
    </data>
    <key>Replace</key>
    <data>
    WEhDXw==
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>change XHC1 to XHC</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    WEhDMQ==
    </data>
    <key>Replace</key>
    <data>
    WEhDXw==
    </data>
    </dict>
    </array>
    <key>ReuseFFFF</key>
    <false/>
    </dict>
    <key>DropTables</key>
    <array>
    <dict>
    <key>Signature</key>
    <string>DMAR</string>
    </dict>
    <dict>
    <key>Signature</key>
    <string>SSDT</string>
    <key>TableId</key>
    <string>Cpu0Ist</string>
    </dict>
    <dict>
    <key>Signature</key>
    <string>SSDT</string>
    <key>TableId</key>
    <string>CpuPm</string>
    </dict>
    </array>
    <key>HaltEnabler</key>
    <true/>
    <key>SSDT</key>
    <dict>
    <key>DropOem</key>
    <false/>
    <key>Generate</key>
    <dict>
    <key>CStates</key>
    <true/>
    <key>PStates</key>
    <true/>
    </dict>
    </dict>
    </dict>
    <key>Boot</key>
    <dict>
    <key>Arguments</key>
    <string>-v dart=0 kext-dev-mode=1 -disablegfxfirmware</string>
    <key>Debug</key>
    <false/>
    <key>DefaultLoader</key>
    <string>boot.efi</string>
    <key>DefaultVolume</key>
    <string>LastBootedVolume</string>
    <key>Legacy</key>
    <string>PBR</string>
    <key>Secure</key>
    <false/>
    <key>Timeout</key>
    <integer>-1</integer>
    <key>XMPDetection</key>
    <string>Yes</string>
    </dict>
    <key>CPU</key>
    <dict>
    <key>UseARTFrequency</key>
    <false/>
    </dict>
    <key>Devices</key>
    <dict>
    <key>AddProperties</key>
    <array>
    <dict>
    <key>Device</key>
    <string>IntelGFX</string>
    <key>Disabled</key>
    <false/>
    <key>Key</key>
    <string>AAPL,GfxYTile</string>
    <key>Value</key>
    <data>
    CqqqAA==
    </data>
    </dict>
    </array>
    <key>Audio</key>
    <dict>
    <key>Inject</key>
    <string>11</string>
    <key>ResetHDA</key>
    <true/>
    </dict>
    <key>USB</key>
    <dict>
    <key>AddClockID</key>
    <true/>
    <key>FixOwnership</key>
    <true/>
    <key>Inject</key>
    <true/>
    </dict>
    </dict>
    <key>GUI</key>
    <dict>
    <key>Mouse</key>
    <dict>
    <key>DoubleClick</key>
    <integer>500</integer>
    <key>Enabled</key>
    <false/>
    <key>Mirror</key>
    <false/>
    <key>Speed</key>
    <integer>8</integer>
    </dict>
    <key>ScreenResolution</key>
    <string>1280x1024</string>
    <key>Theme</key>
    <string>embedded</string>
    </dict>
    <key>Graphics</key>
    <dict>
    <key>EDID</key>
    <dict>
    <key>Inject</key>
    <false/>
    </dict>
    <key>Inject</key>
    <dict>
    <key>ATI</key>
    <false/>
    <key>Intel</key>
    <false/>
    <key>NVidia</key>
    <false/>
    </dict>
    <key>NvidiaSingle</key>
    <false/>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
    <key>AppleIntelCPUPM</key>
    <true/>
    <key>AppleRTC</key>
    <true/>
    <key>Debug</key>
    <false/>
    <key>DellSMBIOSPatch</key>
    <false/>
    <key>KernelCpu</key>
    <false/>
    <key>KernelHaswellE</key>
    <false/>
    <key>KernelLapic</key>
    <false/>
    <key>KernelPm</key>
    <true/>
    <key>KextsToPatch</key>
    <array>
    <dict>
    <key>Comment</key>
    <string>External Drives as Internal to fix Orange Icons</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    RXh0ZXJuYWw=
    </data>
    <key>Name</key>
    <string>AppleAHCIPort</string>
    <key>Replace</key>
    <data>
    SW50ZXJuYWw=
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>(c)Pike R. Alpha</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    Ym9hcmQtaWQ=
    </data>
    <key>Name</key>
    <string>AppleGraphicsDevicePolicy</string>
    <key>Replace</key>
    <data>
    Ym9hcmQtaXg=
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>change 15 port limit to 26</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    g710////EA==
    </data>
    <key>MatchOS</key>
    <string>10.12.x</string>
    <key>Name</key>
    <string>AppleUSBXHCIPCI</string>
    <key>Replace</key>
    <data>
    g710////Gw==
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>change 15 port limit to 26</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    g72M/v//EA==
    </data>
    <key>MatchOS</key>
    <string>10.11.x</string>
    <key>Name</key>
    <string>AppleUSBXHCIPCI</string>
    <key>Replace</key>
    <data>
    g72M/v//Gw==
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>change 15 port limit to 26 in XHCI kext (100-series)</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    g710////EA==
    </data>
    <key>MatchOS</key>
    <string>10.12.x</string>
    <key>Name</key>
    <string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
    <key>Replace</key>
    <data>
    g710////Gw==
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>change 15 port limit to 30 in XHCI kext (200-series)</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    g710////EA==
    </data>
    <key>MatchOS</key>
    <string>10.12.x</string>
    <key>Name</key>
    <string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
    <key>Replace</key>
    <data>
    g710////Hw==
    </data>
    </dict>
    </array>
    </dict>
    <key>RtVariables</key>
    <dict>
    <key>BooterConfig</key>
    <string>0x28</string>
    <key>CsrActiveConfig</key>
    <string>0x67</string>
    <key>MLB</key>
    <string>C02032109R5DC771H</string>
    <key>ROM</key>
    <string>UseMacAddr0</string>
    </dict>
    <key>SMBIOS</key>
    <dict>
    <key>BiosReleaseDate</key>
    <string>08/08/2017</string>
    <key>BiosVendor</key>
    <string>Apple Inc.</string>
    <key>BiosVersion</key>
    <string>IM183.88Z.0151.B00.1708080034</string>
    <key>Board-ID</key>
    <string>Mac-77F17D7DA9285301</string>
    <key>BoardManufacturer</key>
    <string>Apple Inc.</string>
    <key>BoardSerialNumber</key>
    <string>C027315014NDNJKJC</string>
    <key>BoardType</key>
    <integer>10</integer>
    <key>BoardVersion</key>
    <string>iMac18,2</string>
    <key>ChassisAssetTag</key>
    <string>iMac-Aluminum</string>
    <key>ChassisManufacturer</key>
    <string>Apple Inc.</string>
    <key>ChassisType</key>
    <string>0x09</string>
    <key>Family</key>
    <string>iMac</string>
    <key>FirmwareFeatures</key>
    <string>0xFC0FE136</string>
    <key>FirmwareFeaturesMask</key>
    <string>0xFF1FFF3F</string>
    <key>LocationInChassis</key>
    <string>Part Component</string>
    <key>Manufacturer</key>
    <string>Apple Inc.</string>
    <key>Mobile</key>
    <false/>
    <key>PlatformFeature</key>
    <string>0x00</string>
    <key>ProductName</key>
    <string>iMac18,2</string>
    <key>SerialNumber</key>
    <string>C02V51V8J1G5</string>
    <key>Version</key>
    <string>1.0</string>
    </dict>
    <key>SystemParameters</key>
    <dict>
    <key>InjectKexts</key>
    <string>Yes</string>
    <key>InjectSystemID</key>
    <true/>
    <key>NvidiaWeb</key>
    <true/>
    </dict>
    </dict>
    </plist>
     

    Attached Files:

    Last edited: Oct 9, 2017
  2. mitch_de

    mitch_de

    Joined:
    Mar 3, 2011
    Messages:
    26
    Mobo:
    Gigabyte EP35-DS3
    CPU:
    Intel C2D 7300
    Graphics:
    Nvidia 9600 GT 512MB
    Oct 7, 2017 at 7:50 PM #2
    mitch_de

    mitch_de

    Joined:
    Mar 3, 2011
    Messages:
    26
    Mobo:
    Gigabyte EP35-DS3
    CPU:
    Intel C2D 7300
    Graphics:
    Nvidia 9600 GT 512MB
    Oh dear, gioscreen lock3 also main Problem since High Sierra on Nvidia Pascal cards. Hope you get it fixed.
    Or do you have that problem on Sierra too?
    Perhaps i plan to buy such an RX 560 ...
     
  3. hotbullet79

    hotbullet79

    Joined:
    Jun 20, 2016
    Messages:
    7
    Oct 9, 2017 at 8:39 AM #3
    hotbullet79

    hotbullet79

    Joined:
    Jun 20, 2016
    Messages:
    7
    hi i have same problem on both
     
  4. CrashMidnick

    CrashMidnick

    Joined:
    Dec 15, 2015
    Messages:
    180
    Mobo:
    MSI Z270 M7
    CPU:
    Kaby Lake 7700k
    Graphics:
    GTX 1070
    Mobile Phone:
    iOS
    Oct 9, 2017 at 8:47 AM #4
    CrashMidnick

    CrashMidnick

    Joined:
    Dec 15, 2015
    Messages:
    180
    Mobo:
    MSI Z270 M7
    CPU:
    Kaby Lake 7700k
    Graphics:
    GTX 1070
    Mobile Phone:
    iOS
    hotbullet79 : add your specs in your profile as per forum's rules

    For your problem, did you add lilu.kext + whatevergreen.kext in your "other" folder in clover ? They are required for your graphic card.
     
  5. hotbullet79

    hotbullet79

    Joined:
    Jun 20, 2016
    Messages:
    7
    Oct 9, 2017 at 9:11 AM #5
    hotbullet79

    hotbullet79

    Joined:
    Jun 20, 2016
    Messages:
    7
    Hi CrashMidnick i am not sure is it because of the card brand HIS ? yes i have both the kext in my other folders.

    for my HIS RX560 Green 4 GB RAM

    the system reports detects as
    Vendor: ATI (0x1002)
    Device ID: 0x67ff
    Revision ID: 0x00cf
    EFI Driver Version: WEAR-104-2017-08-27

    i am not getting any picture out of it if i use igp as first boot device.

    my igpu is hd630

    if i use pcie i get gioscreen lock3 and system keeps restart.
    what should i do?

    thanks.
     
  6. CrashMidnick

    CrashMidnick

    Joined:
    Dec 15, 2015
    Messages:
    180
    Mobo:
    MSI Z270 M7
    CPU:
    Kaby Lake 7700k
    Graphics:
    GTX 1070
    Mobile Phone:
    iOS
    Oct 9, 2017 at 1:50 PM #6
    CrashMidnick

    CrashMidnick

    Joined:
    Dec 15, 2015
    Messages:
    180
    Mobo:
    MSI Z270 M7
    CPU:
    Kaby Lake 7700k
    Graphics:
    GTX 1070
    Mobile Phone:
    iOS
    You need to disable your iGPU in your bios, so only PEG/PCIe is activated.
    Check your config.plist that nothing is injected (nvidia, intel...).

    Again, please update your specs, we are blind.
     
  7. CrashMidnick

    CrashMidnick

    Joined:
    Dec 15, 2015
    Messages:
    180
    Mobo:
    MSI Z270 M7
    CPU:
    Kaby Lake 7700k
    Graphics:
    GTX 1070
    Mobile Phone:
    iOS
    Oct 9, 2017 at 2:39 PM #7
    CrashMidnick

    CrashMidnick

    Joined:
    Dec 15, 2015
    Messages:
    180
    Mobo:
    MSI Z270 M7
    CPU:
    Kaby Lake 7700k
    Graphics:
    GTX 1070
    Mobile Phone:
    iOS
    You NEED to update your PROFILE, NOT YOUR FIRST POST.

    You are injecting too many things and set inject intel and nvdiaweb to false as advised before. It will never work with an AMD card and iGPU disabled.
     

Share This Page