Contribute
Register

RX 6600 XT: Henbury framebuffer and Zero RPM in Monterey 12.3

Joined
May 22, 2011
Messages
882
Motherboard
GA-Z370N-WiFi
CPU
i7-8700
Graphics
RX 6800
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
If you are talking about the patch, there are 4 properties (@x,name) each of them for each of the 4 ports available in the GPU. So all of them are required, to set the framebuffer for all ports.

Gotcha - thank you for clarifying.
As you can tell - I'm not an expert on any of this (not even remotely close)
:wave:
 
Joined
May 11, 2010
Messages
136
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
Core i7-7700K
Graphics
XFX SWFT 210 RX 6600 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Weirdly, I had the opposite problem with my card--after the first couple of times I booted my system post-install the fans defaulted to maximum speed and wouldn't slow down even though the GPU temperature was only showing up as 40C.

The fan speed was also maxed out in Windows, although I haven't installed the full Radeon software package yet, just the automatically downloaded drivers.

Applying the Henbury patch brought the fans back under control. Has anyone else seen similar behavior with AMD fan speeds getting maxed out?

(Using OC 0.8.0, I was switching a couple of SSDTs in and out, but I'm back to just the default SSDT-PLUG and SSDT-EC-USBX now.)
 
Joined
Dec 10, 2010
Messages
1,027
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 6600 XT
Mobile Phone
  1. iOS
@darukaru
NO, I haven’t seen this behaviour before. It seems that your AMD is set to spin fans all the time at maximum. It can be a hardware defect.
There is another thread about this card and Zero RPM
 
Joined
Dec 14, 2011
Messages
11
Motherboard
Asus Z590 Prime-A
CPU
i7-11700
Graphics
RX 6900 XT
Mac
  1. Mac Pro
@darukaru
NO, I haven’t seen this behaviour before. It seems that your AMD is set to spin fans all the time at maximum. It can be a hardware defect.
There is another thread about this card and Zero RPM
Can you please help me with my Asrock RX 6900 XT - I am sending my EFI that a edited with SoftPowerPlayTable and no luck - I am on Monterey 12.6 - Opencore 0.8.4

Asus Z590 Prime-A - Intel Core i7-11700 - Asrock RX 6900 XT
 

Attachments

  • EFI.zip
    15.7 MB · Views: 23
  • PP_PhmSoftPowerPlayTable.txt
    195 KB · Views: 8
Last edited:
Joined
Dec 10, 2010
Messages
1,027
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 6600 XT
Mobile Phone
  1. iOS
@sonojo
Good night. I’m not at home. I’ll review your EFI. What is not working? Black screen at desktop?
 
Joined
Dec 14, 2011
Messages
11
Motherboard
Asus Z590 Prime-A
CPU
i7-11700
Graphics
RX 6900 XT
Mac
  1. Mac Pro
@sonojo
Good night. I’m not at home. I’ll review your EFI. What is not working? Black screen at desktop?
After I sent you this message I said to my self ''Hackintosh is not for the lazy one'' and I read again your topic about the framebuffer and I removed the SoftPowerPlayTable (I was having Black screen) and left only the framebuffer patch, because I was trying both at once in my EFI. After I reboot I looked at the temperature and saw 35ºC in the GPU and the fan was working. I applied the patch with ''framebuffer: ATY,Belknap''. I would like to thank you for your attention and say the the patch is working 100%, even on the Mac Os VENTURA BETA 8 (22A5352e).
 
Joined
Dec 10, 2010
Messages
1,027
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 6600 XT
Mobile Phone
  1. iOS
@sonojo
That's correct. sPPT or patch. Not both.
The path is easier to apply and it works fine choosing the right framebuffer.
The long string is harder to get and apply.

Btw, I have built the OpenCore sPPT string from the uploaded PP_PhmSoftPowerPlayTable.txt file and the result doesn't match exactly the string that you have added to config.plist. There are 2 different characters. I attach the value I got just in case that you want to try this string to see if it works fine.

But having the framebuffer patch is okey.
 

Attachments

  • config.plist
    3.7 KB · Views: 29
  • PP_PhmSoftPowerPlayTable.txt
    4.8 KB · Views: 15
Joined
Dec 14, 2011
Messages
11
Motherboard
Asus Z590 Prime-A
CPU
i7-11700
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Unfortunately with OpenCore sPPT you sent I'm still having black screen, I will stick with framebuffer.

THANKS!!!!
 
Top