Contribute
Register

RX 580 No signal at wake / No input in DPCIManager

Joined
Mar 10, 2013
Messages
24
Motherboard
ASUS Maximus VIII Hero
CPU
i7 6700K
Graphics
GTX 1080 Ti
Mac
MacBook Pro
Mobile Phone
iOS
Hi everyone!

I have just switched from GTX 1080Ti to RX 580 to use Mojave and Catalina and everything else seems to be working fine except for Sleep / Wake and I am stumped.

Hardware:
ASUS Z170 Maximus Hero VIII
Intel i7 6700K
AMD RX 580 Sapphire Nitro+ 4GB
Kingston HyperX 16GB DDR4 RAM

I am on latest Mojave (10.14.6) and using iMac 14,2 SMBIOS.

I have mostly followed Stork's guide from here: https://www.tonymacx86.com/threads/...70-maximus-viii-hero-i7-6700k-gtx-980.197284/ to get everything set up and I am able to get display on 3 monitors that I have connected (2x DP + 1x HDMI) and everything else seems to be working fine.

However, as soon as I want to wake them from sleep, they all light up like the signal is provided for a second, then there is no signal to either of monitors and the system seemingly freezes (I was unable to use Teamviewer to connect to it afterwards). Btw. I am not able to use reset button to reboot, only holding power button for a few seconds will work.

I have tried using WhateverGreen + Lilu kexts, injecting Framebuffer and device ID manually or even not injecting nothing and no kexts. Also tried with IGPU switched to off and on in BIOS and the result are always the same :(

What is curious is that I have no output in DCPIManager whatsoever for the AMD GPU, see the attached screenshot:
Screenshot 2019-08-19 at 21.38.33.png


I am also attaching my EFI Folder, please let me know if you need anything else to debug this problem.

If anyone has any idea what else I can try to fix Sleep / Wake on this card I'll be very grateful! :)
 

Attachments

Top